]> git.pld-linux.org Git - packages/crossdjgpp-platform.git/blob - crossdjgpp-platform.spec
- tabs in preamble
[packages/crossdjgpp-platform.git] / crossdjgpp-platform.spec
1 Summary:        DJGPP GNU Binary Utility Development Utilities - libraries
2 Summary(pl.UTF-8):      Narzędzia programistyczne GNU DJGPP - biblioteki
3 Name:           crossdjgpp-platform
4 Version:        203
5 Release:        2
6 Epoch:          1
7 License:        GPL
8 Group:          Development/Libraries
9 URL:            http://www.delorie.com/djgpp/
10 Source0:        http://www.delorie.com/pub/djgpp/current/v2/djcrx%{version}.zip
11 # Source0-md5:  dbaceb26365a14e702f2e1c9def16afc
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13 BuildRequires:  unzip
14 PreReq:         fix-info-dir
15
16 %define         target          i386-pc-msdosdjgpp
17 %define         arch            %{_prefix}/%{target}
18 %define         no_install_post_strip   1
19
20 %description
21 DJGPP is a port of GNU GCC to the DOS environment. (It stands for DJ's
22 Gnu Programming Platform, if it has to stand for something, but it's
23 best left ambiguous.)
24
25 This package contains DOS API includes and libraries.
26
27 %description -l pl.UTF-8
28 DJGPP to port GNU GCC dla środowiska DOS (skrót oznacza DJ's Gnu
29 Programming Platform, jeśli już koniecznie ma coś oznaczać).
30
31 Ten pakiet zawiera pliki nagłówkowe i biblioteki DOS API.
32
33 %prep
34 %setup -q -c -T -n djcrx-%{version}
35 unzip -a %{SOURCE0} > /dev/null
36
37 %build
38 %{__cc} %{rpmcflags} -o stubify src/stub/stubify.c
39 %{__cc} %{rpmcflags} -o stubedit src/stub/stubedit.c
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 install -d $RPM_BUILD_ROOT{%{_infodir},%{arch}/{include,lib,bin},%{_bindir}}
45 cp -fa include/* $RPM_BUILD_ROOT%{arch}/include
46 cp -fa lib/* $RPM_BUILD_ROOT%{arch}/lib
47 # required by linker... strange
48 ln -sf ../lib/djgpp.djl $RPM_BUILD_ROOT%{arch}/bin
49
50 ( cat <<EOF
51 This is foobarbaz.
52
53 INFO-DIR-SECTION Libraries:
54 START-INFO-DIR-ENTRY
55 * DJGPP Libc: (djgpp-libc)              Libc for cross-djgpp
56 END-INFO-DIR-ENTRY
57 EOF
58   cat info/libc.info ) | \
59         sed -e 's/libc\.info/djgpp-libc.info/g' \
60                 > $RPM_BUILD_ROOT%{_infodir}/djgpp-libc.info
61
62 install stubify stubedit $RPM_BUILD_ROOT%{_bindir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
69
70 %postun
71 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
72
73 %files
74 %defattr(644,root,root,755)
75 %{arch}
76 %{_infodir}/*
77 %attr(755,root,root) %{_bindir}/*
This page took 0.041256 seconds and 3 git commands to generate.