]> git.pld-linux.org Git - packages/crossdjgpp-binutils.git/blob - crossdjgpp-binutils.spec
c4115ba0241e39e34f2fc49654d66cd756a6796f
[packages/crossdjgpp-binutils.git] / crossdjgpp-binutils.spec
1 Summary:        DJGPP GNU Binary Utility Development Utilities - binutils
2 Summary(pl):    Narzêdzia programistyczne GNU DJGPP - binutils
3 Name:           crossdjgpp-binutils
4 Version:        2.11.90.0.19
5 Release:        1
6 License:        GPL
7 Group:          Development/Tools
8 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
9 # Source0-md5:  59cb6db4b7642562b5abb3298a25b063
10 BuildRequires:  flex
11 BuildRequires:  bison
12 BuildRequires:  /bin/bash
13 Requires:       crossdjgpp-platform
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         target          i386-pc-msdosdjgpp
17 %define         arch            %{_prefix}/%{target}
18
19 %description
20 DJGPP is a port of GNU GCC to the DOS environment. (It stands for DJ's
21 Gnu Programming Platform, if it has to stand for something, but it's
22 best left ambiguous.)
23
24 This package contains cross targeted binutils.
25
26 %description -l pl
27 DJGPP to port GNU GCC dla ¶rodowiska DOS (skrót oznacza DJ's Gnu
28 Programming Platform, je¶li ju¿ koniecznie ma co¶ oznaczaæ).
29
30 Ten pakiet zawiera binutils skompilowane do kompilacji skro¶nej.
31
32 %prep
33 %setup -q -n binutils-%{version}
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # Because of a bug in binutils-2.9.1, a cross libbfd.so* is not named
39 # lib<target>bfd.so*. To prevent confusion with native binutils, we
40 # forget about shared libraries right now, and do not install libbfd.a
41 # [the same applies to binutils 2.10.1.0.4]
42
43 # ldscripts won't be generated properly if SHELL is not bash...
44 CFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
45 CONFIG_SHELL="/bin/bash" \
46 ./configure \
47         --prefix=%{_prefix} \
48         --libdir=%{_libdir} \
49         --mandir=%{_mandir} \
50         --infodir=%{_infodir} \
51         --target=%{target}
52
53 %{__make} tooldir=%{_prefix} EXEEXT="" all
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         prefix=$RPM_BUILD_ROOT%{_prefix} \
60         mandir=$RPM_BUILD_ROOT%{_mandir} \
61         infodir=$RPM_BUILD_ROOT%{_infodir} \
62         libdir=$RPM_BUILD_ROOT%{_libdir}
63
64 %files
65 %defattr(644,root,root,755)
66 %attr(755,root,root) %{arch}/bin/*
67 %{arch}/lib/*
68 %attr(755,root,root) %{_bindir}/%{target}-*
69 %{_mandir}/man1/%{target}-*
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
This page took 0.046898 seconds and 3 git commands to generate.