]> git.pld-linux.org Git - packages/crossavr-gdb.git/blob - crossavr-gdb.spec
- updated for 6.3
[packages/crossavr-gdb.git] / crossavr-gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen
3 Summary(es):    Depurador de programas C y otras lenguajes
4 Summary(fr):    Débugger symbolique pour C et d'autres langages
5 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
6 Summary(pt_BR): Depurador de programas C e outras linguagens
7 Summary(ru):    óÉÍ×ÏÌÉÞÅÓËÉÊ ÏÔÌÁÄÞÉË ÄÌÑ C É ÄÒÕÇÉÈ ÑÚÙËÏ×
8 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
9 Summary(uk):    óÉÍ×ÏÌØÎÉʠצÄÌÁÄÞÉË ÄÌÑ ó ÔÁ ¦ÎÛÉÈ ÍÏ×
10 Summary(zh_CN): [¿ª·¢]CºÍÆäËûÓïÑԵĵ÷ÊÔÆ÷
11 Summary(zh_TW): [.-A¶}µo]C©M.$)B¨ä.-A¥L»y.$)B¨¥ªº½Õ¸Õ¾¹
12 Name:           crossavr-gdb
13 Version:        6.2.1
14 Release:        0.1
15 License:        GPL
16 Group:          Development/Debuggers
17 Source0:        ftp://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
18 # Source0-md5:  3b3898cfd426e1acd5efc89560aa93ba
19 Patch0:         gdb-ncurses.patch
20 Patch1:         gdb-readline.patch
21 Patch2:         gdb-info.patch
22 Patch3:         gdb-passflags.patch
23 Patch4:         gdb-headers.patch
24 BuildRequires:  XFree86-devel
25 BuildRequires:  autoconf >= 2.53
26 BuildRequires:  automake
27 BuildRequires:  libtool
28 BuildRequires:  ncurses-devel >= 5.2
29 BuildRequires:  readline-devel >= 4.2
30 BuildRoot:      %{tmpdir}/gdb-%{version}-root-%(id -u -n)
31
32 %define         target          avr
33
34 %description
35 Gdb is a full featured, command driven debugger. Gdb allows you to
36 trace the execution of programs and examine their internal state at
37 any time. Gdb works for C and C++ compiled with the GNU C compiler
38 gcc.
39
40 %description -l de
41 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
42 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
43 kompiliertes C++.
44
45 %description -l es
46 Este es un debugger orientado a comandos repleto de características.
47 Te permite rastrear la ejecución de programas y examinar su estado
48 interno a cualquier momento. Funciona para C y C++ compilado con el
49 compilador GNU C.
50
51 %description -l fr
52 Débugger complet, piloté par commandes. Permet de tracer l'exécution
53 des programmes et d'examiner à tout moment leur état interne.
54 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
55 de GNU, gcc.
56
57 %description -l pl
58 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
59 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
60 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
61 przy pomocy kompilatora GNU (gcc).
62
63 %description -l pt_BR
64 Este é um debugger orientado a comandos repleto de características.
65 Ele permite à você rastrear a execução de programas e examinar o seu
66 estado interno a qualquer momento. Ele funciona para para C e C++
67 compilado com o compilador GNU C.
68
69 %description -l ru
70 üÔÏ ÐÏÌÎÏÃÅÎÎÙÊ ÏÔÌÁÄÞÉË, ÕÐÒÁ×ÌÑÅÍÙÊ ËÏÍÁÎÄÁÍÉ. ïΠÐÏÚ×ÏÌÑÅÔ
71 ÔÒÁÓÓÉÒÏ×ÁÔØ ÉÓÐÏÌÎÅÎÉÅ ÐÒÏÇÒÁÍÍ É ÉÚÕÞÁÔØ ÉÈ ×ÎÕÔÒÅÎÎÅÅ ÓÏÓÔÏÑÎÉÅ ×
72 ÌÀÂÏÊ ÍÏÍÅÎÔ ×ÒÅÍÅÎÉ. òÁÂÏÔÁÅÔ Ó ÐÒÏÇÒÁÍÍÁÍÉ ÎÁ C É C++,
73 ÓËÏÍÐÉÌÉÒÏ×ÁÎÎÙÍÉ GNU ËÏÍÐÉÌÑÔÏÒÏÍ C (gcc, egcs, pgcc).
74
75 %description -l tr
76 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
77 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
78 verir.
79
80 %description -l uk
81 ãÅ ÐÏ×ÎÏæÎÎÉʠצÄÌÁÄÞÉË, ÝÏ ËÅÒÕ¤ÔØÓÑ ËÏÍÁÎÄÁÍÉ. ÷¦Î ÄÏÚ×ÏÌѤ
82 ÔÒÁÓÕ×ÁÔÉ ×ÉËÏÎÁÎÎÑ ÐÒÏÇÒÁÍ ÔÁ ×É×ÞÁÔÉ §È ×ÎÕÔÒ¦ÛΦʠÓÔÁΠנÄÏצÌØÎÉÊ
83 ÍÏÍÅÎÔ ÞÁÓÕ. ðÒÁÃÀ¤ Ú ÐÒÏÇÒÁÍÁÍÉ ÎÁ C ÔÁ C++, ÚËÏÍЦÌØÏ×ÁÎÉÍÉ
84 ËÏÍЦÌÑÔÏÒÁÍÉ GNU C (gcc, egcs, pgcc).
85
86 %prep
87 %setup -q -n gdb-%{version}
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 %patch4 -p1
93
94 %build
95 for dir in `find gdb/ -name 'configure.in'`; do
96         dir=$(dirname "$dir")
97         olddir=$(pwd)
98         cd $dir
99         %{__aclocal}
100         %{__autoconf}
101         cd $olddir
102 done
103 cp -f /usr/share/automake/config.* .
104 # !! Don't enable shared here !!
105 # This will cause serious problems --misiek
106 %configure2_13 \
107         --target=%{target} \
108         --disable-shared \
109         --enable-nls \
110         --without-included-gettext \
111         --without-included-regex \
112         --enable-gdcli \
113         --enable-gdbmi \
114         --enable-multi-ice \
115         --enable-netrom \
116         --with-cpu=%{_target_cpu} \
117         --enable-tui \
118 %ifnarch alpha
119         --with-mmalloc
120 %endif
121
122 # something is wrong after above - e.g. $exeext=="no" - fix it:
123 cd gdb
124 %configure \
125         --target=%{target}
126 cd ..
127
128 %{__make}
129 %{__make} info
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT%{_infodir}
134
135 %{__make} install \
136         prefix=$RPM_BUILD_ROOT%{_prefix} \
137         bindir=$RPM_BUILD_ROOT%{_bindir} \
138         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
139         infodir=$RPM_BUILD_ROOT%{_infodir} \
140         includedir=$RPM_BUILD_ROOT%{_includedir} \
141         libdir=$RPM_BUILD_ROOT%{_libdir} \
142         mandir=$RPM_BUILD_ROOT%{_mandir}
143
144 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/%{target}-gdb*
152 %{_mandir}/man1/%{target}-gdb*.1*
This page took 0.109307 seconds and 3 git commands to generate.