]> git.pld-linux.org Git - packages/crossavr-gcc.git/blob - crossavr-gcc.spec
97234f69a10520fe7ccc04cd41189389905f79ce
[packages/crossavr-gcc.git] / crossavr-gcc.spec
1 Summary:        Cross AVR GNU binary utility development utilities - gcc
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - AVR gcc
3 Summary(fr):    Utilitaires de développement binaire de GNU - AVR gcc
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla AVR - gcc
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - AVR gcc
6 Summary(tr):    GNU geliþtirme araçlarý - AVR gcc
7 Name:           crossavr-gcc
8 Version:        3.3.2
9 Release:        2
10 Epoch:          1
11 License:        GPL
12 Group:          Development/Languages
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
14 # Source0-md5:  65999f654102f5438ac8562d13a6eced
15 BuildRequires:  autoconf
16 BuildRequires:  /bin/bash
17 BuildRequires:  bison
18 BuildRequires:  crossavr-binutils
19 BuildRequires:  flex
20 Requires:       crossavr-binutils
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         target          avr
24 %define         arch            %{_prefix}/%{target}
25 %define         gccarch         %{_prefix}/lib/gcc-lib/%{target}
26 %define         gcclib          %{_prefix}/lib/gcc-lib/%{target}/%{version}
27 %define         no_install_post_strip   1
28
29 %description
30 This package contains a cross-gcc which allows the creation of
31 binaries to be run on Atmel AVR on i386-machines.
32
33 %description -l de
34 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
35 i386-Rechner Code für Atmel AVR zu generieren.
36
37 %description -l pl
38 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na maszynach
39 i386 binariów do uruchamiania na Atmel AVR.
40
41 %package c++
42 Summary:        C++ support for avr-gcc
43 Summary(pl):    Obs³uga C++ dla avr-gcc
44 Group:          Development/Languages
45 Requires:       crossavr-gcc = %{epoch}:%{version}
46
47 %description c++
48 This package adds C++ support to the GNU Compiler Collection for AVR.
49
50 %description c++ -l pl
51 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc dla AVR.
52
53 %prep
54 %setup -q -n gcc-%{version}
55
56 %build
57 rm -rf obj-%{target}
58 install -d obj-%{target}
59 cd obj-%{target}
60
61 CFLAGS="%{rpmcflags}" \
62 CXXFLAGS="%{rpmcflags}" \
63 TEXCONFIG=false \
64 ../configure \
65         --prefix=%{_prefix} \
66         --infodir=%{_infodir} \
67         --mandir=%{_mandir} \
68         --disable-shared \
69         --enable-languages="c,c++" \
70         --enable-long-long \
71         --with-gnu-as \
72         --with-gnu-ld \
73         --with-system-zlib \
74         --with-multilib \
75         --without-x \
76         --target=%{target}
77
78 PATH=$PATH:/sbin:%{_sbindir}
79
80 cd ..
81 #LDFLAGS_FOR_TARGET="%{rpmldflags}"
82
83 %{__make} -C obj-%{target}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_bindir},%{gcclib}}
88
89 cd obj-%{target}
90 PATH=$PATH:/sbin:%{_sbindir}
91
92 %{__make} -C gcc install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # c++filt is provided by binutils
96 #rm -f $RPM_BUILD_ROOT%{_bindir}/i386-mipsel-c++filt
97
98 # what is this there for???
99 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
100
101 # the same... make hardlink
102 #ln -f $RPM_BUILD_ROOT%{arch}/bin/gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
103
104 %{target}-strip -g $RPM_BUILD_ROOT%{gcclib}/libgcc.a
105
106 #%find_lang %{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files 
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_bindir}/%{target}-gcc*
114 %attr(755,root,root) %{_bindir}/%{target}-cpp
115 %attr(755,root,root) %{_bindir}/%{target}-gcov
116 %dir %{gccarch}
117 %dir %{gcclib}
118 %attr(755,root,root) %{gcclib}/cc1
119 #%attr(755,root,root) %{gcclib}/tradcpp0
120 #%attr(755,root,root) %{gcclib}/cpp0
121 %attr(755,root,root) %{gcclib}/collect2
122 %{gcclib}/libgcc.a
123 %{gcclib}/specs*
124 %{gcclib}/%{target}*
125 %dir %{gcclib}/include
126 %{gcclib}/include/*.h
127 %{_mandir}/man1/%{target}-gcc.1*
128
129 %files c++
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/%{target}-g++
132 %attr(755,root,root) %{_bindir}/%{target}-c++
133 %attr(755,root,root) %{gcclib}/cc1plus
134 %{_mandir}/man1/%{target}-g++.1*
This page took 0.038358 seconds and 3 git commands to generate.