]> git.pld-linux.org Git - packages/crossavr-gcc.git/blob - crossavr-gcc.spec
67121197bfd5161aae038e51d0c9ea714a69e86f
[packages/crossavr-gcc.git] / crossavr-gcc.spec
1 Summary:        Cross AVR GNU binary utility development utilities - gcc
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - AVR gcc
3 Summary(fr):    Utilitaires de développement binaire de GNU - AVR gcc
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla AVR - gcc
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - AVR gcc
6 Summary(tr):    GNU geliþtirme araçlarý - AVR gcc
7 Name:           crossavr-gcc
8 Version:        3.4.0
9 Release:        1
10 Epoch:          1
11 License:        GPL
12 Group:          Development/Languages
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
14 # Source0-md5:  85c6fc83d51be0fbb4f8205accbaff59
15 BuildRequires:  autoconf
16 BuildRequires:  /bin/bash
17 BuildRequires:  bison
18 BuildRequires:  crossavr-binutils
19 BuildRequires:  flex
20 Requires:       crossavr-binutils
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         target          avr
24 %define         arch            %{_prefix}/%{target}
25 %define         gccarch         %{_libdir}/gcc/%{target}
26 %define         gcclib          %{_libdir}/gcc/%{target}/%{version}
27 %define         no_install_post_strip   1
28
29 %description
30 This package contains a cross-gcc which allows the creation of
31 binaries to be run on Atmel AVR on i386-machines.
32
33 %description -l de
34 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
35 i386-Rechner Code für Atmel AVR zu generieren.
36
37 %description -l pl
38 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na maszynach
39 i386 binariów do uruchamiania na Atmel AVR.
40
41 %package c++
42 Summary:        C++ support for avr-gcc
43 Summary(pl):    Obs³uga C++ dla avr-gcc
44 Group:          Development/Languages
45 Requires:       crossavr-gcc = %{epoch}:%{version}-%{release}
46
47 %description c++
48 This package adds C++ support to the GNU Compiler Collection for AVR.
49
50 %description c++ -l pl
51 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc dla AVR.
52
53 %prep
54 %setup -q -n gcc-%{version}
55
56 %build
57 rm -rf obj-%{target}
58 install -d obj-%{target}
59 cd obj-%{target}
60
61 CFLAGS="%{rpmcflags}" \
62 CXXFLAGS="%{rpmcflags}" \
63 TEXCONFIG=false \
64 ../configure \
65         --prefix=%{_prefix} \
66         --infodir=%{_infodir} \
67         --mandir=%{_mandir} \
68         --bindir=%{_bindir} \
69         --libdir=%{_libdir} \
70         --libexecdir=%{_libdir} \
71         --disable-shared \
72         --enable-languages="c,c++" \
73         --enable-long-long \
74         --with-gnu-as \
75         --with-gnu-ld \
76         --with-system-zlib \
77         --with-multilib \
78         --without-x \
79         --target=%{target}
80
81 PATH=$PATH:/sbin:%{_sbindir}
82
83 cd ..
84 #LDFLAGS_FOR_TARGET="%{rpmldflags}"
85
86 %{__make} -C obj-%{target}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_bindir},%{gcclib}}
91
92 cd obj-%{target}
93 PATH=$PATH:/sbin:%{_sbindir}
94
95 %{__make} -C gcc install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %if 0%{!?debug:1}
99 # strip native binaries
100 strip -R .comment -R .note \
101         `echo $RPM_BUILD_ROOT%{_bindir}/* | grep -v gccbug` \
102         $RPM_BUILD_ROOT%{gcclib}/{cc1*,collect2}
103
104 # strip target libraries
105 %{target}-strip -g $RPM_BUILD_ROOT%{gcclib}{,/avr*}/libg*.a
106 %endif
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files 
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_bindir}/%{target}-gcc*
114 %attr(755,root,root) %{_bindir}/%{target}-cpp
115 %attr(755,root,root) %{_bindir}/%{target}-gcov
116 %dir %{gccarch}
117 %dir %{gcclib}
118 %attr(755,root,root) %{gcclib}/cc1
119 %attr(755,root,root) %{gcclib}/collect2
120 %{gcclib}/libg*.a
121 %{gcclib}/specs
122 %{gcclib}/%{target}*
123 %dir %{gcclib}/include
124 %{gcclib}/include/*.h
125 %{_mandir}/man1/%{target}-cpp.1*
126 %{_mandir}/man1/%{target}-gcc.1*
127 %{_mandir}/man1/%{target}-gcov.1*
128
129 %files c++
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/%{target}-g++
132 %attr(755,root,root) %{_bindir}/%{target}-c++
133 %attr(755,root,root) %{gcclib}/cc1plus
134 %{_mandir}/man1/%{target}-g++.1*
This page took 0.069776 seconds and 3 git commands to generate.