]> git.pld-linux.org Git - packages/crossarm-binutils.git/blob - crossarm-binutils.spec
6205216355624210dbc4fe9f67d77e77e9e71982
[packages/crossarm-binutils.git] / crossarm-binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     eabi            # build with Embedded ABI support
4 #
5 Summary:        Cross ARM GNU binary utility development utilities - binutils
6 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - ARM binutils
7 Summary(fr):    Utilitaires de développement binaire de GNU - ARM binutils
8 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla ARM - binutils
9 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - ARM binutils
10 Summary(tr):    GNU geliþtirme araçlarý - ARM binutils
11 Name:           crossarm-binutils
12 Version:        2.16.90.0.1
13 Release:        1%{?with_eabi:eabi}
14 License:        GPL
15 Group:          Development/Tools
16 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
17 # Source0-md5:  b231856d84a6181572b0b3371cfc6843
18 Patch0:         binutils-needed.patch
19 Patch1:         binutils-pr815.patch
20 Patch2:         binutils-pr872.patch
21 URL:            http://sources.redhat.com/binutils/
22 BuildRequires:  automake
23 BuildRequires:  bash
24 BuildRequires:  bison
25 BuildRequires:  flex
26 %{?with_eabi:Provides:  crossarm-binutils(eabi)}
27 ExcludeArch:    arm
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         target          arm-linux%{?with_eabi:-eabi}
31 %define         arch            %{_prefix}/%{target}
32 %define         specflags       -Wno-error
33
34 %description
35 Binutils is a collection of binary utilities, including:
36 - ar - create, modify and extract from archives,
37 - nm - lists symbols from object files,
38 - objcopy - copy and translate object files,
39 - objdump - display information from object files,
40 - ranlib - generate an index for the contents of an archive,
41 - size - list the section sizes of an object or archive file,
42 - strings - list printable strings from files,
43 - strip - discard symbols,
44 - c++filt - a filter for demangling encoded C++ symbols,
45 - addr2line - convert addresses to file and line,
46 - nlmconv - convert object code into an NLM.
47
48 This package contains the cross version for ARM.
49
50 %description -l pl
51 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
52 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
53 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
54 programów i bibliotek.
55
56 Ten pakiet zawiera wersjê skro¶n± generuj±c± kod dla ARM.
57
58 %prep
59 %setup -q -n binutils-%{version}
60 %patch0 -p0
61 %patch1 -p0
62 %patch2 -p0
63
64 %build
65 cp -f /usr/share/automake/config.sub .
66
67 # ldscripts won't be generated properly if SHELL is not bash...
68 CFLAGS="%{rpmcflags}" \
69 LDFLAGS="%{rpmldflags}" \
70 CONFIG_SHELL="/bin/bash" \
71 ./configure \
72         --disable-shared \
73         --disable-nls \
74         --prefix=%{_prefix} \
75         --libdir=%{_libdir} \
76         --mandir=%{_mandir} \
77         --infodir=%{_infodir} \
78         --target=%{target}
79
80 %{__make} all \
81         tooldir=%{_prefix} \
82         EXEEXT=""
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_prefix}
87
88 %{__make} install \
89         prefix=$RPM_BUILD_ROOT%{_prefix} \
90         mandir=$RPM_BUILD_ROOT%{_mandir} \
91         infodir=$RPM_BUILD_ROOT%{_infodir} \
92         libdir=$RPM_BUILD_ROOT%{_libdir}
93
94 # remove these man pages unless we cross-build for win*/netware platforms.
95 # however, this should be done in Makefiles.
96 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc README
104 %attr(755,root,root) %{_bindir}/%{target}-*
105 %dir %{arch}
106 %dir %{arch}/bin
107 %attr(755,root,root) %{arch}/bin/*
108 %dir %{arch}/lib
109 %dir %{arch}/lib/*
110 %{arch}/lib/ldscripts/*
111 %{_mandir}/man?/%{target}-*
This page took 0.098691 seconds and 3 git commands to generate.