]> git.pld-linux.org Git - packages/cronie.git/blob - cronie.spec
adfc0a44cd2dd6107dbece11cfedac7166d8b1d9
[packages/cronie.git] / cronie.spec
1 # TODO
2 # - update paths in manuals (create .in files and send upstream)
3 # - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
4 # - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5 #   Mar  3 09:30:01 ravenous CROND[2528]: 4ÿ
6 #
7 # Conditional build:
8 %bcond_without  inotify         # without inotify support
9 %if "%{pld_release}" == "ac"
10 %bcond_with             selinux         # with SELinux support
11 %bcond_with             audit           # with audit support
12 %else
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  audit           # without audit support
15 %endif
16
17 Summary:        Cron daemon for executing programs at set times
18 Summary(pl.UTF-8):      Demon cron do uruchamiania programów o zadanym czasie
19 Name:           cronie
20 Version:        1.7.1
21 Release:        1
22 License:        MIT and BSD and GPL v2
23 Group:          Daemons
24 Source0:        https://github.com/cronie-crond/cronie/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
25 # Source0-md5:  e7528df4b0d7d59307677da7c82e4f70
26 Source1:        %{name}.init
27 Source3:        cron.sysconfig
28 Source4:        %{name}.crontab
29 Source5:        %{name}.pam
30 Source6:        crond.service
31 Patch0:         inotify-nosys.patch
32 Patch1:         sendmail-path.patch
33 URL:            https://github.com/cronie-crond/cronie/
34 %{?with_audit:BuildRequires:    audit-libs-devel}
35 BuildRequires:  autoconf >= 2.60
36 BuildRequires:  automake
37 BuildRequires:  glibc-devel >= 6:2.21
38 %{?with_selinux:BuildRequires:  libselinux-devel}
39 BuildRequires:  pam-devel
40 BuildRequires:  rpm >= 4.4.9-56
41 BuildRequires:  rpmbuild(macros) >= 1.647
42 Requires(post): fileutils
43 Requires(post,preun):   /sbin/chkconfig
44 Requires(postun):       /usr/sbin/groupdel
45 Requires(pre):  /usr/bin/getgid
46 Requires(pre):  /usr/sbin/groupadd
47 Requires:       /bin/run-parts
48 Requires:       psmisc >= 20.1
49 Requires:       rc-scripts >= 0.4.3.0
50 %if "%{pld_release}" != "ac"
51 Requires(post,preun,postun):    systemd-units >= 38
52 Requires:       systemd-units >= 38}
53 %endif
54 %{?with_inotify:Requires:       uname(release) >= 2.6.13}
55 Provides:       crondaemon
56 Provides:       crontabs = 1.7
57 Provides:       cronjobs
58 Provides:       group(crontab)
59 %if "%{pld_release}" == "th"
60 Provides:       vixie-cron = 4.3-1
61 %endif
62 Obsoletes:      crondaemon
63 Obsoletes:      cronie-systemd < 1.4.8-9
64 Obsoletes:      cronie-upstart < 1.4.12-5
65 Obsoletes:      crontabs
66 Obsoletes:      cronjobs
67 %if "%{pld_release}" == "th"
68 Obsoletes:      vixie-cron < 4.3-1
69 %endif
70 Conflicts:      sysklogd < 1.5.1-2
71 Conflicts:      syslog-ng < 3.6.4-3
72 Conflicts:      rsyslog < 5.10.1-4
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 Cronie contains the standard UNIX daemon crond that runs specified
77 programs at scheduled times and related tools. It is based on the
78 original cron and has security and configuration enhancements like the
79 ability to use PAM and SELinux.
80
81 %description -l pl.UTF-8
82 Cronie zawiera standardowego demona uniksowego crond, uruchamiającego
83 podane programy o zadanym czasie, oraz powiązane narzędzia. Jest
84 oparty na oryginalnym cronie i zawiera rozszerzenia bezpieczeństwa i
85 konfiguracji, takie jak możliwość wykorzystania mechanizmów PAM i
86 SELinux.
87
88 %package anacron
89 Summary:        Utility for running regular jobs
90 Summary(pl.UTF-8):      Narzędzie do uruchamiania regularnych zadań
91 Group:          Base
92 Provides:       anacron = 2.4
93 Obsoletes:      anacron <= 2.3
94
95 %description anacron
96 Anacron becames part of cronie. Anacron is used only for running
97 regular jobs. The default settings execute regular jobs by anacron,
98 however this could be overloaded in settings.
99
100 %description anacron -l pl.UTF-8
101 Anacron stał się częścią cronie. Służy tylko do uruchamiania
102 regularnych zadań. Domyślne ustawienia wykonują zadania przy użyciu
103 anacrona, ale może to być zmienione w ustawieniach.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         SYSCRONTAB=/etc/crontab \
117         SYS_CROND_DIR=/etc/cron.d \
118         --sysconfdir=/etc/cron \
119         --with-editor=/bin/vi \
120         --with-audit%{!?with_audit:=no} \
121         --with-inotify%{!?with_inotify:=no} \
122         --with-pam \
123         --with-selinux%{!?with_selinux:=no} \
124         --disable-silent-rules \
125         --disable-syscrontab \
126         --enable-anacron \
127 %if "%{cc_version}" >= "3.4"
128         --enable-pie \
129 %endif
130         --enable-relro
131
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
137         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
138         $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
139
140 %{__make} install \
141         pamdir=/etc/pam.d \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 cp -p %{SOURCE5} crond.pam
145
146 %if %{without audit}
147 # remove recording user's login uid to the process attribute
148 %{__sed} -i -e '/pam_loginuid.so/d' crond.pam
149 %endif
150
151 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
152 cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
153 cp -a contrib/anacrontab $RPM_BUILD_ROOT/etc/cron/anacrontab
154 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
155 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
156 cp -a crond.pam  $RPM_BUILD_ROOT/etc/pam.d/crond
157 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
158
159 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
160 # cron.allow    This file describes the names of the users which are
161 #               allowed to use the local cron daemon
162 root
163 EOF
164
165 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
166 # cron.deny     This file describes the names of the users which are
167 #               NOT allowed to use the local cron daemon
168 EOF
169
170 cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/check-crond << 'EOF'
171 #!/bin/sh
172
173 # ugly and limited hack. make cronie restart itself
174 if [ -x /bin/awk -a -x /bin/grep -a -f /var/log/cron ]; then
175         LC_ALL=C /bin/awk -v d="$(LC_ALL=C date "+%b %e")" ' $1 " " $2 ~ d' /var/log/cron \
176                 | /bin/grep -qE "PAM.*(Modu. jest nieznany|Module is unknown)" \
177                 && echo "crond is failing on PAM, restarting ( https://github.com/cronie-crond/cronie/issues/87 )" >&2 \
178                 && /sbin/service crond try-restart
179 fi
180 exit 0
181 EOF
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %pre
187 %groupadd -g 117 -r -f crontab
188
189 %post
190 /sbin/chkconfig --add crond
191 %service crond restart "Cron Daemon"
192 %systemd_post crond.service
193
194 %preun
195 if [ "$1" = "0" ]; then
196         %service crond stop
197         /sbin/chkconfig --del crond
198 fi
199 %systemd_preun crond.service
200
201 %postun
202 if [ "$1" = "0" ]; then
203         %groupremove crontab
204 fi
205 %systemd_reload
206
207 %triggerpostun -- cronie < 1.4.8-13
208 if [ -f /etc/sysconfig/cron ]; then
209         . /etc/sysconfig/cron
210         __CROND_ARGS=
211         [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
212         [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
213         if [ -n "$__CROND_ARGS" ]; then
214                 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
215                 echo >>/etc/sysconfig/cron
216                 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
217                 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
218         fi
219 fi
220 %systemd_trigger crond.service
221
222 %triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
223 # Prevent preun from crond from working
224 chmod a-x /etc/rc.d/init.d/crond
225
226 %triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
227 # Restore what triggerun removed
228 chmod 754 /etc/rc.d/init.d/crond
229 # reinstall crond init.d links, which could be different
230 /sbin/chkconfig --del crond
231 /sbin/chkconfig --add crond
232
233 %files
234 %defattr(644,root,root,755)
235 %doc AUTHORS ChangeLog README
236 %attr(750,root,crontab) %dir /etc/cron
237 %attr(750,root,crontab) %dir /etc/cron.daily
238 %attr(750,root,root) /etc/cron.daily/check-crond
239 %attr(750,root,crontab) %dir /etc/cron.hourly
240 %attr(750,root,crontab) %dir /etc/cron.monthly
241 %attr(750,root,crontab) %dir /etc/cron.weekly
242 %attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
243 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
244 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
245 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
246 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
247 %attr(754,root,root) /etc/rc.d/init.d/crond
248 %{systemdunitdir}/crond.service
249 %attr(755,root,root) %{_sbindir}/crond
250 %attr(2755,root,crontab) %{_bindir}/cronnext
251 %attr(2755,root,crontab) %{_bindir}/crontab
252
253 %{_mandir}/man8/crond.8*
254 %{_mandir}/man8/cron.8*
255 %{_mandir}/man5/crontab.5*
256 %{_mandir}/man1/cronnext.1*
257 %{_mandir}/man1/crontab.1*
258
259 %attr(1730,root,crontab) /var/spool/cron
260
261 %files anacron
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{_sbindir}/anacron
264 %attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
265 %attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/cron/anacrontab
266 %{_mandir}/man5/anacrontab.5*
267 %{_mandir}/man8/anacron.8*
268
269 %attr(1730,root,crontab) /var/spool/anacron
This page took 0.054658 seconds and 2 git commands to generate.