]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- added lsw patch (fix for ls -w memory consumption and int overflow - CAN-2003-0853...
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_with     selinux         # build with selinux support
4 #
5 # TODO:
6 # - see Source 8
7
8 Summary:        GNU Core-utils - basic command line utilities
9 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
10 Name:           coreutils
11 Version:        5.0
12 Release:        3
13 License:        GPL
14 Group:          Applications/System
15 # devel versions:
16 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
17 # final versions:
18 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
19 # Source0-md5: 94e5558ee2a65723d4840bfde2d323f0
20 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/fileutils-non-english-man-pages.tar.bz2
21 # Source1-md5: def2f215ac4832e3de0889f06d8543ca
22 Source2:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/sh-utils-non-english-man-pages.tar.bz2
23 # Source2-md5: 9c5fd04cad759fe8d2a70d755679cbc9
24 Source3:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/textutils-non-english-man-pages.tar.bz2
25 # Source3-md5: 4331303b69dd3b74b7c9be9fa3905557
26 Source4:        DIR_COLORS
27 Source5:        fileutils.sh
28 Source6:        fileutils.csh
29 Source7:        su.pamd
30 # to be put in Source1
31 Source8:        stat.1.pl
32 Patch0:         %{name}-info.patch
33 Patch1:         %{name}-pam.patch
34 Patch2:         %{name}-getgid.patch
35 Patch3:         %{name}-utmp.patch
36 Patch4:         %{name}-su-paths.patch
37 Patch5:         %{name}-uname-cpuinfo.patch
38 Patch6:         %{name}-date-man.patch
39 Patch7:         %{name}-mem.patch
40 Patch8:         %{name}-install-C.patch
41 Patch9:         %{name}-po.patch
42 Patch10:        %{name}-no-nb.patch
43 # based on http://acl.bestbits.at/current/diff/fileutils-4.1.8acl-0.8.25.diff.gz
44 Patch11:        %{name}-acl-0.8.25.patch
45 Patch12:        %{name}-lsw.patch
46 Patch13:        %{name}-selinux.patch
47 BuildRequires:  acl-devel
48 BuildRequires:  autoconf >= 2.56
49 BuildRequires:  automake >= 1.7
50 BuildRequires:  gettext-devel >= 0.11.5
51 BuildRequires:  help2man
52 BuildRequires:  pam-devel
53 BuildRequires:  texinfo >= 4.2
54 %{?with_selinux:BuildRequires:  libselinux-devel}
55 Provides:       fileutils
56 Provides:       sh-utils
57 Provides:       stat
58 Provides:       textutils
59 Obsoletes:      fileutils
60 Obsoletes:      sh-utils
61 Obsoletes:      stat
62 Obsoletes:      textutils
63 Requires:       pam >= 0.77.3
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 These are the GNU core utilities.  This package is the union of
68 the GNU fileutils, sh-utils, and textutils packages.
69
70 Most of these programs have significant advantages over their Unix
71 counterparts, such as greater speed, additional options, and fewer
72 arbitrary limits.
73
74 The programs that can be built with this package are:
75
76   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
77   df dir dircolors dirname du echo env expand expr factor false fmt fold
78   ginstall head hostid id join link ln logname ls md5sum mkdir mkfifo
79   mknod mv nice nl nohup od paste pathchk pinky pr printenv printf ptx
80   pwd rm rmdir seq sha1sum shred sleep sort split stat stty su sum sync
81   tac tail tee test touch tr true tsort tty uname unexpand uniq unlink
82   users vdir wc who whoami yes
83
84 %description -l pl
85 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
86 fileutils, sh-utils i textutils.
87
88 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
89 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
90 opcje i mniej ograniczeñ.
91
92 Programy zawarte w tej paczce to:
93
94   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
95   df dir dircolors dirname du echo env expand expr factor false fmt fold
96   ginstall head hostid id join link ln logname ls md5sum mkdir mkfifo
97   mknod mv nice nl nohup od paste pathchk pinky pr printenv printf ptx
98   pwd rm rmdir seq sha1sum shred sleep sort split stat stty su sum sync
99   tac tail tee test touch tr true tsort tty uname unexpand uniq unlink
100   users vdir wc who whoami yes
101
102 %prep
103 %setup -q -a1 -a3
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108 %patch4 -p1
109 %patch5 -p1
110 %patch6 -p1
111 %patch7 -p1
112 %patch8 -p1
113 %patch9 -p1
114 %patch10 -p1
115 %patch11 -p1
116 %patch12 -p1
117 %{?with_selinux:%patch13 -p1}
118
119 perl -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
120
121 # nb_NO is just an alias for no_NO in glibc
122 # no.po is outdated, nb.po is more fresh here
123 mv -f po/{nb,no}.po
124 rm -f po/{nb,no}.gmo
125
126 %build
127 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
128 mv -f m4/{inttypes.m4,jm-inttypes.m4}
129 %{__gettextize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         --enable-pam
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/profile.d}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 rm -f $RPM_BUILD_ROOT%{_bindir}/{uptime,hostname,groups,kill}
147 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{uptime,hostname,groups}.1*
148
149 ln -sf test $RPM_BUILD_ROOT%{_bindir}/[
150
151 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
152 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,pwd,rm,rmdir,sleep,sort,stty,\
153 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
154
155 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
156
157 # su is missed by "make install"
158 install src/su $RPM_BUILD_ROOT/bin
159
160 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
161 install %{SOURCE5} %{SOURCE6} $RPM_BUILD_ROOT/etc/profile.d
162 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/su
163
164 mv -f man/pt_BR/*.1 man/pt
165 for d in cs da de es fi fr hu id it ja ko nl pl pt ru ; do
166         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
167         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
168 done
169 install %{SOURCE8} $RPM_BUILD_ROOT%{_mandir}/pl/man1/stat.1
170 bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
171 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{groups,hostname,uptime}.1
172 for f in `find $RPM_BUILD_ROOT%{_mandir} -type f -name ginstall.1`; do
173         mv -f $f `dirname $f`/install.1
174 done
175
176 %find_lang %{name}
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post
182 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
183
184 %postun
185 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
186
187 %files -f %{name}.lang
188 %defattr(644,root,root,755)
189 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
190 %attr(755,root,root) /bin/[!s]*
191 %attr(755,root,root) /bin/s[!u]*
192 %attr(4755,root,root) /bin/su
193 %attr(755,root,root) %{_bindir}/*
194 %attr(755,root,root) %{_sbindir}/*
195 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/su
196 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/DIR_COLORS
197 %attr(755,root,root) /etc/profile.d/*
198 %{_mandir}/man1/*
199 %lang(cs) %{_mandir}/cs/man1/*
200 %lang(da) %{_mandir}/da/man1/*
201 %lang(de) %{_mandir}/de/man1/*
202 %lang(es) %{_mandir}/es/man1/*
203 %lang(fi) %{_mandir}/fi/man1/*
204 %lang(fr) %{_mandir}/fr/man1/*
205 %lang(hu) %{_mandir}/hu/man1/*
206 %lang(id) %{_mandir}/id/man1/*
207 %lang(it) %{_mandir}/it/man1/*
208 %lang(ja) %{_mandir}/ja/man1/*
209 %lang(ko) %{_mandir}/ko/man1/*
210 %lang(nl) %{_mandir}/nl/man1/*
211 %lang(pl) %{_mandir}/pl/man1/*
212 %lang(pt) %{_mandir}/pt/man1/*
213 %lang(ru) %{_mandir}/ru/man1/*
214 %{_infodir}/coreutils.info*
This page took 0.065956 seconds and 4 git commands to generate.