]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- fix build with glibc 2.5 (tee() declared in fnctl.h)
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
7 Name:           coreutils
8 Version:        5.2.1
9 Release:        9
10 License:        GPL
11 Group:          Applications/System
12 # devel versions:
13 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
14 # final versions:
15 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
16 # Source0-md5:  172ee3c315af93d3385ddfbeb843c53f
17 Source1:        %{name}-non-english-man-pages.tar.bz2
18 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
19 Source2:        DIR_COLORS
20 Source3:        fileutils.sh
21 Source4:        fileutils.csh
22 Source5:        su.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-pl.po-update.patch
25 Patch2:         %{name}-pam.patch
26 Patch3:         %{name}-getgid.patch
27 Patch4:         %{name}-su-paths.patch
28 Patch5:         %{name}-uname-cpuinfo.patch
29 Patch6:         %{name}-date-man.patch
30 Patch7:         %{name}-mem.patch
31 Patch8:         %{name}-install-C.patch
32 Patch9:         %{name}-po.patch
33 Patch10:        %{name}-no-nb.patch
34 # based on patch from Fedora, based on patches from http://acl.bestbits.at/
35 Patch11:        %{name}-acl.patch
36 Patch12:        %{name}-selinux.patch
37 Patch13:        %{name}-gettext-m4.patch
38 Patch14:        %{name}-euidaccess.patch
39 URL:            http://www.gnu.org/software/coreutils/
40 BuildRequires:  acl-devel
41 BuildRequires:  autoconf >= 2.58
42 BuildRequires:  automake >= 1:1.8
43 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
44 BuildRequires:  gettext-devel >= 0.11.5
45 BuildRequires:  help2man
46 %{?with_selinux:BuildRequires:  libselinux-devel}
47 BuildRequires:  pam-devel
48 BuildRequires:  texinfo >= 4.2
49 Requires:       pam >= 0.77.3
50 Requires:       setup >= 2.4.6-2
51 Provides:       fileutils
52 Provides:       sh-utils
53 Provides:       stat
54 Provides:       textutils
55 Obsoletes:      fileutils
56 Obsoletes:      sh-utils
57 Obsoletes:      stat
58 Obsoletes:      textutils
59 Conflicts:      shadow < 1:4.0.3-6
60 Conflicts:      tetex < 1:2.0.2
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 These are the GNU core utilities. This package is the union of the GNU
65 fileutils, sh-utils, and textutils packages.
66
67 Most of these programs have significant advantages over their Unix
68 counterparts, such as greater speed, additional options, and fewer
69 arbitrary limits.
70
71 The programs that can be built with this package are:
72
73   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
74   dd df dir dircolors dirname du echo env expand expr factor false fmt
75   fold install groups head hostid id join link ln logname ls md5sum
76   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
77   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
78   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
79   uniq unlink users vdir wc who whoami yes
80
81 %description -l pl
82 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
83 fileutils, sh-utils i textutils.
84
85 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
86 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
87 opcje i mniej ograniczeñ.
88
89 Programy zawarte w tym pakiecie to:
90
91   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
92   dd df dir dircolors dirname du echo env expand expr factor false fmt
93   fold ginstall groups head hostid id join link ln logname ls md5sum
94   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
95   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
96   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
97   uniq unlink users vdir wc who whoami yes
98
99 %prep
100 %setup -q -a1
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105 %patch4 -p1
106 %patch5 -p1
107 %patch6 -p1
108 %patch7 -p1
109 %patch8 -p1
110 %patch9 -p1
111 %patch10 -p1
112 %patch11 -p1
113 %{?with_selinux:%patch12 -p1}
114 %patch13 -p1
115 %patch14 -p1
116
117 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
118 %{__perl} -pi -e 's/tee \(/tee_files (/' src/tee.c
119
120 # no_NO is just an alias for nb_NO in recent glibc
121 # no.po is outdated, nb.po is more fresh here (see also patch10)
122 rm -f po/no.*
123 # allow rebuilding *.gmo
124 rm -f po/stamp-po
125
126 %build
127 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
128 mv -f m4/{inttypes.m4,jm-inttypes.m4}
129 %{__gettextize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
136         DEFAULT_POSIX2_VERSION=199209 \
137         %{?with_selinux:--enable-selinux} \
138         --enable-pam
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shrc.d}
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
150 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{hostname,kill,uptime}.1*
151
152 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
153 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
154 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
155
156 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
157
158 # su is missed by "make install"
159 install src/su $RPM_BUILD_ROOT/bin
160
161 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
162 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
163 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
164
165 mv -f man/pt_BR man/pt
166 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
167         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
168         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
169 done
170 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
171
172 %find_lang %{name}
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post
178 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
179
180 %postun
181 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
182
183 %files -f %{name}.lang
184 %defattr(644,root,root,755)
185 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
186 %attr(755,root,root) /bin/[!s]*
187 %attr(755,root,root) /bin/s[!u]*
188 %attr(4755,root,root) /bin/su
189 %attr(755,root,root) %{_bindir}/*
190 %attr(755,root,root) %{_sbindir}/*
191 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su
192 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
193 /etc/shrc.d/*
194 %{_mandir}/man1/*
195 %lang(cs) %{_mandir}/cs/man1/*
196 %lang(da) %{_mandir}/da/man1/*
197 %lang(de) %{_mandir}/de/man1/*
198 %lang(es) %{_mandir}/es/man1/*
199 %lang(fi) %{_mandir}/fi/man1/*
200 %lang(fr) %{_mandir}/fr/man1/*
201 %lang(hu) %{_mandir}/hu/man1/*
202 %lang(id) %{_mandir}/id/man1/*
203 %lang(it) %{_mandir}/it/man1/*
204 %lang(ja) %{_mandir}/ja/man1/*
205 %lang(ko) %{_mandir}/ko/man1/*
206 %lang(nl) %{_mandir}/nl/man1/*
207 %lang(pl) %{_mandir}/pl/man1/*
208 %lang(pt) %{_mandir}/pt/man1/*
209 %lang(ru) %{_mandir}/ru/man1/*
210 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
211 %{_infodir}/coreutils.info*
This page took 0.074782 seconds and 4 git commands to generate.