]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- move printf to /bin directory - it's used by rc-scripts, release 7
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 # TODO:
6 # - see Source 8
7
8 Summary:        GNU Core-utils - basic command line utilities
9 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
10 Name:           coreutils
11 Version:        5.0
12 Release:        7
13 License:        GPL
14 Group:          Applications/System
15 # devel versions:
16 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
17 # final versions:
18 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
19 # Source0-md5: 94e5558ee2a65723d4840bfde2d323f0
20 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/fileutils-non-english-man-pages.tar.bz2
21 # Source1-md5: def2f215ac4832e3de0889f06d8543ca
22 Source2:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/sh-utils-non-english-man-pages.tar.bz2
23 # Source2-md5: 9c5fd04cad759fe8d2a70d755679cbc9
24 Source3:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/textutils-non-english-man-pages.tar.bz2
25 # Source3-md5: 4331303b69dd3b74b7c9be9fa3905557
26 Source4:        DIR_COLORS
27 Source5:        fileutils.sh
28 Source6:        fileutils.csh
29 Source7:        su.pamd
30 # to be put in Source1
31 Source8:        stat.1.pl
32 Patch0:         %{name}-info.patch
33 Patch1:         %{name}-pam.patch
34 Patch2:         %{name}-getgid.patch
35 Patch3:         %{name}-utmp.patch
36 Patch4:         %{name}-su-paths.patch
37 Patch5:         %{name}-uname-cpuinfo.patch
38 Patch6:         %{name}-date-man.patch
39 Patch7:         %{name}-mem.patch
40 Patch8:         %{name}-install-C.patch
41 Patch9:         %{name}-po.patch
42 Patch10:        %{name}-no-nb.patch
43 # based on http://acl.bestbits.at/current/diff/fileutils-4.1.8acl-0.8.25.diff.gz
44 Patch11:        %{name}-acl-0.8.25.patch
45 Patch12:        %{name}-lsw.patch
46 Patch13:        %{name}-nanosleep.patch
47 Patch14:        %{name}-selinux.patch
48 BuildRequires:  acl-devel
49 BuildRequires:  autoconf >= 2.56
50 BuildRequires:  automake >= 1.7
51 BuildRequires:  gettext-devel >= 0.11.5
52 BuildRequires:  help2man
53 BuildRequires:  pam-devel
54 BuildRequires:  texinfo >= 4.2
55 %{?with_selinux:BuildRequires:  libselinux-devel}
56 Provides:       fileutils
57 Provides:       sh-utils
58 Provides:       stat
59 Provides:       textutils
60 Obsoletes:      fileutils
61 Obsoletes:      sh-utils
62 Obsoletes:      stat
63 Obsoletes:      textutils
64 Requires:       pam >= 0.77.3
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 These are the GNU core utilities.  This package is the union of
69 the GNU fileutils, sh-utils, and textutils packages.
70
71 Most of these programs have significant advantages over their Unix
72 counterparts, such as greater speed, additional options, and fewer
73 arbitrary limits.
74
75 The programs that can be built with this package are:
76
77   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
78   df dir dircolors dirname du echo env expand expr factor false fmt fold
79   ginstall head hostid id join link ln logname ls md5sum mkdir mkfifo
80   mknod mv nice nl nohup od paste pathchk pinky pr printenv printf ptx
81   pwd rm rmdir seq sha1sum shred sleep sort split stat stty su sum sync
82   tac tail tee test touch tr true tsort tty uname unexpand uniq unlink
83   users vdir wc who whoami yes
84
85 %description -l pl
86 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
87 fileutils, sh-utils i textutils.
88
89 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
90 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
91 opcje i mniej ograniczeñ.
92
93 Programy zawarte w tej paczce to:
94
95   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
96   df dir dircolors dirname du echo env expand expr factor false fmt fold
97   ginstall head hostid id join link ln logname ls md5sum mkdir mkfifo
98   mknod mv nice nl nohup od paste pathchk pinky pr printenv printf ptx
99   pwd rm rmdir seq sha1sum shred sleep sort split stat stty su sum sync
100   tac tail tee test touch tr true tsort tty uname unexpand uniq unlink
101   users vdir wc who whoami yes
102
103 %prep
104 %setup -q -a1 -a3
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109 %patch4 -p1
110 %patch5 -p1
111 %patch6 -p1
112 %patch7 -p1
113 %patch8 -p1
114 %patch9 -p1
115 %patch10 -p1
116 %patch11 -p1
117 %patch12 -p1
118 %patch13 -p1
119 %{?with_selinux:%patch14 -p1}
120
121 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
122
123 # nb_NO is just an alias for no_NO in glibc
124 # no.po is outdated, nb.po is more fresh here
125 mv -f po/{nb,no}.po
126 rm -f po/{nb,no}.gmo
127
128 %build
129 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
130 mv -f m4/{inttypes.m4,jm-inttypes.m4}
131 %{__gettextize}
132 %{__aclocal} -I m4
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         %{?with_selinux:--enable-selinux} \
138         --enable-pam
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/profile.d}
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 rm -f $RPM_BUILD_ROOT%{_bindir}/{uptime,hostname,kill}
150 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{uptime,hostname}.1*
151
152 ln -sf test $RPM_BUILD_ROOT%{_bindir}/[
153
154 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
155 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
156 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
157
158 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
159
160 # su is missed by "make install"
161 install src/su $RPM_BUILD_ROOT/bin
162
163 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
164 install %{SOURCE5} %{SOURCE6} $RPM_BUILD_ROOT/etc/profile.d
165 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/su
166
167 mv -f man/pt_BR/*.1 man/pt
168 for d in cs da de es fi fr hu id it ja ko nl pl pt ru ; do
169         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
170         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
171 done
172 install %{SOURCE8} $RPM_BUILD_ROOT%{_mandir}/pl/man1/stat.1
173 bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
174 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,uptime}.1
175 for f in `find $RPM_BUILD_ROOT%{_mandir} -type f -name ginstall.1`; do
176         mv -f $f `dirname $f`/install.1
177 done
178
179 %find_lang %{name}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post
185 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
186
187 %postun
188 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
189
190 %files -f %{name}.lang
191 %defattr(644,root,root,755)
192 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
193 %attr(755,root,root) /bin/[!s]*
194 %attr(755,root,root) /bin/s[!u]*
195 %attr(4755,root,root) /bin/su
196 %attr(755,root,root) %{_bindir}/*
197 %attr(755,root,root) %{_sbindir}/*
198 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/su
199 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/DIR_COLORS
200 %attr(755,root,root) /etc/profile.d/*
201 %{_mandir}/man1/*
202 %lang(cs) %{_mandir}/cs/man1/*
203 %lang(da) %{_mandir}/da/man1/*
204 %lang(de) %{_mandir}/de/man1/*
205 %lang(es) %{_mandir}/es/man1/*
206 %lang(fi) %{_mandir}/fi/man1/*
207 %lang(fr) %{_mandir}/fr/man1/*
208 %lang(hu) %{_mandir}/hu/man1/*
209 %lang(id) %{_mandir}/id/man1/*
210 %lang(it) %{_mandir}/it/man1/*
211 %lang(ja) %{_mandir}/ja/man1/*
212 %lang(ko) %{_mandir}/ko/man1/*
213 %lang(nl) %{_mandir}/nl/man1/*
214 %lang(pl) %{_mandir}/pl/man1/*
215 %lang(pt) %{_mandir}/pt/man1/*
216 %lang(ru) %{_mandir}/ru/man1/*
217 %{_infodir}/coreutils.info*
This page took 0.067111 seconds and 4 git commands to generate.