]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
f8b1ae1bd5fb6a0665b4c71605b79a7727314330
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
7 Name:           coreutils
8 Version:        5.2.1
9 Release:        0.1
10 License:        GPL
11 Group:          Applications/System
12 # devel versions:
13 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
14 # final versions:
15 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
16 # Source0-md5:  172ee3c315af93d3385ddfbeb843c53f
17 Source1:        %{name}-non-english-man-pages.tar.bz2
18 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
19 Source2:        DIR_COLORS
20 Source3:        fileutils.sh
21 Source4:        fileutils.csh
22 Source5:        su.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-pam.patch
25 Patch2:         %{name}-getgid.patch
26 Patch3:         %{name}-utmp.patch
27 Patch4:         %{name}-su-paths.patch
28 Patch5:         %{name}-uname-cpuinfo.patch
29 Patch6:         %{name}-date-man.patch
30 Patch7:         %{name}-mem.patch
31 Patch8:         %{name}-install-C.patch
32 Patch9:         %{name}-po.patch
33 Patch10:        %{name}-no-nb.patch
34 # based on http://acl.bestbits.at/current/diff/fileutils-4.1.8acl-0.8.25.diff.gz
35 Patch11:        %{name}-acl-0.8.25.patch
36 Patch12:        %{name}-lsw.patch
37 Patch13:        %{name}-nanosleep.patch
38 Patch14:        %{name}-selinux.patch
39 # allow obsolete head/tail syntax when compiled on POSIX2.200112-compliant glibc
40 # (only if POSIXLY_CORRECT is not set in environment)
41 Patch15:        %{name}-noposix2.patch
42 BuildRequires:  acl-devel
43 BuildRequires:  autoconf >= 2.56
44 BuildRequires:  automake >= 1.7
45 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
46 BuildRequires:  gettext-devel >= 0.11.5
47 BuildRequires:  help2man
48 BuildRequires:  pam-devel
49 BuildRequires:  texinfo >= 4.2
50 %{?with_selinux:BuildRequires:  libselinux-devel}
51 Requires:       pam >= 0.77.3
52 Provides:       fileutils
53 Provides:       sh-utils
54 Provides:       stat
55 Provides:       textutils
56 Obsoletes:      fileutils
57 Obsoletes:      sh-utils
58 Obsoletes:      stat
59 Obsoletes:      textutils
60 Conflicts:      shadow < 1:4.0.3-6
61 Conflicts:      tetex < 1:2.0.2
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 These are the GNU core utilities.  This package is the union of
66 the GNU fileutils, sh-utils, and textutils packages.
67
68 Most of these programs have significant advantages over their Unix
69 counterparts, such as greater speed, additional options, and fewer
70 arbitrary limits.
71
72 The programs that can be built with this package are:
73
74   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
75   df dir dircolors dirname du echo env expand expr factor false fmt fold
76   ginstall groups head hostid id join link ln logname ls md5sum mkdir
77   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
78   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
79   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
80   uniq unlink users vdir wc who whoami yes
81
82 %description -l pl
83 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
84 fileutils, sh-utils i textutils.
85
86 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
87 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
88 opcje i mniej ograniczeñ.
89
90 Programy zawarte w tym pakiecie to:
91
92   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
93   df dir dircolors dirname du echo env expand expr factor false fmt fold
94   ginstall groups head hostid id join link ln logname ls md5sum mkdir
95   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
96   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
97   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
98   uniq unlink users vdir wc who whoami yes
99
100 %prep
101 %setup -q -a1
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105 %patch3 -p1
106 %patch4 -p1
107 %patch5 -p1
108 %patch6 -p1
109 %patch7 -p1
110 %patch8 -p1
111 %patch9 -p1
112 %patch10 -p1
113 %patch11 -p1
114 %patch12 -p1
115 %patch13 -p1
116 %{?with_selinux:%patch14 -p1}
117 %patch15 -p1
118
119 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
120
121 # no_NO is just an alias for nb_NO in recent glibc
122 # no.po is outdated, nb.po is more fresh here (see also patch10)
123 rm -f po/no.*
124
125 %build
126 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
127 mv -f m4/{inttypes.m4,jm-inttypes.m4}
128 %{__gettextize}
129 %{__aclocal} -I m4
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure \
134         %{?with_selinux:--enable-selinux} \
135         --enable-pam
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/profile.d}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
147 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{uptime,hostname}.1*
148
149 ln -sf test $RPM_BUILD_ROOT%{_bindir}/[
150
151 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
152 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
153 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
154
155 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
156
157 # su is missed by "make install"
158 install src/su $RPM_BUILD_ROOT/bin
159
160 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
161 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
162 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
163
164 mv -f man/pt_BR man/pt
165 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
166         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
167         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
168 done
169 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
170
171 %find_lang %{name}
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post
177 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
178
179 %postun
180 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
181
182 %files -f %{name}.lang
183 %defattr(644,root,root,755)
184 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
185 %attr(755,root,root) /bin/[!s]*
186 %attr(755,root,root) /bin/s[!u]*
187 %attr(4755,root,root) /bin/su
188 %attr(755,root,root) %{_bindir}/*
189 %attr(755,root,root) %{_sbindir}/*
190 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/su
191 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/DIR_COLORS
192 %attr(755,root,root) /etc/profile.d/*
193 %{_mandir}/man1/*
194 %lang(cs) %{_mandir}/cs/man1/*
195 %lang(da) %{_mandir}/da/man1/*
196 %lang(de) %{_mandir}/de/man1/*
197 %lang(es) %{_mandir}/es/man1/*
198 %lang(fi) %{_mandir}/fi/man1/*
199 %lang(fr) %{_mandir}/fr/man1/*
200 %lang(hu) %{_mandir}/hu/man1/*
201 %lang(id) %{_mandir}/id/man1/*
202 %lang(it) %{_mandir}/it/man1/*
203 %lang(ja) %{_mandir}/ja/man1/*
204 %lang(ko) %{_mandir}/ko/man1/*
205 %lang(nl) %{_mandir}/nl/man1/*
206 %lang(pl) %{_mandir}/pl/man1/*
207 %lang(pt) %{_mandir}/pt/man1/*
208 %lang(ru) %{_mandir}/ru/man1/*
209 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
210 %{_infodir}/coreutils.info*
This page took 0.05521 seconds and 3 git commands to generate.