]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
e8dff122341ecc16614a92e0d6d298865b6e6d93
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
7 Name:           coreutils
8 Version:        5.2.1
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 # devel versions:
13 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
14 # final versions:
15 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
16 # Source0-md5:  172ee3c315af93d3385ddfbeb843c53f
17 Source1:        %{name}-non-english-man-pages.tar.bz2
18 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
19 Source2:        DIR_COLORS
20 Source3:        fileutils.sh
21 Source4:        fileutils.csh
22 Source5:        su.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-pl.po-update.patch
25 Patch2:         %{name}-pam.patch
26 Patch3:         %{name}-getgid.patch
27 Patch4:         %{name}-su-paths.patch
28 Patch5:         %{name}-uname-cpuinfo.patch
29 Patch6:         %{name}-date-man.patch
30 Patch7:         %{name}-mem.patch
31 Patch8:         %{name}-install-C.patch
32 Patch9:         %{name}-po.patch
33 Patch10:        %{name}-no-nb.patch
34 # based on patch from Fedora, based on patches from http://acl.bestbits.at/
35 Patch11:        %{name}-acl.patch
36 Patch12:        %{name}-selinux.patch
37 BuildRequires:  acl-devel
38 BuildRequires:  autoconf >= 2.58
39 BuildRequires:  automake >= 1.8
40 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
41 BuildRequires:  gettext-devel >= 0.11.5
42 BuildRequires:  help2man
43 BuildRequires:  pam-devel
44 BuildRequires:  texinfo >= 4.2
45 %{?with_selinux:BuildRequires:  libselinux-devel}
46 PreReq:         fix-info-dir
47 Requires:       pam >= 0.77.3
48 Requires:       setup >= 2.4.6-2
49 Provides:       fileutils
50 Provides:       sh-utils
51 Provides:       stat
52 Provides:       textutils
53 Obsoletes:      fileutils
54 Obsoletes:      sh-utils
55 Obsoletes:      stat
56 Obsoletes:      textutils
57 Conflicts:      shadow < 1:4.0.3-6
58 Conflicts:      tetex < 1:2.0.2
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 These are the GNU core utilities.  This package is the union of
63 the GNU fileutils, sh-utils, and textutils packages.
64
65 Most of these programs have significant advantages over their Unix
66 counterparts, such as greater speed, additional options, and fewer
67 arbitrary limits.
68
69 The programs that can be built with this package are:
70
71   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
72   dd df dir dircolors dirname du echo env expand expr factor false fmt
73   fold install groups head hostid id join link ln logname ls md5sum
74   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
75   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
76   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
77   uniq unlink users vdir wc who whoami yes
78
79 %description -l pl
80 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
81 fileutils, sh-utils i textutils.
82
83 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
84 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
85 opcje i mniej ograniczeñ.
86
87 Programy zawarte w tym pakiecie to:
88
89   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
90   dd df dir dircolors dirname du echo env expand expr factor false fmt
91   fold ginstall groups head hostid id join link ln logname ls md5sum
92   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
93   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
94   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
95   uniq unlink users vdir wc who whoami yes
96
97 %prep
98 %setup -q -a1
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102 %patch3 -p1
103 %patch4 -p1
104 %patch5 -p1
105 %patch6 -p1
106 %patch7 -p1
107 %patch8 -p1
108 %patch9 -p1
109 %patch10 -p1
110 %patch11 -p1
111 %{?with_selinux:%patch12 -p1}
112
113 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
114
115 # no_NO is just an alias for nb_NO in recent glibc
116 # no.po is outdated, nb.po is more fresh here (see also patch10)
117 rm -f po/no.*
118 # allow rebuilding *.gmo
119 rm -f po/stamp-po
120
121 %build
122 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
123 mv -f m4/{inttypes.m4,jm-inttypes.m4}
124 %{__gettextize}
125 %{__aclocal} -I m4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         DEFAULT_POSIX2_VERSION=199209 \
131         %{?with_selinux:--enable-selinux} \
132         --enable-pam
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shrc.d}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
144 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{hostname,kill,uptime}.1*
145
146 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
147 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
148 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
149
150 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
151
152 # su is missed by "make install"
153 install src/su $RPM_BUILD_ROOT/bin
154
155 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
156 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
157 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
158
159 mv -f man/pt_BR man/pt
160 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
161         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
162         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
163 done
164 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
165
166 %find_lang %{name}
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post
172 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
173
174 %postun
175 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
180 %attr(755,root,root) /bin/[!s]*
181 %attr(755,root,root) /bin/s[!u]*
182 %attr(4755,root,root) /bin/su
183 %attr(755,root,root) %{_bindir}/*
184 %attr(755,root,root) %{_sbindir}/*
185 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/su
186 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/DIR_COLORS
187 /etc/shrc.d/*
188 %{_mandir}/man1/*
189 %lang(cs) %{_mandir}/cs/man1/*
190 %lang(da) %{_mandir}/da/man1/*
191 %lang(de) %{_mandir}/de/man1/*
192 %lang(es) %{_mandir}/es/man1/*
193 %lang(fi) %{_mandir}/fi/man1/*
194 %lang(fr) %{_mandir}/fr/man1/*
195 %lang(hu) %{_mandir}/hu/man1/*
196 %lang(id) %{_mandir}/id/man1/*
197 %lang(it) %{_mandir}/it/man1/*
198 %lang(ja) %{_mandir}/ja/man1/*
199 %lang(ko) %{_mandir}/ko/man1/*
200 %lang(nl) %{_mandir}/nl/man1/*
201 %lang(pl) %{_mandir}/pl/man1/*
202 %lang(pt) %{_mandir}/pt/man1/*
203 %lang(ru) %{_mandir}/ru/man1/*
204 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
205 %{_infodir}/coreutils.info*
This page took 0.087737 seconds and 3 git commands to generate.