]> git.pld-linux.org Git - packages/conserver.git/blob - conserver.spec
- up to 8.1.1
[packages/conserver.git] / conserver.spec
1 # TODO: smart .init/.sysconfig, maybe a default configuration
2 #
3 Summary:        Console server
4 Summary(pl):    Serwer konsoli
5 Name:           conserver
6 Version:        8.1.1
7 Release:        1
8 License:        BSD-like
9 Group:          Daemons
10 Source0:        http://www.conserver.com/%{name}-%{version}.tar.gz
11 # Source0-md5:  d2641597713768cb62f09f1d94f95ef1
12 Source1:        %{name}.init
13 Source2:        %{name}.sysconfig
14 Source3:        %{name}.logrotate
15 URL:            http://www.conserver.com/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Conserver is an application that allows multiple users to watch a
22 serial console at the same time.  It can log the data, allows users
23 to take write-access of a console (one at a time), and has a
24 variety of bells and whistles to accentuate that basic
25 functionality.
26
27 %description -l pl
28 Conserver jest aplikacj±, która umo¿liwia kilku u¿ytkownikom naraz
29 ogl±daæ logi na konsoli szeregowej. Mo¿e zapisywaæ zebrane dane,
30 pozwalaæ u¿ytkownikom na pe³ne korzystanie z konsoli (ale tylko
31 jednemu naraz), oraz posiada mnóstwo dodatków rozszerzaj±cych tê
32 podstawow± funkcjonalno¶æ.
33
34 %prep
35 %setup -q
36
37 %build
38 %{__aclocal}
39 %{__autoconf}
40 %{__autoheader}
41 %configure \
42         --with-master=localhost
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d} \
49         $RPM_BUILD_ROOT/var/log/{conserver.d,archiv/conserver.d}
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 mv $RPM_BUILD_ROOT%{_datadir}/examples/conserver examples
54 rm -f examples/conserver.rc
55 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/conserver
56 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/conserver
57 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/conserver
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 /sbin/chkconfig --add conserver
64 if [ -f /var/lock/subsys/conserver ]; then
65         /etc/rc.d/init.d/conserver restart 1>&2
66 else
67         echo "Run \"/etc/rc.d/init.d/conserver start\" to start conserver daemon."
68 fi
69
70 %preun
71 if [ "$1" = "0" ]; then
72         if [ -f /var/lock/subsys/conserver ]; then
73                 /etc/rc.d/init.d/conserver stop 1>&2
74         fi
75         /sbin/chkconfig --del conserver
76 fi
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CHANGES FAQ README TODO examples LICENSE
81 %attr(755,root,root) %{_bindir}/*
82 %attr(755,root,root) %{_sbindir}/*
83 %attr(754,root,root) /etc/rc.d/init.d/conserver
84 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/*
85 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
86 %attr(750,root,root) %dir /var/log/conserver.d
87 %attr(750,root,root) %dir /var/log/archiv/conserver.d
88 %{_mandir}/man*/*
This page took 0.039906 seconds and 4 git commands to generate.