]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- 20060505
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (not working)
6 #
7 %define         _snap   20060505
8 #
9 Summary:        OpenGL window and compositing manager
10 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
11 Name:           compiz
12 Version:        0.0.10
13 Release:        1.%{_snap}.1
14 License:        GPL/MIT
15 Group:          X11
16 Source0:        %{name}-%{_snap}.tar.bz2
17 # Source0-md5:  3807b7f11534f8773a19f80f1031f853
18 Source1:        %{name}-pld.png
19 # Source1-md5:  3050dc90fd4e5e990bb5baeb82bd3c8a
20 Patch0:         %{name}-minimize-scaler-mod.patch
21 %if %{with gconf} || %{with gnome}
22 BuildRequires:  GConf2-devel >= 2.0
23 %endif
24 BuildRequires:  Mesa-libGL-devel >= 6.5-1.20060411.2
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake
27 BuildRequires:  glib2-devel >= 2.0
28 BuildRequires:  glitz-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  libsvg-cairo-devel
31 BuildRequires:  libtool
32 BuildRequires:  pkgconfig
33 BuildRequires:  startup-notification-devel >= 0.7
34 BuildRequires:  xorg-lib-libSM-devel
35 BuildRequires:  xorg-lib-libXcomposite-devel
36 BuildRequires:  xorg-lib-libXdamage-devel
37 BuildRequires:  xorg-lib-libXrandr-devel
38 BuildRequires:  xorg-lib-libXres-devel
39 %if %{with gnome}
40 BuildRequires:  control-center-devel >= 2.0
41 BuildRequires:  gnome-desktop-devel >= 2.0
42 BuildRequires:  gnome-menus-devel
43 BuildRequires:  gtk+2-devel >= 2:2.8.0
44 BuildRequires:  libwnck-devel >= 2.14.1-2
45 %endif
46 %if %{with kde}
47 BuildRequires:  QtCore-devel
48 BuildRequires:  QtGui-devel
49 BuildRequires:  qt4-build
50 %endif
51 Requires(post,preun):   GConf2
52 Conflicts:      xorg-xserver-xgl < 0.0.20060505
53 Obsoletes:      compiz-opacity
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Compiz is an OpenGL compositing manager that use
58 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
59 to texture objects. It has a flexible plug-in system and it is
60 designed to run well on most graphics hardware.
61
62 %description -l pl
63 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
64 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
65 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
66 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
67
68 %package devel
69 Summary:        Header files for compiz
70 Summary(pl):    Pliki nag³ówkowe dla compiza
71 Group:          Development
72 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
73 Requires:       OpenGL-devel
74 Requires:       libpng-devel
75 Requires:       startup-notification-devel >= 0.7
76 Requires:       xorg-lib-libSM-devel
77 Requires:       xorg-lib-libXcomposite-devel
78 Requires:       xorg-lib-libXdamage-devel
79 Requires:       xorg-lib-libXrandr-devel
80
81 %description devel
82 Header files for compiz.
83
84 %description devel -l pl
85 Pliki nag³ówkowe dla compiza.
86
87 %package gnome-settings
88 Summary:        Compiz settings for gnome control panel
89 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
90 Group:          X11
91 Requires:       %{name} = %{version}-%{release}
92
93 %description gnome-settings
94 Compiz settings for gnome control panel.
95
96 %description gnome-settings -l pl
97 Ustawienia compiza dla panelu sterowania gnome.
98
99 %package gnome-decorator
100 Summary:        Window decorator for gnome
101 Summary(pl):    Dekorator okien dla gnome
102 Group:          X11
103 Requires:       %{name} = %{version}-%{release}
104
105 %description gnome-decorator
106 Window decorator for gnome.
107
108 %description gnome-decorator -l pl
109 Dekorator okien dla gnome.
110
111 %package kde-decorator
112 Summary:        Window decorator for KDE
113 Summary(pl):    Dekorator okien dla KDE
114 Group:          X11
115 Requires:       %{name} = %{version}-%{release}
116
117 %description kde-decorator
118 Window decorator for KDE.
119
120 %description kde-decorator -l pl
121 Dekorator okien dla KDE.
122
123 %prep
124 %setup -q -n %{name}-%{_snap}
125 %patch0 -p0
126
127 %build
128 autoreconf -v --install
129
130 %configure \
131         --disable-static \
132         --enable-svg \
133         --enable-libsvg-cairo \
134         %{!?with_gconf:--disable-gconf} \
135         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
136         --%{?with_kde:en}%{!?with_kde:dis}able-kde
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/compiz/novell.png
147
148 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post
154 %gconf_schema_install compiz.schemas
155
156 %preun
157 %gconf_schema_uninstall compiz.schemas
158
159 %files
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog README TODO
162 %attr(755,root,root) %{_bindir}/compiz
163 %dir %{_libdir}/compiz
164 %attr(755,root,root) %{_libdir}/compiz/*.so
165 %{_datadir}/compiz
166 %if %{with gnome}
167 %{_datadir}/gnome/wm-properties/*
168 %endif
169 %{_sysconfdir}/gconf/schemas/compiz.schemas
170
171 %files devel
172 %defattr(644,root,root,755)
173 %{_includedir}/compiz
174 %{_pkgconfigdir}/compiz.pc
175
176 %if %{with gnome}
177 %files gnome-settings
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
180
181 %files gnome-decorator
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/gnome-window-decorator
184 %endif
185
186 %if %{with kde}
187 %files kde-decorator
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/kde-window-decorator
190 %endif
This page took 0.067745 seconds and 4 git commands to generate.