]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- 20060307
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (currently not working)
6 #
7 Summary:        OpenGL window and compositing manager
8 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
9 Name:           compiz
10 Version:        0.0.6
11 Release:        1
12 License:        GPL/MIT
13 Group:          X11
14 %define         _snap   20060307
15 Source0:        %{name}-%{_snap}.tar.bz2
16 # Source0-md5:  516d5510394476e594ad26634aac84a6
17 Patch0:         %{name}-switcher-all-desktops.patch
18 %if %{with gconf} || %{with gnome}
19 BuildRequires:  GConf2-devel >= 2.0
20 %endif
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  libpng-devel
26 BuildRequires:  libsvg-cairo-devel
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 BuildRequires:  startup-notification-devel >= 0.7
30 BuildRequires:  xorg-lib-libSM-devel
31 BuildRequires:  xorg-lib-libXcomposite-devel
32 BuildRequires:  xorg-lib-libXdamage-devel
33 BuildRequires:  xorg-lib-libXrandr-devel
34 %if %{with gnome}
35 BuildRequires:  control-center-devel >= 2.0
36 BuildRequires:  gnome-desktop-devel >= 2.0
37 BuildRequires:  gtk+2-devel >= 2:2.8.0
38 BuildRequires:  libwnck-devel >= 2.0
39 %endif
40 %if %{with kde}
41 BuildRequires:  QtCore-devel
42 BuildRequires:  QtGui-devel
43 BuildRequires:  qt4-build
44 %endif
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Compiz is an OpenGL compositing manager that use
49 GLX_EXT_texture_from_pixmap for binding redirected top-level
50 windows to texture objects. It has a flexible plug-in system
51 and it is designed to run well on most graphics hardware.
52
53 %description -l pl
54 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
55 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien
56 do tekstur. Posiada elastyczny system wtyczek i jest tak
57 zaprojektowany, by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
58
59 %package devel
60 Summary:        Header files for compiz
61 Summary(pl):    Pliki nag³ówkowe dla compiza
62 Group:          Development
63 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
64 Requires:       OpenGL-devel
65 Requires:       libpng-devel
66 Requires:       startup-notification-devel >= 0.7
67 Requires:       xorg-lib-libSM-devel
68 Requires:       xorg-lib-libXcomposite-devel
69 Requires:       xorg-lib-libXdamage-devel
70 Requires:       xorg-lib-libXrandr-devel
71
72 %description devel
73 Header files for compiz.
74
75 %description devel -l pl
76 Pliki nag³ówkowe dla compiza.
77
78 %package gnome-settings
79 Summary:        Compiz settings for gnome control panel
80 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
81 Group:          X11
82 Requires:       %{name} = %{version}-%{release}
83
84 %description gnome-settings
85 Compiz settings for gnome control panel.
86
87 %description gnome-settings -l pl
88 Ustawienia compiza dla panelu sterowania gnome.
89
90 %package gnome-decorator
91 Summary:        Window decorator for gnome
92 Summary(pl):    Dekorator okien dla gnome
93 Group:          X11
94 Requires:       %{name} = %{version}-%{release}
95
96 %description gnome-decorator
97 Window decorator for gnome.
98
99 %description gnome-decorator -l pl
100 Dekorator okien dla gnome.
101
102 %package kde-decorator
103 Summary:        Window decorator for KDE
104 Summary(pl):    Dekorator okien dla KDE
105 Group:          X11
106 Requires:       %{name} = %{version}-%{release}
107
108 %description kde-decorator
109 Window decorator for KDE.
110
111 %description kde-decorator -l pl
112 Dekorator okien dla KDE.
113
114 %prep
115 %setup -q -n %{name}-%{_snap}
116 %patch0 -p1
117
118 %build
119 autoreconf -v --install
120
121 %configure \
122         --disable-static \
123         --enable-svg \
124         --enable-libsvg-cairo \
125         %{!?with_gconf:--disable-gconf} \
126         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
127         --%{?with_kde:en}%{!?with_kde:dis}able-kde
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog README TODO
145 %attr(755,root,root) %{_bindir}/compiz
146 %dir %{_libdir}/compiz
147 %attr(755,root,root) %{_libdir}/compiz/*.so
148 %{_datadir}/compiz
149 %if %{with gnome}
150 %{_datadir}/gnome/wm-properties/*
151 %endif
152
153 %files devel
154 %defattr(644,root,root,755)
155 %{_includedir}/compiz
156 %{_pkgconfigdir}/compiz.pc
157
158 %if %{with gnome}
159 %files gnome-settings
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
162
163 %files gnome-decorator
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/gnome-window-decorator
166 %endif
167
168 %if %{with kde}
169 %files kde-decorator
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/kde-window-decorator
172 %endif
This page took 0.418375 seconds and 4 git commands to generate.