]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- added gconf bcond, revised deps
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (currently not working)
6 #
7 Summary:        OpenGL window and compositing manager
8 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
9 Name:           compiz
10 Version:        0.0.5
11 Release:        2
12 License:        GPL/MIT
13 Group:          X11
14 %define         _snap   20060303
15 Source0:        %{name}-%{_snap}.tar.bz2
16 # Source0-md5:  41917dac89790d83f9d1d634f2491858
17 Patch0:         %{name}-switcher-all-desktops.patch
18 %if %{with gconf} || %{with gnome}
19 BuildRequires:  GConf2-devel >= 2.0
20 %endif
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  libpng-devel
26 BuildRequires:  libsvg-cairo-devel
27 BuildRequires:  libtool
28 BuildRequires:  startup-notification-devel >= 0.7
29 BuildRequires:  xorg-lib-libSM-devel
30 BuildRequires:  xorg-lib-libXcomposite-devel
31 BuildRequires:  xorg-lib-libXdamage-devel
32 BuildRequires:  xorg-lib-libXrandr-devel
33 %if %{with gnome}
34 BuildRequires:  control-center-devel >= 2.0
35 BuildRequires:  gnome-desktop-devel >= 2.0
36 BuildRequires:  gtk+2-devel >= 2:2.8.0
37 BuildRequires:  libwnck-devel >= 2.0
38 %endif
39 %if %{with kde}
40 BuildRequires:  QtCore-devel
41 BuildRequires:  QtGui-devel
42 BuildRequires:  qt4-build
43 %endif
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Compiz is an OpenGL compositing manager that use
48 GLX_EXT_texture_from_pixmap for binding redirected top-level
49 windows to texture objects. It has a flexible plug-in system
50 and it is designed to run well on most graphics hardware.
51
52 %description -l pl
53 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
54 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien
55 do tekstur. Posiada elastyczny system wtyczek i jest tak
56 zaprojektowany, by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
57
58 %package devel
59 Summary:        Header files for compiz
60 Summary(pl):    Pliki nag³ówkowe dla compiza
61 Group:          Development
62 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
63 Requires:       OpenGL-devel
64 Requires:       libpng-devel
65 Requires:       startup-notification-devel >= 0.7
66 Requires:       xorg-lib-libSM-devel
67 Requires:       xorg-lib-libXcomposite-devel
68 Requires:       xorg-lib-libXdamage-devel
69 Requires:       xorg-lib-libXrandr-devel
70
71 %description devel
72 Header files for compiz.
73
74 %description devel -l pl
75 Pliki nag³ówkowe dla compiza.
76
77 %package gnome-settings
78 Summary:        Compiz settings for gnome control panel
79 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
80 Group:          X11
81 Requires:       %{name} = %{version}-%{release}
82
83 %description gnome-settings
84 Compiz settings for gnome control panel.
85
86 %description gnome-settings -l pl
87 Ustawienia compiza dla panelu sterowania gnome.
88
89 %package gnome-decorator
90 Summary:        Window decorator for gnome
91 Summary(pl):    Dekorator okien dla gnome
92 Group:          X11
93 Requires:       %{name} = %{version}-%{release}
94
95 %description gnome-decorator
96 Window decorator for gnome.
97
98 %description gnome-decorator -l pl
99 Dekorator okien dla gnome.
100
101 %package kde-decorator
102 Summary:        Window decorator for KDE
103 Summary(pl):    Dekorator okien dla KDE
104 Group:          X11
105 Requires:       %{name} = %{version}-%{release}
106
107 %description kde-decorator
108 Window decorator for KDE.
109
110 %description kde-decorator -l pl
111 Dekorator okien dla KDE.
112
113 %prep
114 %setup -q -n %{name}-%{_snap}
115 %patch0 -p1
116
117 %build
118 autoreconf -v --install
119
120 %configure \
121         --disable-static \
122         --enable-svg \
123         --enable-libsvg-cairo \
124         %{!?with_gconf:--disable-gconf} \
125         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
126         --%{?with_kde:en}%{!?with_kde:dis}able-kde
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog README TODO
144 %attr(755,root,root) %{_bindir}/compiz
145 %dir %{_libdir}/compiz
146 %attr(755,root,root) %{_libdir}/compiz/*.so
147 %{_datadir}/compiz
148 %if %{with gnome}
149 %{_datadir}/gnome/wm-properties/*
150 %endif
151
152 %files devel
153 %defattr(644,root,root,755)
154 %{_includedir}/compiz
155 %{_pkgconfigdir}/compiz.pc
156
157 %if %{with gnome}
158 %files gnome-settings
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
161
162 %files gnome-decorator
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/gnome-window-decorator
165 %endif
166
167 %if %{with kde}
168 %files kde-decorator
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/kde-window-decorator
171 %endif
This page took 0.04684 seconds and 4 git commands to generate.