]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- noted URL to first official release
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (not working)
6 #
7 %define         _snap   20060712
8 #
9 Summary:        OpenGL window and compositing manager
10 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
11 Name:           compiz
12 Version:        0.0.13
13 Release:        1.%{_snap}.1
14 License:        GPL or MIT
15 Group:          X11
16 #Source0:       http://xorg.freedesktop.org/releases/individual/app/%{name}-%{version}.tar.bz2
17 Source0:        %{name}-%{_snap}.tar.bz2
18 # Source0-md5:  852c1c9c41ae0b593433fac025284880
19 Source1:        %{name}-pld.png
20 # Source1-md5:  3050dc90fd4e5e990bb5baeb82bd3c8a
21 Patch0:         %{name}-minimize-scaler-mod.patch
22 URL:            http://xorg.freedesktop.org/
23 %if %{with gconf} || %{with gnome}
24 BuildRequires:  GConf2-devel >= 2.0
25 %endif
26 BuildRequires:  Mesa-libGL-devel >= 6.5-1.20060411.2
27 BuildRequires:  autoconf >= 2.57
28 BuildRequires:  automake
29 BuildRequires:  glib2-devel >= 2.0
30 BuildRequires:  glitz-devel
31 BuildRequires:  intltool
32 BuildRequires:  libpng-devel
33 BuildRequires:  libsvg-cairo-devel
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig
36 BuildRequires:  startup-notification-devel >= 0.7
37 BuildRequires:  xorg-lib-libSM-devel
38 BuildRequires:  xorg-lib-libXcomposite-devel
39 BuildRequires:  xorg-lib-libXdamage-devel
40 BuildRequires:  xorg-lib-libXrandr-devel
41 BuildRequires:  xorg-lib-libXres-devel
42 %if %{with gnome}
43 BuildRequires:  control-center-devel >= 2.0
44 BuildRequires:  gnome-desktop-devel >= 2.0
45 BuildRequires:  gnome-menus-devel
46 BuildRequires:  gtk+2-devel >= 2:2.8.0
47 BuildRequires:  libwnck-devel >= 2.14.1-2
48 %endif
49 %if %{with kde}
50 BuildRequires:  QtCore-devel
51 BuildRequires:  QtGui-devel
52 BuildRequires:  qt4-build
53 %endif
54 Requires(post,preun):   GConf2
55 Conflicts:      xorg-xserver-xgl < 0.0.20060505
56 Obsoletes:      compiz-opacity
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Compiz is an OpenGL compositing manager that use
61 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
62 to texture objects. It has a flexible plug-in system and it is
63 designed to run well on most graphics hardware.
64
65 %description -l pl
66 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
67 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
68 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
69 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
70
71 %package devel
72 Summary:        Header files for compiz
73 Summary(pl):    Pliki nag³ówkowe dla compiza
74 Group:          Development
75 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
76 Requires:       OpenGL-devel
77 Requires:       libpng-devel
78 Requires:       startup-notification-devel >= 0.7
79 Requires:       xorg-lib-libSM-devel
80 Requires:       xorg-lib-libXcomposite-devel
81 Requires:       xorg-lib-libXdamage-devel
82 Requires:       xorg-lib-libXrandr-devel
83
84 %description devel
85 Header files for compiz.
86
87 %description devel -l pl
88 Pliki nag³ówkowe dla compiza.
89
90 %package gnome-settings
91 Summary:        Compiz settings for gnome control panel
92 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
93 Group:          X11
94 Requires:       %{name} = %{version}-%{release}
95
96 %description gnome-settings
97 Compiz settings for gnome control panel.
98
99 %description gnome-settings -l pl
100 Ustawienia compiza dla panelu sterowania gnome.
101
102 %package gnome-decorator
103 Summary:        Window decorator for gnome
104 Summary(pl):    Dekorator okien dla gnome
105 Group:          X11
106 Requires:       %{name} = %{version}-%{release}
107
108 %description gnome-decorator
109 Window decorator for gnome.
110
111 %description gnome-decorator -l pl
112 Dekorator okien dla gnome.
113
114 %package kde-decorator
115 Summary:        Window decorator for KDE
116 Summary(pl):    Dekorator okien dla KDE
117 Group:          X11
118 Requires:       %{name} = %{version}-%{release}
119
120 %description kde-decorator
121 Window decorator for KDE.
122
123 %description kde-decorator -l pl
124 Dekorator okien dla KDE.
125
126 %prep
127 %setup -q -n %{name}-%{_snap}
128 # doesn't apply anymore
129 #%patch0 -p0
130
131 %build
132 autoreconf -v --install
133 ln -s ../po config/po
134 %{__intltoolize}
135 rm config/po
136 sed -i -e 's/^mkinstalldirs.*/MKINSTALLDIRS=mkdir -p/' po/Makefile.in.in
137
138 %configure \
139         --disable-static \
140         --enable-svg \
141         --enable-libsvg-cairo \
142         %{!?with_gconf:--disable-gconf} \
143         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
144         --%{?with_kde:en}%{!?with_kde:dis}able-kde
145
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} install \
152         desktopfilesdir=%{_datadir}/wm-properties \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/compiz/novell.png
156
157 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
158
159 %find_lang %{name}
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post
165 %gconf_schema_install compiz.schemas
166
167 %preun
168 %gconf_schema_uninstall compiz.schemas
169
170 %files -f %{name}.lang
171 %defattr(644,root,root,755)
172 %doc AUTHORS ChangeLog README TODO
173 %attr(755,root,root) %{_bindir}/compiz
174 %dir %{_libdir}/compiz
175 %attr(755,root,root) %{_libdir}/compiz/*.so
176 %{_datadir}/compiz
177 %if %{with gnome}
178 %{_datadir}/wm-properties/*
179 %endif
180 %{_sysconfdir}/gconf/schemas/compiz.schemas
181
182 %files devel
183 %defattr(644,root,root,755)
184 %{_includedir}/compiz
185 %{_pkgconfigdir}/compiz.pc
186
187 %if %{with gnome}
188 %files gnome-settings
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
191
192 %files gnome-decorator
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_bindir}/gnome-window-decorator
195 %endif
196
197 %if %{with kde}
198 %files kde-decorator
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/kde-window-decorator
201 %endif
This page took 0.068129 seconds and 4 git commands to generate.