]> git.pld-linux.org Git - packages/commoncpp2.git/blob - commoncpp2.spec
- more regeneration, now linking ok
[packages/commoncpp2.git] / commoncpp2.spec
1 Summary:        A GNU package for creating portable C++ programs
2 Summary(pl):    Pakiet GNU do tworzenia przeno¶nych programów w C++
3 Name:           commoncpp2
4 Version:        1.5.3
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnu.org/pub/gnu/commoncpp/%{name}-%{version}.tar.gz
9 # Source0-md5:  559c6cb2e1fbbaa6d1856d037e3722b2
10 Patch0:         %{name}-Makefile.patch
11 URL:            http://www.gnu.org/software/commoncpp/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  doxygen
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  libxml2-devel
18 BuildRequires:  openssl-devel
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is the second major release of GNU Common C++. GNU Common C++ "2"
24 is a GNU package which offers portable "abstraction" of system
25 services such as threads, networks, and sockets. GNU Common C++ "2"
26 also offers individual frameworks generally useful to developing
27 portable C++ applications including a object persistance engine, math
28 libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
29 highly portable. GNU Common C++ "2" will support most Unix operating
30 systems as well as Win32, in addition to GNU/Linux.
31
32 %description -l pl
33 Drugie g³ówne wydanie GNU Common C++. GNU Common C++ oferuje przeno¶ne
34 abstrakcje us³ug systemowych takich jak w±tki, sieci i gniazda.
35 Oferuje tak¿e poszczególne szkielety u¿yteczne do rozwijania
36 przeno¶nych aplikacji C++ zawieraj±ce silnik trwa³ych obiektów,
37 biblioteki matematyczne, w±tków, gniazd itd. GNU Common C++ jest ma³y
38 i przeno¶ny. Oprócz GNU/Linuksa obs³uguje tak¿e wiêkszo¶æ uniksowych
39 systemów operacyjnych oraz Win32.
40
41 %package devel
42 Summary:        Header files for commoncpp2 library
43 Summary(pl):    Pliki nag³ówkowe biblioteki commoncpp2
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       libstdc++-devel
47 Requires:       libxml2-devel
48 Requires:       zlib-devel
49
50 %description devel
51 Header files for commoncpp2 library.
52
53 %description devel -l pl
54 Pliki nag³ówkowe biblioteki commoncpp2.
55
56 %package static
57 Summary:        Static commoncpp2 library
58 Summary(pl):    Statyczna biblioteka commoncpp2
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static commoncpp2 library.
64
65 %description static -l pl
66 Statyczna biblioteka commoncpp2.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 cp -f /usr/share/automake/config.sub .
79 %configure \
80         --with-openssl
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %post devel
96 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
97
98 %postun devel
99 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
104 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc doc/html/*.html doc/html/*.*g*
109 %attr(755,root,root) %{_bindir}/*
110 %attr(755,root,root) %{_libdir}/lib*.so
111 %{_libdir}/lib*.la
112 %{_includedir}/cc++
113 %{_aclocaldir}/*.m4
114 %{_pkgconfigdir}/*.pc
115 %{_infodir}/*.info*
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/lib*.a
This page took 0.066134 seconds and 4 git commands to generate.