]> git.pld-linux.org Git - packages/commoncpp2.git/blob - commoncpp2.spec
- release 2
[packages/commoncpp2.git] / commoncpp2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        A GNU package for creating portable C++ programs
6 Summary(pl.UTF-8):      Pakiet GNU do tworzenia przenośnych programów w C++
7 Name:           commoncpp2
8 Version:        1.7.1
9 Release:        2
10 License:        GPL
11 Group:          Libraries
12 Source0:        http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
13 # Source0-md5:  e1041356c3129e4d3d3d6a44f281d905
14 Patch0:         %{name}-lt.patch
15 URL:            http://www.gnu.org/software/commoncpp/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  doxygen
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool
21 BuildRequires:  libxml2-devel
22 BuildRequires:  openssl-devel
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is the second major release of GNU Common C++. GNU Common C++ "2"
28 is a GNU package which offers portable "abstraction" of system
29 services such as threads, networks, and sockets. GNU Common C++ "2"
30 also offers individual frameworks generally useful to developing
31 portable C++ applications including a object persistance engine, math
32 libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
33 highly portable. GNU Common C++ "2" will support most Unix operating
34 systems as well as Win32, in addition to GNU/Linux.
35
36 %description -l pl.UTF-8
37 Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
38 abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
39 Oferuje także poszczególne szkielety użyteczne do rozwijania
40 przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
41 biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
42 i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
43 systemów operacyjnych oraz Win32.
44
45 %package devel
46 Summary:        Header files for commoncpp2 library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki commoncpp2
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       libstdc++-devel
51 Requires:       libxml2-devel
52 Requires:       openssl-devel
53 Requires:       zlib-devel
54
55 %description devel
56 Header files for commoncpp2 library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki commoncpp2.
60
61 %package static
62 Summary:        Static commoncpp2 library
63 Summary(pl.UTF-8):      Statyczna biblioteka commoncpp2
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static commoncpp2 library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka commoncpp2.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 %{__libtoolize}
79 %{__aclocal} -I m4
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure \
84         %{!?with_static_libs:--disable-static} \
85         --with-openssl
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %post devel     -p      /sbin/postshell
101 -/usr/sbin/fix-info-dir -c %{_infodir}
102
103 %postun devel   -p      /sbin/postshell
104 -/usr/sbin/fix-info-dir -c %{_infodir}
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
109 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
110 %ghost %{_libdir}/libccext2-1.7.so.0
111 %ghost %{_libdir}/libccgnu2-1.7.so.0
112
113 %files devel
114 %defattr(644,root,root,755)
115 %doc doc/html/*.html doc/html/*.*g*
116 %attr(755,root,root) %{_bindir}/*
117 %attr(755,root,root) %{_libdir}/lib*.so
118 %{_libdir}/lib*.la
119 %{_includedir}/cc++
120 %{_aclocaldir}/*.m4
121 %{_pkgconfigdir}/*.pc
122 %{_infodir}/*.info*
123
124 %if %{with static_libs}
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/lib*.a
128 %endif
This page took 0.105442 seconds and 4 git commands to generate.