]> git.pld-linux.org Git - packages/commoncpp2.git/blob - commoncpp2.spec
437672d7c3189f803882f5654a4f16c3ed432efe
[packages/commoncpp2.git] / commoncpp2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        A GNU package for creating portable C++ programs
6 Summary(pl.UTF-8):      Pakiet GNU do tworzenia przenośnych programów w C++
7 Name:           commoncpp2
8 Version:        1.7.3
9 Release:        4
10 License:        GPL
11 Group:          Libraries
12 Source0:        http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
13 # Source0-md5:  ca741179a728d264eb276ae471ebaf70
14 Patch0:         %{name}-lt.patch
15 Patch1:         %{name}-gcc4.patch
16 URL:            http://www.gnu.org/software/commoncpp/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  doxygen
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  libxml2-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  zlib-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         skip_post_check_so      libccgnu2-.*\.so\..* libccext2-.*\.so\..*
28
29 %description
30 This is the second major release of GNU Common C++. GNU Common C++ "2"
31 is a GNU package which offers portable "abstraction" of system
32 services such as threads, networks, and sockets. GNU Common C++ "2"
33 also offers individual frameworks generally useful to developing
34 portable C++ applications including a object persistance engine, math
35 libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
36 highly portable. GNU Common C++ "2" will support most Unix operating
37 systems as well as Win32, in addition to GNU/Linux.
38
39 %description -l pl.UTF-8
40 Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
41 abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
42 Oferuje także poszczególne szkielety użyteczne do rozwijania
43 przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
44 biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
45 i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
46 systemów operacyjnych oraz Win32.
47
48 %package devel
49 Summary:        Header files for commoncpp2 library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki commoncpp2
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       libstdc++-devel
54 Requires:       libxml2-devel
55 Requires:       openssl-devel
56 Requires:       zlib-devel
57
58 %description devel
59 Header files for commoncpp2 library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki commoncpp2.
63
64 %package static
65 Summary:        Static commoncpp2 library
66 Summary(pl.UTF-8):      Statyczna biblioteka commoncpp2
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static commoncpp2 library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka commoncpp2.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         %{!?with_static_libs:--disable-static} \
89         --with-openssl
90 %{__make} -j1
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %post devel     -p      /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %postun devel   -p      /sbin/postshell
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
113 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
114 %ghost %{_libdir}/libccext2-1.7.so.0
115 %ghost %{_libdir}/libccgnu2-1.7.so.0
116
117 %files devel
118 %defattr(644,root,root,755)
119 %doc doc/html/*.html doc/html/*.*g*
120 %attr(755,root,root) %{_bindir}/*
121 %attr(755,root,root) %{_libdir}/lib*.so
122 %{_libdir}/lib*.la
123 %{_includedir}/cc++
124 %{_aclocaldir}/*.m4
125 %{_pkgconfigdir}/*.pc
126 %{_infodir}/*.info*
127
128 %if %{with static_libs}
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/lib*.a
132 %endif
This page took 0.033185 seconds and 3 git commands to generate.