]> git.pld-linux.org Git - packages/colord.git/blob - colord.spec
7ba686530ad735f7531da57b6633f9fac7e62e6b
[packages/colord.git] / colord.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  vala            # don't build Vala API
6 #
7 Summary:        Color daemon - system daemon for managing color devices
8 Summary(pl.UTF-8):      Demon colord - usługa systemowa do zarządzania urządzeniami obsługującymi kolory
9 Name:           colord
10 Version:        0.1.13
11 Release:        1
12 License:        GPL v2+ and LGPL v2+
13 Group:          Daemons
14 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  37437a2119d7c89fe3c991ee4c148f94
16 URL:            http://www.freedesktop.org/software/colord/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  dbus-devel
20 BuildRequires:  gettext-devel >= 0.17
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.8
23 BuildRequires:  gtk-doc >= 1.9
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  lcms2-devel >= 2.2
26 BuildRequires:  libtool
27 BuildRequires:  libusb-devel >= 1.0.0
28 BuildRequires:  pkgconfig
29 BuildRequires:  polkit-devel >= 0.97
30 BuildRequires:  sane-backends-devel
31 BuildRequires:  sqlite3-devel
32 BuildRequires:  udev-glib-devel
33 %{?with_vala:BuildRequires:     vala}
34 Requires:       %{name}-libs = %{version}-%{release}
35 Suggests:       shared-color-profiles
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 colord is a low level system activated daemon that maps color devices
40 to color profiles in the system context.
41
42 %description -l pl.UTF-8
43 colord to niskopoziomowa usługa systemowa odwzorowująca urządzenia
44 obsługujące kolory na profile kolorów w kontekście systemu.
45
46 %package libs
47 Summary:        colord library
48 Summary(pl.UTF-8):      Biblioteka colord
49 Group:          Libraries
50 Suggests:       %{name} = %{version}-%{release}
51 Conflicts:      colord < 0.1.12-4
52
53 %description libs
54 colord library.
55
56 %description libs -l pl.UTF-8
57 Biblioteka colord.
58
59 %package devel
60 Summary:        Header files for colord library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord
62 Group:          Development/Libraries
63 Requires:       %{name}-libs = %{version}-%{release}
64 Requires:       dbus-devel
65 Requires:       glib2-devel >= 1:2.28.0
66
67 %description devel
68 Header files for colord library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki colord.
72
73 %package static
74 Summary:        Static colord library
75 Summary(pl.UTF-8):      Statyczna biblioteka colord
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static colord library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka colord.
84
85 %package apidocs
86 Summary:        colord API documentation
87 Summary(pl.UTF-8):      Dokumentacja API colord
88 Group:          Documentation
89 Requires:       gtk-doc-common
90
91 %description apidocs
92 colord API documentation.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API colord.
96
97 %package -n vala-colord
98 Summary:        colord API for Vala language
99 Summary(pl.UTF-8):      API colord dla języka Vala
100 Group:          Development/Libraries
101 Requires:       %{name}-devel = %{version}-%{release}
102
103 %description -n vala-colord
104 colord API for Vala language.
105
106 %description -n vala-colord -l pl.UTF-8
107 API colord dla języka Vala.
108
109 %prep
110 %setup -q
111
112 %build
113 %{__intltoolize}
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure \
120         --disable-silent-rules \
121         %{__enable_disable apidocs gtk-doc} \
122         %{__enable_disable static_libs static} \
123         --with-html-dir=%{_gtkdocdir}
124 # doc build is broken with -j
125 %{__make} -j1
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.a
135 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.la
136
137 # the same as it locale
138 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/it_IT
139
140 %find_lang %{name}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   libs -p /sbin/ldconfig
146 %postun libs -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README TODO
151 %attr(755,root,root) %{_bindir}/cd-create-profile
152 %attr(755,root,root) %{_bindir}/cd-fix-profile
153 %attr(755,root,root) %{_bindir}/colormgr
154 %attr(755,root,root) %{_libexecdir}/colord
155 %dir %{_libdir}/colord-sensors
156 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_dummy.so
157 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_huey.so
158 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_munki.so
159 %dir %{_datadir}/color/icc/colord
160 %{_datadir}/color/icc/colord/*.icc
161 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Device.xml
162 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Profile.xml
163 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Sensor.xml
164 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.xml
165 %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
166 %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
167 %{_mandir}/man1/cd-create-profile.1*
168 %{_mandir}/man1/cd-fix-profile.1*
169 %{_mandir}/man1/colormgr.1*
170 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/colord.conf
171 /etc/dbus-1/system.d/org.freedesktop.ColorManager.conf
172 /lib/udev/rules.d/69-cd-sensors.rules
173 /lib/udev/rules.d/95-cd-devices.rules
174 %dir /var/lib/colord
175
176 %files libs
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libcolord.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libcolord.so.1
180 %{_libdir}/girepository-1.0/Colord-1.0.typelib
181
182 %files devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libcolord.so
185 %{_includedir}/colord-1
186 %{_pkgconfigdir}/colord.pc
187 %{_datadir}/gir-1.0/Colord-1.0.gir
188
189 %if %{with static_libs}
190 %files static
191 %defattr(644,root,root,755)
192 %{_libdir}/libcolord.a
193 %endif
194
195 %if %{with apidocs}
196 %files apidocs
197 %defattr(644,root,root,755)
198 %{_gtkdocdir}/colord
199 %endif
200
201 %if %{with vala}
202 %files -n vala-colord
203 %defattr(644,root,root,755)
204 %{_datadir}/vala/vapi/colord.vapi
205 %endif
This page took 0.075568 seconds and 3 git commands to generate.