]> git.pld-linux.org Git - packages/colord.git/blob - colord.spec
456aff1a770724cbafcd81372a8a4d6bc7155826
[packages/colord.git] / colord.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  vala            # don't build Vala API
6 #
7 Summary:        Color daemon - system daemon for managing color devices
8 Summary(pl.UTF-8):      Demon colord - usługa systemowa do zarządzania urządzeniami obsługującymi kolory
9 Name:           colord
10 Version:        0.1.15
11 Release:        1
12 License:        GPL v2+ and LGPL v2+
13 Group:          Daemons
14 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  f212cbc7eece3fa403c1507fc8b10dbb
16 URL:            http://www.freedesktop.org/software/colord/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  dbus-devel
20 BuildRequires:  gettext-devel >= 0.17
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.8
23 BuildRequires:  gtk-doc >= 1.9
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  lcms2-devel >= 2.2
26 BuildRequires:  libgusb-devel >= 0.1.1
27 BuildRequires:  libtool
28 BuildRequires:  libusb-devel >= 1.0.0
29 BuildRequires:  pkgconfig
30 BuildRequires:  polkit-devel >= 0.97
31 BuildRequires:  sane-backends-devel >= 1.0.20-3
32 BuildRequires:  sqlite3-devel
33 BuildRequires:  udev-glib-devel
34 %{?with_vala:BuildRequires:     vala}
35 Requires:       %{name}-libs = %{version}-%{release}
36 Suggests:       shared-color-profiles
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 colord is a low level system activated daemon that maps color devices
41 to color profiles in the system context.
42
43 %description -l pl.UTF-8
44 colord to niskopoziomowa usługa systemowa odwzorowująca urządzenia
45 obsługujące kolory na profile kolorów w kontekście systemu.
46
47 %package libs
48 Summary:        colord library
49 Summary(pl.UTF-8):      Biblioteka colord
50 Group:          Libraries
51 Suggests:       %{name} = %{version}-%{release}
52 Conflicts:      colord < 0.1.12-4
53
54 %description libs
55 colord library.
56
57 %description libs -l pl.UTF-8
58 Biblioteka colord.
59
60 %package devel
61 Summary:        Header files for colord library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord
63 Group:          Development/Libraries
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       dbus-devel
66 Requires:       glib2-devel >= 1:2.28.0
67
68 %description devel
69 Header files for colord library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki colord.
73
74 %package static
75 Summary:        Static colord library
76 Summary(pl.UTF-8):      Statyczna biblioteka colord
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static colord library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka colord.
85
86 %package apidocs
87 Summary:        colord API documentation
88 Summary(pl.UTF-8):      Dokumentacja API colord
89 Group:          Documentation
90 Requires:       gtk-doc-common
91
92 %description apidocs
93 colord API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API colord.
97
98 %package -n vala-colord
99 Summary:        colord API for Vala language
100 Summary(pl.UTF-8):      API colord dla języka Vala
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103
104 %description -n vala-colord
105 colord API for Vala language.
106
107 %description -n vala-colord -l pl.UTF-8
108 API colord dla języka Vala.
109
110 %prep
111 %setup -q
112
113 %build
114 %{__intltoolize}
115 %{__libtoolize}
116 %{__aclocal}
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         --disable-silent-rules \
122         %{__enable_disable apidocs gtk-doc} \
123         %{__enable_disable static_libs static} \
124         --with-html-dir=%{_gtkdocdir}
125 # doc build is broken with -j
126 %{__make} -j1
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
135 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.a
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.la
137
138 # the same as it locale
139 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/it_IT
140
141 %find_lang %{name}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   libs -p /sbin/ldconfig
147 %postun libs -p /sbin/ldconfig
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog NEWS README TODO
152 %attr(755,root,root) %{_bindir}/cd-create-profile
153 %attr(755,root,root) %{_bindir}/cd-fix-profile
154 %attr(755,root,root) %{_bindir}/colormgr
155 %attr(755,root,root) %{_libexecdir}/colord
156 %dir %{_libdir}/colord-sensors
157 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_colorhug.so
158 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_dummy.so
159 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_huey.so
160 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_munki.so
161 %dir %{_datadir}/color/icc/colord
162 %{_datadir}/color/icc/colord/*.icc
163 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Device.xml
164 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Profile.xml
165 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Sensor.xml
166 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.xml
167 %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
168 %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
169 %{_mandir}/man1/cd-create-profile.1*
170 %{_mandir}/man1/cd-fix-profile.1*
171 %{_mandir}/man1/colormgr.1*
172 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/colord.conf
173 /etc/dbus-1/system.d/org.freedesktop.ColorManager.conf
174 /lib/udev/rules.d/69-cd-sensors.rules
175 /lib/udev/rules.d/95-cd-devices.rules
176 %dir /var/lib/colord
177
178 %files libs
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libcolord.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libcolord.so.1
182 %{_libdir}/girepository-1.0/Colord-1.0.typelib
183
184 %files devel
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libcolord.so
187 %{_includedir}/colord-1
188 %{_pkgconfigdir}/colord.pc
189 %{_datadir}/gir-1.0/Colord-1.0.gir
190
191 %if %{with static_libs}
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/libcolord.a
195 %endif
196
197 %if %{with apidocs}
198 %files apidocs
199 %defattr(644,root,root,755)
200 %{_gtkdocdir}/colord
201 %endif
202
203 %if %{with vala}
204 %files -n vala-colord
205 %defattr(644,root,root,755)
206 %{_datadir}/vala/vapi/colord.vapi
207 %endif
This page took 0.049783 seconds and 3 git commands to generate.