]> git.pld-linux.org Git - packages/colord.git/blob - colord.spec
0c48042488d1cfbdb2c7aaf2b82383a6b4c97709
[packages/colord.git] / colord.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  vala            # don't build Vala API
6 #
7 Summary:        Color daemon - system daemon for managing color devices
8 Summary(pl.UTF-8):      Demon colord - usługa systemowa do zarządzania urządzeniami obsługującymi kolory
9 Name:           colord
10 Version:        0.1.23
11 Release:        1
12 License:        GPL v2+ and LGPL v2+
13 Group:          Daemons
14 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  e1e3bfd048afa63e3187e9b9dc68f0c7
16 URL:            http://www.freedesktop.org/software/colord/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  dbus-devel
20 BuildRequires:  gettext-devel >= 0.17
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.8
23 BuildRequires:  gtk-doc >= 1.9
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  lcms2-devel >= 2.2
26 BuildRequires:  libgusb-devel >= 0.1.1
27 BuildRequires:  libtool >= 2:2.0
28 BuildRequires:  libusb-devel >= 1.0.0
29 BuildRequires:  pkgconfig
30 BuildRequires:  polkit-devel >= 0.103
31 BuildRequires:  rpmbuild(macros) >= 1.644
32 BuildRequires:  sane-backends-devel >= 1.0.20-3
33 BuildRequires:  sqlite3-devel
34 BuildRequires:  udev-devel
35 BuildRequires:  udev-glib-devel
36 %{?with_vala:BuildRequires:     vala}
37 Requires(post,preun,postun):    systemd-units >= 38
38 Requires:       %{name}-libs = %{version}-%{release}
39 Requires:       polkit-libs >= 0.103
40 Requires:       systemd-units >= 38
41 Suggests:       shared-color-profiles
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 colord is a low level system activated daemon that maps color devices
46 to color profiles in the system context.
47
48 %description -l pl.UTF-8
49 colord to niskopoziomowa usługa systemowa odwzorowująca urządzenia
50 obsługujące kolory na profile kolorów w kontekście systemu.
51
52 %package libs
53 Summary:        colord library
54 Summary(pl.UTF-8):      Biblioteka colord
55 Group:          Libraries
56 Requires:       glib2 >= 1:2.28.0
57 Suggests:       %{name} = %{version}-%{release}
58 Conflicts:      colord < 0.1.12-4
59
60 %description libs
61 colord library.
62
63 %description libs -l pl.UTF-8
64 Biblioteka colord.
65
66 %package devel
67 Summary:        Header files for colord library
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord
69 Group:          Development/Libraries
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       dbus-devel
72 Requires:       glib2-devel >= 1:2.28.0
73
74 %description devel
75 Header files for colord library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki colord.
79
80 %package static
81 Summary:        Static colord library
82 Summary(pl.UTF-8):      Statyczna biblioteka colord
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static colord library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka colord.
91
92 %package apidocs
93 Summary:        colord API documentation
94 Summary(pl.UTF-8):      Dokumentacja API colord
95 Group:          Documentation
96 Requires:       gtk-doc-common
97
98 %description apidocs
99 colord API documentation.
100
101 %description apidocs -l pl.UTF-8
102 Dokumentacja API colord.
103
104 %package -n vala-colord
105 Summary:        colord API for Vala language
106 Summary(pl.UTF-8):      API colord dla języka Vala
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description -n vala-colord
111 colord API for Vala language.
112
113 %description -n vala-colord -l pl.UTF-8
114 API colord dla języka Vala.
115
116 %package -n bash-completion-colord
117 Summary:        bash-completion for colormgr console commands
118 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń terminalowych colormgr
119 Group:          Applications/Shells
120 Requires:       bash-completion
121
122 %description -n bash-completion-colord
123 bash-completion for colormgr console commands.
124
125 %description -n bash-completion-colord -l pl.UTF-8
126 Bashowe uzupełnianie poleceń terminalowych colormgr.
127
128 %prep
129 %setup -q
130
131 %build
132 %{__intltoolize}
133 %{__libtoolize}
134 %{__aclocal} -I m4
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         --disable-silent-rules \
140         %{__enable_disable apidocs gtk-doc} \
141         %{__enable_disable static_libs static} \
142         --with-html-dir=%{_gtkdocdir} \
143         --with-systemdsystemunitdir=%{systemdunitdir}
144 # doc build is broken with -j
145 %{__make} -j1
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
154 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.a
155 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.la
156
157 # the same as it locale
158 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/it_IT
159 # empty version of bg locale
160 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/bg_BG
161
162 %find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post
168 %systemd_post colord.service
169
170 %preun
171 %systemd_preun colord.service
172
173 %postun
174 %systemd_reload
175
176 %post   libs -p /sbin/ldconfig
177 %postun libs -p /sbin/ldconfig
178
179 %files -f %{name}.lang
180 %defattr(644,root,root,755)
181 %doc AUTHORS ChangeLog NEWS README TODO
182 %attr(755,root,root) %{_bindir}/cd-create-profile
183 %attr(755,root,root) %{_bindir}/cd-fix-profile
184 %attr(755,root,root) %{_bindir}/colormgr
185 %attr(755,root,root) %{_libexecdir}/colord
186 %attr(755,root,root) %{_libexecdir}/colord-sane
187 %dir %{_libdir}/colord-sensors
188 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_colorhug.so
189 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_dummy.so
190 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_huey.so
191 # disabled for now
192 #%attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_munki.so
193 %dir %{_datadir}/color/icc/colord
194 %{_datadir}/color/icc/colord/*.icc
195 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Device.xml
196 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Profile.xml
197 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Sensor.xml
198 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.xml
199 %{_datadir}/dbus-1/interfaces/org.freedesktop.colord.sane.xml
200 %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
201 %{_datadir}/dbus-1/system-services/org.freedesktop.colord-sane.service
202 %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
203 %{_mandir}/man1/cd-create-profile.1*
204 %{_mandir}/man1/cd-fix-profile.1*
205 %{_mandir}/man1/colormgr.1*
206 %{systemdunitdir}/colord.service
207 %{systemdunitdir}/colord-sane.service
208 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/colord.conf
209 /etc/dbus-1/system.d/org.freedesktop.ColorManager.conf
210 /etc/dbus-1/system.d/org.freedesktop.colord-sane.conf
211 /lib/udev/rules.d/69-cd-sensors.rules
212 /lib/udev/rules.d/95-cd-devices.rules
213 %dir /var/lib/colord
214
215 %files libs
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libcolord.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libcolord.so.1
219 %{_libdir}/girepository-1.0/Colord-1.0.typelib
220
221 %files devel
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_libdir}/libcolord.so
224 %{_includedir}/colord-1
225 %{_pkgconfigdir}/colord.pc
226 %{_datadir}/gir-1.0/Colord-1.0.gir
227
228 %if %{with static_libs}
229 %files static
230 %defattr(644,root,root,755)
231 %{_libdir}/libcolord.a
232 %endif
233
234 %if %{with apidocs}
235 %files apidocs
236 %defattr(644,root,root,755)
237 %{_gtkdocdir}/colord
238 %endif
239
240 %if %{with vala}
241 %files -n vala-colord
242 %defattr(644,root,root,755)
243 %{_datadir}/vala/vapi/colord.vapi
244 %endif
245
246 %files -n bash-completion-colord
247 %defattr(644,root,root,755)
248 %{_sysconfdir}/bash_completion.d/colormgr-completion.bash
This page took 0.218593 seconds and 3 git commands to generate.