]> git.pld-linux.org Git - packages/codeblocks.git/blob - codeblocks.spec
- *-pwd.patch get rid of $(PWD) from Makefile to allow build on
[packages/codeblocks.git] / codeblocks.spec
1 Summary:        An open source, cross platform, free C++ IDE
2 Summary(pl):    Wieloplatformowe, darmowe IDE do C++ o otwartych ¼ród³ach
3 Name:           codeblocks
4 Version:        1.0
5 %define         _rc     rc2
6 Release:        0.%{_rc}.0.5
7 License:        GPL
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/codeblocks/%{name}-%{version}%{_rc}.tgz
10 # Source0-md5:  425c700feb77d22b1b85b1061d2504d9
11 Source1:        %{name}.conf
12 Patch0:         %{name}-ac.patch
13 Patch1:         %{name}-fhs.patch
14 Patch2:         %{name}-pwd.patch
15 URL:            http://www.codeblocks.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  dos2unix
19 BuildRequires:  libtool
20 BuildRequires:  wxGTK2-devel >= 2.6.0
21 BuildRequires:  zip
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define _pluginsdir %{_libdir}/%{name}/plugins
25
26 %description
27 Code::Blocks is a free C++ IDE built specifically to meet the most
28 demanding needs of its users. It was designed, right from the start,
29 to be extensible and configurable. Built around a plugin framework,
30 Code::Blocks can be extended with plugin DLLs. It includes a plugin
31 wizard so you can compile your own plugins!
32
33 Highlights:
34  - Open Source! GPL 2, no hidden costs
35  - Cross-platform; runs on Linux or Windows (uses wxWidgets)
36  - Made in GNU C++; no interpreted languages or proprietary libs
37    needed
38  - Extensible thru plugins
39
40 Compiler-related features:
41  - Multiple compiler support: GCC (MingW / Linux), MSVC++, Digital
42    Mars, Borland C++ 5.5, Open Watcom
43  - Compiles directly or with makefiles
44  - Predefined project templates
45  - Custom template support
46  - Uses XML format for project files
47  - Multi-target projects
48  - Workspaces support
49  - Imports MSVC projects and workspaces (NOTE: assembly code and
50    inter-project dependencies not supported yet)
51  - Imports Dev-C++ projects
52  - Integrates with GDB for debugging
53
54 Interface Features:
55  - Syntax highlighting, customizable and extensible
56  - Code folding for C++ and XML files
57  - Tabbed interface
58  - Code completion plugin
59  - Class Browser
60  - Smart indent
61  - One-key swap between .h and .c/.cpp files
62  - Open files list for quick switching between files (optional)
63  - External customizable "Tools"
64  - To-do list management with different users
65
66 %description -l pl
67 Code::Blocks to darmowe IDE dla C++ tworzone specjalnie w celu
68 zaspokojenia najwiêkszych potrzeb swoich u¿ytkowników. Zosta³o
69 zaprojektowane od pocz±tku aby by³o rozszerzalne i konfigurowalne.
70 Code::Blocks, jako zbudowane w oparciu o szkielet wtyczek, mo¿na
71 rozszerzaæ. Zawiera czarodzieja dla wtyczek, wiêc mo¿na kompilowaæ
72 w³asne.
73
74 G³ówne cechy:
75  - otwarte ¼ród³a na licencji GPL 2, bez ukrytych kosztów
76  - wieloplatformowo¶æ - dzia³a na Linuksie i Windows (przy u¿yciu
77    wxWidgets)
78  - stworzone w GNU C++, nie wymaga jêzyków interpretowanych ani
79    w³asno¶ciowych bibliotek
80  - rozszerzalne poprzez wtyczki
81
82 Cechy zwi±zane z kompilatorami:
83  - obs³uga wielu kompilatorów: GCC (MingW / Linux), MSVC++, Digital
84    Mars, Borland C++ 5.5, Open Watcom
85  - kompiluje bezpo¶rednio lub z u¿yciem plików Makefile
86  - predefiniowane szablony projektów
87  - obs³uga w³asnych szablonów
88  - u¿ywa formatu XML dla plików projektów
89  - projekty z wieloma celami
90  - obs³uga przestrzeni zadañ (workspace)
91  - import projektów i przestrzeni zadañ MSVC (uwaga: kdo w asemblerze
92    i zale¿no¶ci miêdzy projektami nie s± jeszcze obs³ugiwane)
93  - import projektów Dev-C++
94  - integracja z GDB do odpluskwiania
95
96 Cechy interfejsu:
97  - pod¶wietlanie sk³adni - konfigurowalne i rozszerzalne
98  - zwijanie kodu w plikach C++ i XML
99  - interfejs z zak³adkami
100  - wtyczka dope³niania kodu
101  - przegl±darka klas
102  - inteligentne wciêcia
103  - prze³±czanie jednym klawiszem miêdzy plikami .h i .c/.cpp
104  - lista otwartych plików do szybkiego prze³±czania miêdzy nimi
105    (opcja)
106  - zewnêtrzne, konfigurowalne "narzêdzia"
107  - zarz±dzanie list± rzeczy do zrobienia ("To-do") przez ró¿nych
108    u¿ytkowników
109
110 %prep
111 %setup -q -n %{name}-%{version}%{_rc}
112 find . -type f -and -not -name "*.cpp" -and -not -name "*.h" -and -not -name "*.png" -and -not -name "*.bmp" -and -not -name "*.c" -and -not -name "*.cxx" -and -not -name "*.ico" | sed "s/.*/\"\\0\"/" | xargs dos2unix
113 chmod a+x acinclude.m4 src/update
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p1
117
118 %build
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         --with-wx-config=wx-gtk2-ansi-config
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 install -d $RPM_BUILD_ROOT/%{_sysconfdir}
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134 cp %{SOURCE1} "$RPM_BUILD_ROOT/%{_sysconfdir}/Code::Blocks v1.0"
135
136 rm -rf $RPM_BUILD_ROOT%{_pluginsdir}/*.la
137 rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc AUTHORS BUGS COMPILERS README TODO ChangeLog
148 %config(noreplace) %verify(not md5 mtime size) "%{_sysconfdir}/Code::Blocks v1.0"
149 %attr(755,root,root) %{_bindir}/codeblocks
150 %attr(755,root,root) %{_bindir}/console_runner
151 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
152 %{_desktopdir}/*.desktop
153 %{_pixmapsdir}/*.png
154 %dir %{_datadir}/%{name}
155 %{_datadir}/%{name}/*.zip
156 %{_datadir}/%{name}/*.txt
157 %{_datadir}/%{name}/icons
158 %{_datadir}/%{name}/images
159 %{_datadir}/%{name}/lexers
160 %{_datadir}/%{name}/templates
161 %dir %{_pluginsdir}
162 %attr(755,root,root) %{_pluginsdir}/*.so
163 %{_pkgconfigdir}/codeblocks.pc
This page took 0.074126 seconds and 4 git commands to generate.