]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- %%{_libdir}/clisp/full/lisp.run is back to %files.
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Summary(pl):    Implementacja Common Lisp (ANSI CL)
3 Name:           clisp
4 Version:        2.28
5 Release:        3
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/%{name}-%{version}.tar.bz2
9 #Alternatively http://prdownloads.sourceforge.net/clisp/clisp-2.27.tar.bz2
10 Patch0:         %{name}-shell.patch
11 Icon:           clisp.gif
12 URL:            http://clisp.cons.org/
13 BuildRequires:  readline-devel
14 BuildRequires:  gettext-devel
15 BuildRequires:  ncurses-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Common Lisp is a high-level, all-purpose programming language. CLISP
20 is a Common Lisp implementation by Bruno Haible of Karlsruhe
21 University and Michael Stoll of Munich University, both in Germany. It
22 mostly supports Common Lisp as described in the ANSI CL standard. It
23 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
24 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
25 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
26 needs only 2 MB of RAM.
27
28 It is free software and may be distributed under the terms of GNU GPL,
29 while it is possible to distribute commercial applications compiled
30 with CLISP.
31
32 The user interface comes in German, English, French and Spanish. CLISP
33 includes an interpreter, a compiler, a large subset of CLOS, a foreign
34 language interface and a socket interface. An X11 interface is
35 available through CLX and Garnet.
36
37 %description -l pl
38 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
39 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
40 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
41 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
42 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
43 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
44 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
45 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
46
47 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
48 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
49
50 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
51 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
52 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
53 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 ./configure --prefix=%{_prefix}
61 cd src
62 ./makemake \
63         --prefix=%{_prefix} \
64         --with-readline \
65         --with-gettext \
66         --with-dynamic-ffi \
67         --with-module=wildcard \
68         --with-module=regexp \
69         --with-module=bindings/linuxlibc6 \
70         >Makefile
71 %{__make} config.lisp
72 %{__make}
73 #make check
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 cd src
78 install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT \
81         lispdocdir=%{_docdir}/%{name}-%{version} \
82         mandir=%{_mandir}
83 cd ..
84 mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
85 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
86
87 %find_lang %{name} --all-name
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files -f %{name}.lang
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_bindir}/clisp
95 %doc %{_docdir}/%{name}-%{version}
96 %dir %{_libdir}/clisp
97 %dir %{_libdir}/clisp/base
98 %{_libdir}/clisp/base/*.[aho]
99 %{_libdir}/clisp/base/lispinit.mem
100 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
101 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
102 %{_libdir}/clisp/base/makevars
103 %{_libdir}/clisp/clisp-link
104 %{_libdir}/clisp/data
105 %{_libdir}/clisp/full/*.[aho]
106 %{_libdir}/clisp/full/lispinit.mem
107 %{_libdir}/clisp/full/makevars
108 %{_libdir}/clisp/linkkit
109 %{_mandir}/man[13]/*
This page took 0.070032 seconds and 4 git commands to generate.