]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- up to 2.41
[packages/clisp.git] / clisp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # run test suite `make check'
4 #
5 Summary:        Common Lisp (ANSI CL) implementation
6 Summary(pl):    Implementacja Common Lisp (ANSI CL)
7 Summary(pt_BR): Implementação do Common Lisp (ANSI CL)
8 Name:           clisp
9 Version:        2.41
10 Release:        1
11 License:        GPL
12 Group:          Development/Languages
13 Source0:        http://dl.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
14 # Source0-md5:  3a7a00e82ebeeb72a75a032f84c36c6c
15 Patch0:         %{name}-shell.patch
16 Patch1:         %{name}-alpha.patch
17 URL:            http://clisp.cons.org/
18 BuildRequires:  gettext-devel
19 BuildRequires:  libsigsegv >= 2.4
20 BuildRequires:  ncurses-devel
21 BuildRequires:  readline-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Common Lisp is a high-level, all-purpose programming language. CLISP
26 is a Common Lisp implementation by Bruno Haible of Karlsruhe
27 University and Michael Stoll of Munich University, both in Germany. It
28 mostly supports Common Lisp as described in the ANSI CL standard. It
29 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
30 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
31 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
32 needs only 2 MB of RAM.
33
34 It is free software and may be distributed under the terms of GNU GPL,
35 while it is possible to distribute commercial applications compiled
36 with CLISP.
37
38 The user interface comes in German, English, French and Spanish. CLISP
39 includes an interpreter, a compiler, a large subset of CLOS, a foreign
40 language interface and a socket interface. An X11 interface is
41 available through CLX and Garnet.
42
43 %description -l pl
44 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
45 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
46 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
47 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
48 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
49 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
50 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
51 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
52
53 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
54 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
55
56 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
57 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
58 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
59 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
60
61 %description -l pt_BR
62 Common Lisp é uma linguagem de programação de propósito geral de alto
63 nível. CLISP é uma implementação do Common Lisp feita por Bruno
64 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
65 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
66 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
67 software livre, distribuído sob os termos da GNU GPL.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73
74 # changing default -O to optflags causes memory fault on amd64
75 # - so something is broken... code or compiler
76 # -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
77 # random crashes on sparc (which occur with default CFLAGS)
78 #%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
79
80 %build
81 CC="%{__cc}" \
82 ./configure \
83         --prefix=%{_prefix}
84
85 cd src
86 ./makemake \
87         --prefix=%{_prefix} \
88         --with-readline \
89         --with-gettext \
90         --with-dynamic-ffi \
91         --fsstnd=redhat \
92         --with-module=wildcard \
93         --with-module=bindings/glibc \
94         --with-module=clx/new-clx \
95         >Makefile
96 %{__make} config.lisp
97 %{__make} \
98         libdir=%{_libdir}
99
100 %{?with_tests:%{__make} check}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} -C src install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         libdir=%{_libdir} \
108         lispdocdir=%{_docdir}/%{name}-%{version} \
109         mandir=%{_mandir}
110
111 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
112 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
113
114 %find_lang %{name} --all-name
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/clisp
122 %doc %{_docdir}/%{name}-%{version}
123 %dir %{_libdir}/clisp
124 %dir %{_libdir}/clisp/base
125 %{_libdir}/clisp/base/*.[aho]
126 %{_libdir}/clisp/base/lispinit.mem
127 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
128 %{_libdir}/clisp/base/makevars
129 %{_libdir}/clisp/clisp-link
130 %{_libdir}/clisp/data
131 %dir %{_libdir}/clisp/full
132 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
133 %{_libdir}/clisp/full/*.[aho]
134 %{_libdir}/clisp/full/lispinit.mem
135 %{_libdir}/clisp/full/makevars
136 %{_libdir}/clisp/linkkit
137 %{_mandir}/man[13]/*
This page took 0.08732 seconds and 4 git commands to generate.