]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- rel. 0.1 (downgrade) - it builds on Ac but doesn't pass tests
[packages/clisp.git] / clisp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # run test suite `make check'
4 #
5 Summary:        Common Lisp (ANSI CL) implementation
6 Summary(pl):    Implementacja Common Lisp (ANSI CL)
7 Summary(pt_BR): Implementação do Common Lisp (ANSI CL)
8 Name:           clisp
9 Version:        2.41
10 Release:        0.1
11 License:        GPL
12 Group:          Development/Languages
13 Source0:        http://dl.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
14 # Source0-md5:  3a7a00e82ebeeb72a75a032f84c36c6c
15 Patch0:         %{name}-shell.patch
16 Patch1:         %{name}-alpha.patch
17 URL:            http://clisp.cons.org/
18 BuildRequires:  gettext-devel
19 BuildRequires:  libsigsegv >= 2.4
20 BuildRequires:  ncurses-devel
21 BuildRequires:  readline-devel
22 BuildRequires:  xorg-lib-libX11-devel
23 BuildRequires:  xorg-proto-xextproto-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Common Lisp is a high-level, all-purpose programming language. CLISP
28 is a Common Lisp implementation by Bruno Haible of Karlsruhe
29 University and Michael Stoll of Munich University, both in Germany. It
30 mostly supports Common Lisp as described in the ANSI CL standard. It
31 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
32 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
33 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
34 needs only 2 MB of RAM.
35
36 It is free software and may be distributed under the terms of GNU GPL,
37 while it is possible to distribute commercial applications compiled
38 with CLISP.
39
40 The user interface comes in German, English, French and Spanish. CLISP
41 includes an interpreter, a compiler, a large subset of CLOS, a foreign
42 language interface and a socket interface. An X11 interface is
43 available through CLX and Garnet.
44
45 %description -l pl
46 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
47 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
48 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
49 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
50 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
51 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
52 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
53 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
54
55 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
56 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
57
58 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
59 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
60 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
61 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
62
63 %description -l pt_BR
64 Common Lisp é uma linguagem de programação de propósito geral de alto
65 nível. CLISP é uma implementação do Common Lisp feita por Bruno
66 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
67 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
68 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
69 software livre, distribuído sob os termos da GNU GPL.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75
76 # changing default -O to optflags causes memory fault on amd64
77 # - so something is broken... code or compiler
78 # -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
79 # random crashes on sparc (which occur with default CFLAGS)
80 #%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
81
82 %build
83 CC="%{__cc}" \
84 ./configure \
85         --prefix=%{_prefix}
86
87 cd src
88 ./makemake \
89         --prefix=%{_prefix} \
90         --with-readline \
91         --with-gettext \
92         --with-dynamic-ffi \
93         --fsstnd=redhat \
94         --with-module=wildcard \
95         --with-module=bindings/glibc \
96         --with-module=clx/new-clx \
97         >Makefile
98 %{__make} config.lisp
99 %{__make} \
100         libdir=%{_libdir}
101
102 %{?with_tests:%{__make} check}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} -C src install \
108         DESTDIR=$RPM_BUILD_ROOT \
109         libdir=%{_libdir} \
110         lispdocdir=%{_docdir}/%{name}-%{version} \
111         mandir=%{_mandir}
112
113 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
114 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
115
116 %find_lang %{name} --all-name
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/clisp
124 %doc %{_docdir}/%{name}-%{version}
125 %dir %{_libdir}/clisp
126 %dir %{_libdir}/clisp/base
127 %{_libdir}/clisp/base/*.[aho]
128 %{_libdir}/clisp/base/lispinit.mem
129 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
130 %{_libdir}/clisp/base/makevars
131 %{_libdir}/clisp/clisp-link
132 %{_libdir}/clisp/data
133 %dir %{_libdir}/clisp/full
134 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
135 %{_libdir}/clisp/full/*.[aho]
136 %{_libdir}/clisp/full/lispinit.mem
137 %{_libdir}/clisp/full/makevars
138 %{_libdir}/clisp/linkkit
139 %{_mandir}/man[13]/*
This page took 0.071456 seconds and 4 git commands to generate.