]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- s/linuxlibc6/glibc/
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Summary(pl):    Implementacja Common Lisp (ANSI CL)
3 Summary(pt_BR): Implementação do Common Lisp (ANSI CL)
4 Name:           clisp
5 Version:        2.30
6 Release:        1
7 License:        GPL
8 Group:          Development/Languages
9 Source0:        ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/%{name}-%{version}.tar.bz2
10 # Source0-md5:  29e80e430c6098c78dbd2e56334aaa90
11 Patch0:         %{name}-shell.patch
12 Patch1:         %{name}-no_LIBC.patch
13 Icon:           clisp.gif
14 URL:            http://clisp.cons.org/
15 BuildRequires:  readline-devel
16 BuildRequires:  gettext-devel
17 BuildRequires:  ncurses-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Common Lisp is a high-level, all-purpose programming language. CLISP
22 is a Common Lisp implementation by Bruno Haible of Karlsruhe
23 University and Michael Stoll of Munich University, both in Germany. It
24 mostly supports Common Lisp as described in the ANSI CL standard. It
25 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
26 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
27 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
28 needs only 2 MB of RAM.
29
30 It is free software and may be distributed under the terms of GNU GPL,
31 while it is possible to distribute commercial applications compiled
32 with CLISP.
33
34 The user interface comes in German, English, French and Spanish. CLISP
35 includes an interpreter, a compiler, a large subset of CLOS, a foreign
36 language interface and a socket interface. An X11 interface is
37 available through CLX and Garnet.
38
39 %description -l pl
40 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
41 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
42 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
43 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
44 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
45 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
46 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
47 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
48
49 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
50 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
51
52 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
53 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
54 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
55 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
56
57 %description -l pt_BR
58 Common Lisp é uma linguagem de programação de propósito geral de alto
59 nível. CLISP é uma implementação do Common Lisp feita por Bruno
60 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
61 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
62 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
63 software livre, distribuído sob os termos da GNU GPL.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 ./configure --prefix=%{_prefix}
72 cd src
73 ./makemake \
74         --prefix=%{_prefix} \
75         --with-readline \
76         --with-gettext \
77         --with-dynamic-ffi \
78         --with-module=wildcard \
79         --with-module=regexp \
80         --with-module=bindings/glibc \
81         >Makefile
82 %{__make} config.lisp
83 %{__make}
84 #make check
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 cd src
89 install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT \
92         lispdocdir=%{_docdir}/%{name}-%{version} \
93         mandir=%{_mandir}
94 cd ..
95 mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
96 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
97
98 %find_lang %{name} --all-name
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/clisp
106 %doc %{_docdir}/%{name}-%{version}
107 %dir %{_libdir}/clisp
108 %dir %{_libdir}/clisp/base
109 %{_libdir}/clisp/base/*.[aho]
110 %{_libdir}/clisp/base/lispinit.mem
111 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
112 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
113 %{_libdir}/clisp/base/makevars
114 %{_libdir}/clisp/clisp-link
115 %{_libdir}/clisp/data
116 %{_libdir}/clisp/full/*.[aho]
117 %{_libdir}/clisp/full/lispinit.mem
118 %{_libdir}/clisp/full/makevars
119 %{_libdir}/clisp/linkkit
120 %{_mandir}/man[13]/*
This page took 0.062005 seconds and 3 git commands to generate.