]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- rel 4; builds with readline 7; likely software depending on clisp will need rebuild
[packages/clisp.git] / clisp.spec
1 # TODO:
2 # - review alpha patch
3 #
4 # Conditional build:
5 %bcond_with     tests   # run test suite `make check' (uses network, won't pass on vserver)
6 #
7 Summary:        Common Lisp (ANSI CL) implementation
8 Summary(pl.UTF-8):      Implementacja Common Lisp (ANSI CL)
9 Summary(pt_BR.UTF-8):   Implementação do Common Lisp (ANSI CL)
10 Name:           clisp
11 Version:        2.49
12 Release:        4
13 License:        GPL
14 Group:          Development/Languages
15 Source0:        http://download.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
16 # Source0-md5:  1962b99d5e530390ec3829236d168649
17 Patch0:         %{name}-shell.patch
18 Patch1:         %{name}-alpha.patch
19 Patch2:         %{name}-glibc.patch
20 # https://sourceforge.net/p/clisp/bugs/688/attachment/patch-modules_readline_readline.lisp
21 Patch3:         %{name}-readline.patch
22 URL:            http://clisp.cons.org/
23 BuildRequires:  ffcall-devel
24 BuildRequires:  gettext-tools
25 BuildRequires:  libsigsegv >= 2.4
26 BuildRequires:  ncurses-devel
27 BuildRequires:  readline-devel
28 BuildRequires:  xorg-lib-libX11-devel
29 BuildRequires:  xorg-lib-libXpm-devel
30 BuildRequires:  xorg-proto-xextproto-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define specflags_ppc   -DNO_GENERATIONAL_GC
34 %define specflags_ppc64 -DNO_GENERATIONAL_GC
35
36 %description
37 Common Lisp is a high-level, all-purpose programming language. CLISP
38 is a Common Lisp implementation by Bruno Haible of Karlsruhe
39 University and Michael Stoll of Munich University, both in Germany. It
40 mostly supports Common Lisp as described in the ANSI CL standard. It
41 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
42 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
43 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
44 needs only 2 MB of RAM.
45
46 It is free software and may be distributed under the terms of GNU GPL,
47 while it is possible to distribute commercial applications compiled
48 with CLISP.
49
50 The user interface comes in German, English, French and Spanish. CLISP
51 includes an interpreter, a compiler, a large subset of CLOS, a foreign
52 language interface and a socket interface. An X11 interface is
53 available through CLX and Garnet.
54
55 %description -l pl.UTF-8
56 Common Lisp to wysokopoziomowy język programowania ogólnego
57 przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
58 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
59 University (oba w Niemczech). W większości wspiera Common Lisp opisany
60 w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
61 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
62 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
63 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
64
65 To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
66 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
67
68 Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
69 i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
70 CLOS, interfejs do innych języków oraz interfejs do gniazdek.
71 Interfejs X11 jest dostępny poprzez CLX i Garnet.
72
73 %description -l pt_BR.UTF-8
74 Common Lisp é uma linguagem de programação de propósito geral de alto
75 nível. CLISP é uma implementação do Common Lisp feita por Bruno
76 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
77 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
78 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
79 software livre, distribuído sob os termos da GNU GPL.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86 %patch3 -p0
87
88 # changing default -O to optflags causes memory fault on amd64
89 # - so something is broken... code or compiler
90 # -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
91 # random crashes on sparc (which occur with default CFLAGS)
92 #%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
93
94 %build
95
96 %ifarch ppc ppc64
97 ulimit -s unlimited
98 %else
99 ulimit -s 32768
100 %endif
101
102 CC="%{__cc}" \
103 %ifarch sparc sparcv9 sparc64
104 CFLAGS="%{rpmcflags} -DSAFETY=3" \
105 %else
106 CFLAGS="%{rpmcflags}" \
107 %endif
108 ./configure \
109         --prefix=%{_prefix}
110
111 cd src
112 ./makemake \
113         --prefix=%{_prefix} \
114         --with-readline \
115         --with-gettext \
116         --with-dynamic-ffi \
117         --fsstnd=redhat \
118         --with-module=wildcard \
119         --with-module=bindings/glibc \
120         --with-module=clx/new-clx \
121         >Makefile
122 %{__make} -j1 config.lisp \
123         TOPDIR=clisp
124 %{__make} -j1 \
125         libdir=%{_libdir} \
126         TOPDIR=clisp
127
128 %{?with_tests:%{__make} -j1 check}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} -j1 -C src install \
134         DESTDIR=$RPM_BUILD_ROOT \
135         libdir=%{_libdir} \
136         docdir=%{_docdir}/%{name}-%{version} \
137         mandir=%{_mandir} \
138         TOPDIR=clisp
139
140 # already packaged as man/html/pdf
141 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/doc/clisp*.{1,ps}
142
143 # clisp and clisplow domains
144 %find_lang %{name} --all-name
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/clisp
152 %attr(755,root,root) %{_bindir}/clisp-link
153 %doc %{_docdir}/%{name}-%{version} 
154 %dir %{_libdir}/clisp
155 %dir %{_libdir}/clisp/base
156 %{_libdir}/clisp/base/*.[aho]
157 %{_libdir}/clisp/base/lispinit.mem
158 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
159 %{_libdir}/clisp/base/makevars
160 %{_libdir}/clisp/bindings
161 %{_libdir}/clisp/build-aux
162 %{_libdir}/clisp/clx
163 %{_libdir}/clisp/data
164 %dir %{_libdir}/clisp/dynmod
165 %{_libdir}/clisp/dynmod/*.lisp
166 %attr(755,root,root) %{_libdir}/clisp/dynmod/lib-*.so
167 %{_libdir}/clisp/linkkit
168 %{_libdir}/clisp/wildcard
169 %{_aclocaldir}/clisp.m4
170 %{_mandir}/man1/clisp.1*
171 %{_mandir}/man1/clisp-link.1*
172
173 # TODO:
174 #%{_datadir}/emacs/site-lisp/clhs.el
175 #%{_datadir}/emacs/site-lisp/clisp-coding.el
176 #%{_datadir}/emacs/site-lisp/clisp-ffi.el
177 #%{_datadir}/emacs/site-lisp/clisp-indent.el
178 #%{_datadir}/emacs/site-lisp/clisp-indent.lisp
179 #%{_datadir}/vim/vimfiles/after/syntax/lisp.vim
This page took 0.07544 seconds and 3 git commands to generate.