]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
8e7313796146b9e9e78cf7f31f0b2cc55c3ec706
[packages/clisp.git] / clisp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # run test suite `make check'
4 #
5 Summary:        Common Lisp (ANSI CL) implementation
6 Summary(pl):    Implementacja Common Lisp (ANSI CL)
7 Summary(pt_BR): Implementação do Common Lisp (ANSI CL)
8 Name:           clisp
9 Version:        2.37
10 Release:        1       
11 License:        GPL
12 Group:          Development/Languages
13 Source0:        http://dl.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
14 # Source0-md5:  f2445b3935b6f97b443d9548c38872e9
15 Patch0:         %{name}-shell.patch
16 Patch1:         %{name}-alpha.patch
17 Icon:           clisp.gif
18 URL:            http://clisp.cons.org/
19 BuildRequires:  gettext-devel
20 BuildRequires:  libsigsegv
21 BuildRequires:  ncurses-devel
22 BuildRequires:  readline-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Common Lisp is a high-level, all-purpose programming language. CLISP
27 is a Common Lisp implementation by Bruno Haible of Karlsruhe
28 University and Michael Stoll of Munich University, both in Germany. It
29 mostly supports Common Lisp as described in the ANSI CL standard. It
30 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
31 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
32 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
33 needs only 2 MB of RAM.
34
35 It is free software and may be distributed under the terms of GNU GPL,
36 while it is possible to distribute commercial applications compiled
37 with CLISP.
38
39 The user interface comes in German, English, French and Spanish. CLISP
40 includes an interpreter, a compiler, a large subset of CLOS, a foreign
41 language interface and a socket interface. An X11 interface is
42 available through CLX and Garnet.
43
44 %description -l pl
45 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
46 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
47 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
48 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
49 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
50 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
51 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
52 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
53
54 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
55 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
56
57 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
58 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
59 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
60 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
61
62 %description -l pt_BR
63 Common Lisp é uma linguagem de programação de propósito geral de alto
64 nível. CLISP é uma implementação do Common Lisp feita por Bruno
65 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
66 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
67 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
68 software livre, distribuído sob os termos da GNU GPL.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74
75 # changing default -O to optflags causes memory fault on amd64
76 # - so something is broken... code or compiler
77 # -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
78 # random crashes on sparc (which occur with default CFLAGS)
79 #%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
80
81 %build
82 CC="%{__cc}" \
83 ./configure \
84         --prefix=%{_prefix} 
85
86 cd src
87 ./makemake \
88         --prefix=%{_prefix} \
89         --with-readline \
90         --with-gettext \
91         --with-dynamic-ffi \
92         --fsstnd=redhat \
93         --with-module=wildcard \
94         --with-module=bindings/glibc \
95         --with-module=clx/new-clx \
96         >Makefile
97 %{__make} config.lisp
98 %{__make} \
99         libdir=%{_libdir}
100
101 %{?with_tests:%{__make} check}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} -C src install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         libdir=%{_libdir} \
109         lispdocdir=%{_docdir}/%{name}-%{version} \
110         mandir=%{_mandir}
111
112 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
113 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
114
115 %find_lang %{name} --all-name
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files -f %{name}.lang
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/clisp
123 %doc %{_docdir}/%{name}-%{version}
124 %dir %{_libdir}/clisp
125 %dir %{_libdir}/clisp/base
126 %{_libdir}/clisp/base/*.[aho]
127 %{_libdir}/clisp/base/lispinit.mem
128 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
129 %{_libdir}/clisp/base/makevars
130 %{_libdir}/clisp/clisp-link
131 %{_libdir}/clisp/data
132 %dir %{_libdir}/clisp/full
133 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
134 %{_libdir}/clisp/full/*.[aho]
135 %{_libdir}/clisp/full/lispinit.mem
136 %{_libdir}/clisp/full/makevars
137 %{_libdir}/clisp/linkkit
138 %{_mandir}/man[13]/*
This page took 0.037207 seconds and 3 git commands to generate.