]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
12f4a85af9f3033e73346baabc7397b0c179ca59
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Summary(pl):    Implementacja Common Lisp (ANSI CL)
3 Name:           clisp
4 Version:        2.27
5 Release:        1
6 Icon:           clisp.gif
7 License:        GPL
8 Group:          Development/Languages
9 Group(de):      Entwicklung/Sprachen
10 Group(pl):      Programowanie/Jêzyki
11 Source0:        ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/%{name}-%{version}.tar.bz2
12 #Alternatively http://prdownloads.sourceforge.net/clisp/clisp-2.27.tar.bz2
13 Patch0:         %{name}-shell.patch
14 URL:            http://clisp.cons.org/
15 BuildRequires:  readline-devel
16 BuildRequires:  gettext-devel
17 BuildRequires:  ncurses-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Common Lisp is a high-level, all-purpose programming language. CLISP
22 is a Common Lisp implementation by Bruno Haible of Karlsruhe
23 University and Michael Stoll of Munich University, both in Germany. It
24 mostly supports Common Lisp as described in the ANSI CL standard. It
25 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
26 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
27 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
28 needs only 2 MB of RAM.
29
30 It is free software and may be distributed under the terms of GNU GPL,
31 while it is possible to distribute commercial applications compiled
32 with CLISP.
33
34 The user interface comes in German, English, French and Spanish. CLISP
35 includes an interpreter, a compiler, a large subset of CLOS, a foreign
36 language interface and a socket interface. An X11 interface is
37 available through CLX and Garnet.
38
39 %description -l pl
40 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
41 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
42 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
43 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
44 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
45 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
46 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
47 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
48
49 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
50 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
51
52 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
53 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
54 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
55 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 %build
62 ./configure --prefix=%{_prefix}
63 cd src
64 ./makemake \
65         --prefix=%{_prefix} \
66         --with-readline \
67         --with-gettext \
68         --with-dynamic-ffi \
69         --with-module=wildcard \
70         --with-module=regexp \
71         --with-module=bindings/linuxlibc6 \
72         >Makefile
73 %{__make} config.lisp
74 %{__make}
75 #make check
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 cd src
80 install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT \
83         lispdocdir=%{_docdir}/%{name}-%{version} \
84         mandir=%{_mandir}
85 cd ..
86 mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
87 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_bindir}/clisp
95 %doc %{_docdir}/%{name}-%{version}
96 %dir %{_libdir}/clisp
97 %dir %{_libdir}/clisp/base
98 %{_libdir}/clisp/base/*.[aho]
99 %{_libdir}/clisp/base/lispinit.mem
100 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
101 %{_libdir}/clisp/base/makevars
102 %{_libdir}/clisp/clisp-link
103 %{_libdir}/clisp/data
104 %{_libdir}/clisp/full/*.[aho]
105 %{_libdir}/clisp/full/lispinit.mem
106 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
107 %{_libdir}/clisp/full/makevars
108 %{_libdir}/clisp/linkkit
109 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/*
110 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/*
111 %lang(es) %{_datadir}/locale/es/LC_MESSAGES/*
112 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/*
113 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/*
114 %{_mandir}/man[13]/*
This page took 0.104842 seconds and 3 git commands to generate.