]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
BR QtXmlPatterns-devel
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # - apply patches to libprojectM.spec and use
4 # - checking for module 'libspotify>=12.1.45' - Spotify support: non-GPL binary helper (missing libspotify)
5 # - checking for module 'libchromaprint'
6 # - Google Drive support (missing Google sparsehash)
7 # - package for kde4 stuff (or nuke them):
8 #        /usr/share/kde4/services/clementine-feed.protocol
9 #        /usr/share/kde4/services/clementine-itms.protocol
10 #        /usr/share/kde4/services/clementine-itpc.protocol
11 #        /usr/share/kde4/services/clementine-zune.protocol
12 #
13 # Conditional build:
14 %bcond_without  static_sqlite   # with static sqlite3
15 %bcond_with     static_projectm # with static projectM
16
17 %define         qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
18 Summary:        A music player and library organiser
19 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
20 Name:           clementine
21 Version:        1.1.1
22 Release:        5
23 License:        GPL v3 and GPL v2+
24 Group:          Applications/Multimedia
25 URL:            http://www.clementine-player.org/
26 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
27 # Source0-md5:  28e4afb822388bd337a761db8f86febf
28 Patch0:         desktop-install.patch
29 Patch1:         unbundle-po.patch
30 BuildRequires:  QtCore-devel >= %{qtver}
31 BuildRequires:  QtDBus-devel >= %{qtver}
32 BuildRequires:  QtGui-devel >= %{qtver}
33 BuildRequires:  QtIOCompressor-devel
34 BuildRequires:  QtNetwork-devel >= %{qtver}
35 BuildRequires:  QtOpenGL-devel >= %{qtver}
36 BuildRequires:  QtSingleApplication-devel >= 2.6-4
37 BuildRequires:  QtSql-devel >= %{qtver}
38 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
39 BuildRequires:  QtXml-devel >= %{qtver}
40 BuildRequires:  QtXmlPatterns-devel >= %{qtver}
41 BuildRequires:  boost-devel
42 BuildRequires:  cmake >= 2.6
43 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
44 BuildRequires:  gettext-devel
45 %{?with_static_projectm:BuildRequires:  glew-devel}
46 BuildRequires:  glib2-devel
47 BuildRequires:  gstreamer0.10-devel
48 BuildRequires:  gstreamer0.10-plugins-base-devel
49 BuildRequires:  gtest-devel
50 BuildRequires:  libgpod-devel >= 0.7.92
51 BuildRequires:  libimobiledevice-devel
52 BuildRequires:  libindicate-qt-devel
53 BuildRequires:  liblastfm-devel >= 0.3.3
54 BuildRequires:  libmtp-devel
55 BuildRequires:  libplist-devel
56 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
57 BuildRequires:  libqxt-devel
58 BuildRequires:  libxml2-devel
59 BuildRequires:  pkgconfig
60 BuildRequires:  pkgconfig
61 BuildRequires:  protobuf-devel
62 BuildRequires:  qca-devel
63 BuildRequires:  qjson-devel
64 BuildRequires:  qt4-build >= %{qtver}
65 BuildRequires:  qt4-linguist
66 BuildRequires:  qt4-qmake
67 BuildRequires:  rpmbuild(find_lang) >= 1.33
68 BuildRequires:  rpmbuild(macros) >= 1.596
69 BuildRequires:  sed >= 4.0
70 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
71 BuildRequires:  taglib-devel >= 1.6
72 BuildRequires:  usbmuxd-devel
73 Requires(post,postun):  desktop-file-utils
74 Requires(post,postun):  gtk-update-icon-cache
75 Requires(post,postun):  hicolor-icon-theme
76 Requires:       QtSingleApplication >= 2.6-4
77 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
78 Requires:       gstreamer0.10-audio-effects-base
79 Requires:       gstreamer0.10-mad
80 # while we do not link (yet), we use datafiles
81 Requires:       libprojectM
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 # see libprojectM.spec for explanation
85 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
86
87 %description
88 Clementine is a modern music player and library organiser. It is
89 largely a port of Amarok 1.4, with some features rewritten to take
90 advantage of Qt4.
91
92 %description -l hu.UTF-8
93 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
94 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
95 a Qt4 előnyeit.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101
102 # We already don't use these but just to make sure
103 rm -rf 3rdparty/gmock
104 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
105 rm -rf 3rdparty/qtsingleapplication
106 rm -rf 3rdparty/qxt
107 rm -rf 3rdparty/qtiocompressor
108 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
109
110 # Don't build tests. They require gmock
111 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
112 # remove -Wall
113 sed -i -e 's/-Wall//' src/CMakeLists.txt
114 # ...and -Werror
115 sed -i -e 's/-Werror//' src/CMakeLists.txt
116
117 %build
118 install -d build
119 install -d build/src/translations
120 cd build
121 # as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
122 CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
123 %cmake \
124         -DBUNDLE_PROJECTM_PRESETS=OFF \
125         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
126         -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
127         -DUSE_SYSTEM_QXT=ON \
128         -DUSE_SYSTEM_PROJECTM=ON \
129         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
130         ..
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 %{__make} -C build install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
139
140 # not in our glibc?
141 rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
142
143 %find_lang %{name} --with-qm
144
145 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
146 cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
147 cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 %update_desktop_database_post
154 %update_icon_cache hicolor
155
156 %postun
157 %update_desktop_database_postun
158 %update_icon_cache hicolor
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc Changelog
163 %attr(755,root,root) %{_bindir}/clementine
164 %attr(755,root,root) %{_bindir}/clementine-tagreader
165 %{_desktopdir}/clementine.desktop
166 %{_pixmapsdir}/clementine.png
167 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
168 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.13018 seconds and 3 git commands to generate.