]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
35b93ae700e133018d371c30f38397b7317bf9d3
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - update patch0
3 # - add missing BRs
4 #
5 # Conditional build:
6 %bcond_without  engine_xine             # without xine engine
7 %bcond_without  engine_vlc              # without vlc engine
8 %bcond_without  engine_qt-phonon        # without qt-phonon engine
9 %bcond_without  engine_gstreamer        # without gstreamer engine
10 #
11 Summary:        A music player and library organiser
12 Name:           clementine
13 Version:        0.3
14 Release:        0.1
15 License:        GPL v3 and GPL v2+
16 Group:          Applications/Multimedia
17 URL:            http://code.google.com/p/clementine-player
18 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
19 # Source0-md5:  3aff98e41d9bf96717ecf97c780ef086
20 Patch0:         %{name}-dont-bundle-external-lib.patch
21 Patch1:         %{name}-static.patch
22 Patch2:         desktop-install.patch
23 BuildRequires:  QtCore-devel
24 BuildRequires:  QtDBus-devel
25 BuildRequires:  QtGui-devel
26 BuildRequires:  QtNetwork-devel
27 BuildRequires:  QtOpenGL-devel
28 BuildRequires:  QtSingleApplication-devel
29 BuildRequires:  QtSql-devel
30 BuildRequires:  QtTest-devel
31 BuildRequires:  boost-devel
32 BuildRequires:  cmake >= 2.6
33 BuildRequires:  desktop-file-utils
34 BuildRequires:  gtest-devel
35 BuildRequires:  liblastfm-devel
36 BuildRequires:  libnotify-devel
37 BuildRequires:  libqxt-devel
38 BuildRequires:  notification-daemon
39 BuildRequires:  qt4-build
40 BuildRequires:  qt4-linguist
41 BuildRequires:  qt4-qmake
42 BuildRequires:  rpmbuild(macros) >= 1.198
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  sqlite-devel
45 BuildRequires:  sqlite3-devel
46 BuildRequires:  taglib-devel
47 BuildRequires:  xine-lib-devel
48 Requires(post,postun):  desktop-file-utils
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Clementine is a modern music player and library organiser. It is
53 largely a port of Amarok 1.4, with some features rewritten to take
54 advantage of Qt4.
55
56 %prep
57 %setup -q
58 #%patch0 -p1
59 %patch1 -p1
60 %patch2 -p1
61
62 # We already don't use these but just to make sure
63 #rm -fr 3rdparty
64
65 # Don't build tests. They require gmock
66 sed -i -e '/tests/d' CMakeLists.txt
67
68 %build
69 install -d build
70 cd build
71 %cmake \
72         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
73         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
74         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
75         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
76         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt-phonon:ON}%{!?with_engine_qt-phonon:OFF} \
77         ..
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 %{__make} -C build install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post
89 %update_desktop_database_post
90
91 %postun
92 %update_desktop_database_postun
93
94 %files
95 %defattr(644,root,root,755)
96 %doc Changelog TODO
97 %attr(755,root,root) %{_bindir}/clementine
98 %{_desktopdir}/clementine.desktop
99 %{_pixmapsdir}/clementine.png
This page took 0.092181 seconds and 3 git commands to generate.