]> git.pld-linux.org Git - packages/claws-mail.git/blob - claws-mail.spec
- small changes, cleaning
[packages/claws-mail.git] / claws-mail.spec
1 #
2 # Conditional build:
3 %bcond_without  gpg             # build without GPG support
4 %bcond_without  ssl             # build without SSL support
5 %bcond_without  ipv6            # build without IPv6 support
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_without  faces           # build without compfaces support
8 %bcond_without  dillo           # build without dillo plugin (html browser)
9 %bcond_without  clamav          # build without clamav plugin
10 %bcond_without  spamassassin    # build without spamassassin plugin
11 %bcond_without  trayicon        # build without trayicon plugin
12 %bcond_with     mathml          # build with mathml plugin
13 #
14 %define         _iconver        20040929
15 Summary:        A bleeding edge branch of Sylpheed, a GTK2 based, lightweight, and fast e-mail client
16 Summary(pl):    Rozwojowa wersja Sylpheed z du¿± ilo¶ci± zmian oraz ulepszeñ
17 Name:           sylpheed-claws
18 Version:        1.9.13
19 Release:        1
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/sylpheed-claws/%{name}-%{version}.tar.bz2
23 # Source0-md5:  afd3b82ca210520f0ad241b77c5e673a
24 Source1:        %{name}.desktop
25 Source2:        http://dl.sourceforge.net/sylpheed-claws/sylpheed-iconset-%{_iconver}.tar.gz
26 # Source2-md5:  d72cf03bf3d13cf9e2785eaca3807707
27 Patch0:         %{name}-locale-names.patch
28 URL:            http://sylpheed-claws.sourceforge.net/
29 BuildRequires:  aspell-devel >= 2:0.50
30 BuildRequires:  autoconf >= 2.50
31 BuildRequires:  automake
32 BuildRequires:  bzip2-devel
33 %{?with_clamav:BuildRequires:   clamav-devel}
34 %{?with_faces:BuildRequires:    faces-devel}
35 BuildRequires:  gdk-pixbuf-devel >= 0.8
36 BuildRequires:  gettext-devel
37 BuildRequires:  gmp-devel
38 %{?with_gpg:BuildRequires:      gpgme-devel >= 1:0.4.5}
39 BuildRequires:  gtk+-devel >= 1.2.6
40 BuildRequires:  imlib-devel >= 1.9
41 BuildRequires:  libetpan-devel >= 0.38
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libtool
44 # TODO: package gtkmathview: http://helm.cs.unibo.it/mml-widget/ (0.4.3 for gtk1, 0.6.0 for gtk2)
45 %{?with_mathml:BuildRequires:   gtkmathview >= 0.4.2}
46 %{?with_mathml:BuildRequires:   gtkmathview < 0.5}
47 %{?with_ldap:BuildRequires:     openldap-devel}
48 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
49 BuildRequires:  pkgconfig
50 %{?with_faces:Requires: faces}
51 Obsoletes:      sylpheed
52 Obsoletes:      sylpheed-gtk2
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 This program is an X based fast e-mail client which has features same
57 as orginal Sylpheed but with new/improved features. Some of new stuff
58 is really cool and useable.
59
60 %description -l pl
61 Szybki klient poczty o mo¿liwo¶ciach takich jak oryginalny Sylpheed
62 ale z nowymi/poprawionymi funkcjami. Niektóre dodatki s± naprawdê
63 ¶wietne i u¿yteczne.
64
65 %package plugins
66 Summary:        Special plugins for Sylpheed-Claws
67 Summary(pl):    Dodatkowe pluginy dla Sylpheed-Claws
68 Group:          X11/Applications/Networking
69 Requires:       %{name} = %{version}-%{release}
70 %{?with_dillo:Requires: dillo}
71
72 %description plugins
73 This is collection of some usefull plugins for Sylpheed-claws.
74
75 %description plugins -l pl
76 Jest to zbiór kilku dodatkowych pluginów powiêkszaj±cych mo¿liwo¶ci
77 Sylpheeda.
78
79 %package devel
80 Summary:        Headers from Sylpheed-Claws
81 Summary(pl):    Pliki nag³ówkowe programu Sylpheed-Claws
82 Group:          X11/Applications/Networking
83 Requires:       %{name} = %{version}-%{release}
84
85 %description devel
86 Sylpheed-Claws development package.
87
88 %description devel -l pl
89 Pliki nag³ówkowe programu Sylpheed-Claws.
90
91 %package themes
92 Summary:        Themes for Sylpheed-Claws
93 Summary(pl):    Motywy dla programu Sylpheed-Claws
94 Group:          X11/Applications/Networking
95 Requires:       %{name} = %{version}-%{release}
96
97 %description themes
98 Sylpheed-Claws themes package.
99
100 %description themes -l pl
101 Motywy dla programu Sylpheed-Claws.
102
103 %prep
104 %setup -q -a2
105 %patch0 -p1
106 mv sylpheed-iconset-* themes
107 mv -f themes/README README.themes
108
109 mv -f po/{zh_TW.Big5,zh_TW}.po
110 mv -f po/{zh_TW.Big5,zh_TW}.gmo
111 rm -f po/stamp-po
112
113 %build
114 #%%{__libtoolize}
115 #%%{__gettextize}
116 #%%{__aclocal} -I m4
117 #%%{__autoconf}
118 #%%{__autoheader}
119 #%%{__automake}
120 %configure \
121         %{!?with_gpg:--disable-pgpmime-plugin} \
122         %{?with_gpg:--enable-pgpmime-plugin} \
123         %{?with_ldap:--enable-ldap} \
124         %{?with_ssl:--enable-openssl} \
125         %{!?with_ssl:--disable-openssl} \
126         %{?with_ipv6:--enable-ipv6} \
127         %{!?with_faces:--disable-compface} \
128         %{?with_dillo:--enable-dillo-viewer-plugin } \
129         %{!?with_dillo:--disable-dillo-viewer-plugin } \
130         %{?with_clamav:--enable-clamav-plugin } \
131         %{!?with_clamav:--disable-clamav-plugin } \
132         %{?with_mathml:--enable-mathml-viewer-plugin } \
133         %{!?with_mathml:--disable-mathml-viewer-plugin } \
134         %{?with_trayicon:--enable-trayicon-plugin } \
135         %{!?with_trayicon:--disable-trayicon-plugin } \
136         %{?with_spamassassin:--enable-spamassassin-plugin } \
137         --enable-aspell \
138         --enable-gdk-pixbuf \
139         --enable-pthread \
140         --disable-static \
141         --enable-gnomeprint \
142         --enable-libetpan \
143         --with-config-dir=.sylpheed
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
150
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
155 cp -a themes $RPM_BUILD_ROOT%{_datadir}/%{name}
156
157 install %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
158
159 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
160
161 %find_lang %{name}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc AUTHORS ChangeLog NEWS README* TODO
169 %{_mandir}/man1/sylpheed.1*
170 %attr(755,root,root) %{_bindir}/*
171 %dir %{_datadir}/%{name}
172 %dir %{_datadir}/%{name}/manual
173 %{_datadir}/%{name}/manual/en
174 %lang(de) %{_datadir}/%{name}/manual/de
175 %lang(es) %{_datadir}/%{name}/manual/es
176 %lang(fr) %{_datadir}/%{name}/manual/fr
177 %lang(ja) %{_datadir}/%{name}/manual/ja
178 %dir %{_datadir}/%{name}/faq
179 %{_datadir}/%{name}/faq/en
180 %lang(de) %{_datadir}/%{name}/faq/de
181 %lang(es) %{_datadir}/%{name}/faq/es
182 %lang(fr) %{_datadir}/%{name}/faq/fr
183 %lang(it) %{_datadir}/%{name}/faq/it
184 %{_desktopdir}/%{name}.desktop
185 %{_pixmapsdir}/%{name}.png
186
187 %files plugins
188 %defattr(644,root,root,755)
189 %dir %{_libdir}/%{name}
190 %dir %{_libdir}/%{name}/plugins
191 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
192
193 %files devel
194 %defattr(644,root,root,755)
195 %{_includedir}/%{name}
196 %{_pkgconfigdir}/*.pc
197
198 %files themes
199 %defattr(644,root,root,755)
200 %{_datadir}/%{name}/themes
This page took 0.077122 seconds and 4 git commands to generate.