]> git.pld-linux.org Git - packages/claws-mail.git/blob - claws-mail.spec
- missing BR: pkgconfig
[packages/claws-mail.git] / claws-mail.spec
1 #
2 # Conditional build:
3 %bcond_without jconv    # build without jconv support
4 %bcond_without gpg      # build without gpg support
5 %bcond_without ssl      # build without ssl support
6 %bcond_without ipv6     # build without ipv6 support
7 %bcond_without ldap     # build without ldap support
8 %bcond_without faces    # build without compfaces support
9 %bcond_without dillo    # build without dillo plugin (html browser)
10 %bcond_without clamav   # build without clamav plugin
11 %bcond_with mathml      # build with mathml plugin
12 %bcond_without trayicon # buildwithout trayicon plugin
13 %bcond_without spamassassin     # build without spamassassin plugin
14 #
15
16 %define         _sname  sylpheed
17 %define         _iconver        20040206
18 Summary:        A bleeding edge branch of Sylpheed, a GTK+ based, lightweight, and fast e-mail client
19 Summary(pl):    Rozwojowa wersja Sylpheed z du¿± ilo¶ci± zmian oraz ulepszeñ
20 Name:           %{_sname}-claws
21 Version:        0.9.9
22 Release:        2
23 License:        GPL v2
24 Group:          X11/Applications/Networking
25 Source0:        http://dl.sourceforge.net/%{name}/%{_sname}-%{version}claws.tar.bz2
26 # Source0-md5:  9068192f009fb8240be6e9222ff27999
27 Source1:        %{name}.desktop
28 Source2:        http://dl.sourceforge.net/%{name}/%{_sname}-iconset-%{_iconver}.tar.gz
29 # Source2-md5:  478128ccf00914990f73383692b5cd30
30 URL:            http://sylpheed-claws.sourceforge.net/
31 BuildRequires:  aspell-devel >= 0.50
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  bzip2-devel
35 %{?with_clamav:BuildRequires:   clamav-devel}
36 %{?with_faces:BuildRequires:    faces-devel}
37 BuildRequires:  gdk-pixbuf-devel >= 0.8
38 BuildRequires:  gettext-devel
39 BuildRequires:  gmp-devel
40 %{?with_gpg:BuildRequires:      gpgme-devel < 0.4}
41 BuildRequires:  gtk+-devel >= 1.2.6
42 BuildRequires:  imlib-devel
43 %{?with_jconv:BuildRequires:    libjconv-devel}
44 BuildRequires:  libltdl-devel
45 BuildRequires:  libtool
46 %{?with_ldap:BuildRequires:     openldap-devel}
47 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7c}
48 BuildRequires:  pkgconfig
49 %{?with_faces:Requires: faces}
50 Obsoletes:      sylpheed
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 This program is an X based fast e-mail client which has features same
55 as orginal Sylpheed but with new/improved features. Some of new stuff
56 is really cool and useable.
57
58 %description -l pl
59 Szybki klient poczty o mo¿liwo¶ciach takich jak oryginalny Sylpheed
60 ale z nowymi/poprawionymi funkcjami. Niektóre dodatki s± naprawdê
61 ¶wietne i u¿yteczne.
62
63 %package plugins
64 Summary:        Special plugins for Sylpheed-Claws
65 Summary(pl):    Dodatkowe pluginy dla Sylpheed-Claws
66 Group:          X11/Applications/Networking
67 Requires:       %{name} = %{version}
68 %{?with_dillo:Requires: dillo}
69
70 %description plugins
71 This is collection of some usefull plugins for Sylpheed-claws.
72
73 %description plugins -l pl
74 Jest to zbiór kilku dodatkowych pluginów powiêkszaj±cych mo¿liwo¶ci Sylpheeda.
75
76 %package devel
77 Summary:        Headers from Sylpheed-Claws
78 Summary(pl):    Pliki nag³ówkowe programu Sylpheed-Claws
79 Group:          X11/Applications/Networking
80 Requires:       %{name} = %{version}
81
82 %description devel
83 Sylpheed-Claws development package.
84
85 %description devel -l pl
86 Pliki nag³ówkowe programu Sylpheed-Claws.
87
88 %package themes
89 Summary:        Themes for Sylpheed-Claws
90 Summary(pl):    Motywy dla programu Sylpheed-Claws
91 Group:          X11/Applications/Networking
92 Requires:       %{name} = %{version}
93
94 %description themes
95 Sylpheed-Claws themes package.
96
97 %description themes -l pl
98 Motywy dla programu Sylpheed-Claws.
99
100 %prep
101 %setup -q -n %{_sname}-%{version}claws -a1 -a2
102 mv %{_sname}-iconset-* themes
103 mv -f themes/README README.themes
104
105 %build
106 rm -f missing
107 %{__libtoolize}
108 %{__gettextize}
109 %{__aclocal} -I ac
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         %{?with_jconv:--enable-jconv} %{?without_jconv:--disable-jconv} \
115         %{?with_gpg:--enable-gpgme} %{?without_gpg:--disable-gpgme} \
116         %{?with_ldap:--enable-ldap} \
117         %{?with_ssl:--enable-openssl} \
118         %{?with_ipv6:--enable-ipv6 } \
119         %{?without_faces:--disable-compfaces } \
120         %{?with_dillo:--enable-dillo-viewer-plugin } \
121         %{?without_dillo:--disable-dillo-viewer-plugin } \
122         %{?with_clamav:--enable-clamav-plugin } \
123         %{?without_clamav:--disable-clamav-plugin } \
124         %{?with_mathml:--enable-mathml-viewer-plugin } \
125         %{?without_mathml:--disable-mathml-viewer-plugin } \
126         %{?with_trayicon:--enable-trayicon-plugin } \
127         %{?without_trayicon:--disable-trayicon-plugin } \
128         %{?with_spamassassin:--enable-spamassassin-plugin } \
129         --enable-aspell \
130         --enable-gdk-pixbuf \
131         --enable-threads
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
143 cp -a themes $RPM_BUILD_ROOT%{_datadir}/%{_sname}
144
145 install %{_sname}.png $RPM_BUILD_ROOT%{_pixmapsdir}
146
147 %find_lang %{_sname}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files -f %{_sname}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README* TODO
155 %{_mandir}/man1/%{_sname}.1*
156 %attr(755,root,root) %{_bindir}/*
157 %dir %{_datadir}/%{_sname}
158 %dir %{_datadir}/%{_sname}/manual
159 %{_datadir}/%{_sname}/manual/en
160 %lang(de) %{_datadir}/%{_sname}/manual/de
161 %lang(es) %{_datadir}/%{_sname}/manual/es
162 %lang(fr) %{_datadir}/%{_sname}/manual/fr
163 %lang(ja) %{_datadir}/%{_sname}/manual/ja
164 %dir %{_datadir}/%{_sname}/faq
165 %{_datadir}/%{_sname}/faq/en
166 %lang(de) %{_datadir}/%{_sname}/faq/de
167 %lang(es) %{_datadir}/%{_sname}/faq/es
168 %lang(fr) %{_datadir}/%{_sname}/faq/fr
169 %lang(it) %{_datadir}/%{_sname}/faq/it
170 %{_desktopdir}/%{name}.desktop
171 %{_pixmapsdir}/%{_sname}.png
172
173 %files plugins
174 %defattr(644,root,root,755)
175 %dir %{_libdir}/%{_sname}
176 %dir %{_libdir}/%{_sname}/plugins
177 %attr(755,root,root) %{_libdir}/%{_sname}/plugins/*so
178
179 %files devel
180 %defattr(644,root,root,755)
181 %{_includedir}/%{_sname}
182 %{_pkgconfigdir}/*.pc
183
184 %files themes
185 %defattr(644,root,root,755)
186 %{_datadir}/%{_sname}/themes
This page took 0.145442 seconds and 4 git commands to generate.