]> git.pld-linux.org Git - packages/claws-mail.git/blob - claws-mail.spec
- updated to 1.9.100
[packages/claws-mail.git] / claws-mail.spec
1 #
2 # Conditional build:
3 %bcond_without  gpg             # build without GPG support
4 %bcond_without  ssl             # build without SSL support
5 %bcond_without  ipv6            # build without IPv6 support
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_without  faces           # build without compfaces support
8 %bcond_without  dillo           # build without dillo plugin (html browser)
9 %bcond_without  clamav          # build without clamav plugin
10 %bcond_without  spamassassin    # build without spamassassin plugin
11 %bcond_without  trayicon        # build without trayicon plugin
12 %bcond_with     mathml          # build with mathml plugin
13 #
14 %define         _iconver        20040929
15 Summary:        A bleeding edge branch of Sylpheed, a GTK2 based, lightweight, and fast e-mail client
16 Summary(pl):    Rozwojowa wersja Sylpheed z du¿± ilo¶ci± zmian oraz ulepszeñ
17 Name:           sylpheed-claws
18 Version:        1.9.100
19 Release:        1
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/sylpheed-claws/%{name}-%{version}.tar.bz2
23 # Source0-md5:  863c314557f90f17c2f6d6a0ab57e6c2
24 Source1:        %{name}.desktop
25 Source2:        http://dl.sourceforge.net/sylpheed-claws/sylpheed-iconset-%{_iconver}.tar.gz
26 # Source2-md5:  d72cf03bf3d13cf9e2785eaca3807707
27 URL:            http://sylpheed-claws.sourceforge.net/
28 BuildRequires:  aspell-devel >= 2:0.50
29 BuildRequires:  autoconf >= 2.50
30 BuildRequires:  automake
31 BuildRequires:  bzip2-devel
32 %{?with_clamav:BuildRequires:   clamav-devel}
33 %{?with_faces:BuildRequires:    faces-devel}
34 BuildRequires:  gdk-pixbuf-devel >= 0.8
35 BuildRequires:  gettext-devel
36 BuildRequires:  gmp-devel
37 %{?with_gpg:BuildRequires:      gpgme-devel >= 1:0.4.5}
38 BuildRequires:  gtk+-devel >= 1.2.6
39 BuildRequires:  imlib-devel >= 1.9
40 BuildRequires:  libetpan-devel >= 0.40
41 BuildRequires:  libltdl-devel
42 BuildRequires:  libtool
43 # TODO: package gtkmathview: http://helm.cs.unibo.it/mml-widget/ (0.4.3 for gtk1, 0.6.0 for gtk2)
44 %{?with_mathml:BuildRequires:   gtkmathview >= 0.4.2}
45 %{?with_mathml:BuildRequires:   gtkmathview < 0.5}
46 %{?with_ldap:BuildRequires:     openldap-devel}
47 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
48 BuildRequires:  pkgconfig
49 %{?with_faces:Requires: faces}
50 Obsoletes:      sylpheed
51 Obsoletes:      sylpheed-gtk2
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 This program is an X based fast e-mail client which has features same
56 as orginal Sylpheed but with new/improved features. Some of new stuff
57 is really cool and useable.
58
59 %description -l pl
60 Szybki klient poczty o mo¿liwo¶ciach takich jak oryginalny Sylpheed
61 ale z nowymi/poprawionymi funkcjami. Niektóre dodatki s± naprawdê
62 ¶wietne i u¿yteczne.
63
64 %package plugins
65 Summary:        Special plugins for Sylpheed-Claws
66 Summary(pl):    Dodatkowe pluginy dla Sylpheed-Claws
67 Group:          X11/Applications/Networking
68 Requires:       %{name} = %{version}-%{release}
69 %{?with_dillo:Requires: dillo}
70
71 %description plugins
72 This is collection of some usefull plugins for Sylpheed-claws.
73
74 %description plugins -l pl
75 Jest to zbiór kilku dodatkowych pluginów powiêkszaj±cych mo¿liwo¶ci
76 Sylpheeda.
77
78 %package devel
79 Summary:        Headers from Sylpheed-Claws
80 Summary(pl):    Pliki nag³ówkowe programu Sylpheed-Claws
81 Group:          X11/Applications/Networking
82 Requires:       %{name} = %{version}-%{release}
83
84 %description devel
85 Sylpheed-Claws development package.
86
87 %description devel -l pl
88 Pliki nag³ówkowe programu Sylpheed-Claws.
89
90 %package themes
91 Summary:        Themes for Sylpheed-Claws
92 Summary(pl):    Motywy dla programu Sylpheed-Claws
93 Group:          X11/Applications/Networking
94 Requires:       %{name} = %{version}-%{release}
95
96 %description themes
97 Sylpheed-Claws themes package.
98
99 %description themes -l pl
100 Motywy dla programu Sylpheed-Claws.
101
102 %prep
103 %setup -q -a2
104 mv sylpheed-iconset-* themes
105 mv -f themes/README README.themes
106
107 rm -f po/stamp-po
108
109 %build
110 #%%{__libtoolize}
111 #%%{__gettextize}
112 #%%{__aclocal} -I m4
113 #%%{__autoconf}
114 #%%{__autoheader}
115 #%%{__automake}
116 %configure \
117         %{!?with_gpg:--disable-pgpmime-plugin} \
118         %{?with_gpg:--enable-pgpmime-plugin} \
119         %{!?with_ldap:--disable-ldap} \
120         %{?with_ssl:--enable-openssl} \
121         %{!?with_ssl:--disable-openssl} \
122         %{?with_ipv6:--enable-ipv6} \
123         %{!?with_faces:--disable-compface} \
124         %{?with_dillo:--enable-dillo-viewer-plugin } \
125         %{!?with_dillo:--disable-dillo-viewer-plugin } \
126         %{?with_clamav:--enable-clamav-plugin } \
127         %{!?with_clamav:--disable-clamav-plugin } \
128         %{?with_mathml:--enable-mathml-viewer-plugin } \
129         %{!?with_mathml:--disable-mathml-viewer-plugin } \
130         %{?with_trayicon:--enable-trayicon-plugin } \
131         %{!?with_trayicon:--disable-trayicon-plugin } \
132         %{?with_spamassassin:--enable-spamassassin-plugin } \
133         --enable-aspell \
134         --enable-gdk-pixbuf \
135         --enable-pthread \
136         --disable-static \
137         --enable-gnomeprint \
138         --enable-libetpan \
139         --with-config-dir=.sylpheed
140
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
151 cp -a themes $RPM_BUILD_ROOT%{_datadir}/%{name}
152
153 install %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
154
155 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
156
157 %find_lang %{name}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %files -f %{name}.lang
163 %defattr(644,root,root,755)
164 %doc AUTHORS ChangeLog NEWS README* TODO
165 %{_mandir}/man1/%{name}.1*
166 %attr(755,root,root) %{_bindir}/*
167 %dir %{_datadir}/%{name}
168 %dir %{_datadir}/%{name}/manual
169 %{_datadir}/%{name}/manual/en
170 %lang(de) %{_datadir}/%{name}/manual/de
171 %lang(es) %{_datadir}/%{name}/manual/es
172 %lang(fr) %{_datadir}/%{name}/manual/fr
173 %lang(ja) %{_datadir}/%{name}/manual/ja
174 %dir %{_datadir}/%{name}/faq
175 %{_datadir}/%{name}/faq/en
176 %lang(de) %{_datadir}/%{name}/faq/de
177 %lang(es) %{_datadir}/%{name}/faq/es
178 %lang(fr) %{_datadir}/%{name}/faq/fr
179 %lang(it) %{_datadir}/%{name}/faq/it
180 %{_desktopdir}/%{name}.desktop
181 %{_pixmapsdir}/%{name}.png
182
183 %files plugins
184 %defattr(644,root,root,755)
185 %dir %{_libdir}/%{name}
186 %dir %{_libdir}/%{name}/plugins
187 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
188
189 %files devel
190 %defattr(644,root,root,755)
191 %{_includedir}/%{name}
192 %{_pkgconfigdir}/*.pc
193
194 %files themes
195 %defattr(644,root,root,755)
196 %{_datadir}/%{name}/themes
This page took 1.02131 seconds and 4 git commands to generate.