]> git.pld-linux.org Git - packages/claws-mail.git/blob - claws-mail.spec
- rel 2 for aspell 0.50 rebuild
[packages/claws-mail.git] / claws-mail.spec
1 #
2 # Conditional build:
3 %bcond_without  gpg             # build without GPG support
4 %bcond_without  ssl             # build without SSL support
5 %bcond_without  ipv6            # build without IPv6 support
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_without  faces           # build without compfaces support
8 %bcond_without  dillo           # build without dillo plugin (html browser)
9 %bcond_without  clamav          # build without clamav plugin
10 %bcond_without  spamassassin    # build without spamassassin plugin
11 %bcond_without  trayicon        # build without trayicon plugin
12 %bcond_with     mathml          # build with mathml plugin
13 #
14 %define         _sname  sylpheed
15 %define         _iconver        20040929
16 Summary:        A bleeding edge branch of Sylpheed, a GTK+ based, lightweight, and fast e-mail client
17 Summary(pl):    Rozwojowa wersja Sylpheed z du¿± ilo¶ci± zmian oraz ulepszeñ
18 Name:           %{_sname}-claws
19 Version:        0.9.13
20 Release:        2
21 License:        GPL v2
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/sylpheed-claws/%{name}-%{version}.tar.bz2
24 # Source0-md5:  c528dbcb471a106dcccce145f58c4055
25 Source1:        %{name}.desktop
26 Source2:        http://dl.sourceforge.net/sylpheed-claws/%{_sname}-iconset-%{_iconver}.tar.gz
27 # Source2-md5:  d72cf03bf3d13cf9e2785eaca3807707
28 Patch0:         %{name}-locale-names.patch
29 URL:            http://sylpheed-claws.sourceforge.net/
30 BuildRequires:  aspell-devel >= 2:0.50
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  bzip2-devel
34 %{?with_clamav:BuildRequires:   clamav-devel}
35 %{?with_faces:BuildRequires:    faces-devel}
36 BuildRequires:  gdk-pixbuf-devel >= 0.8
37 BuildRequires:  gettext-devel
38 BuildRequires:  gmp-devel
39 %{?with_gpg:BuildRequires:      gpgme-devel >= 0.3.10}
40 %{?with_gpg:BuildRequires:      gpgme-devel < 0.4}
41 BuildRequires:  gtk+-devel >= 1.2.6
42 BuildRequires:  imlib-devel
43 BuildRequires:  libltdl-devel
44 BuildRequires:  libtool
45 # TODO: package gtkmathview: http://helm.cs.unibo.it/mml-widget/ (0.4.3 for gtk1, 0.6.0 for gtk2)
46 %{?with_mathml:BuildRequires:   gtkmathview >= 0.4.2}
47 %{?with_mathml:BuildRequires:   gtkmathview < 0.5}
48 %{?with_ldap:BuildRequires:     openldap-devel}
49 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
50 BuildRequires:  pkgconfig
51 %{?with_faces:Requires: faces}
52 Obsoletes:      sylpheed
53 Obsoletes:      sylpheed-gtk2
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 This program is an X based fast e-mail client which has features same
58 as orginal Sylpheed but with new/improved features. Some of new stuff
59 is really cool and useable.
60
61 %description -l pl
62 Szybki klient poczty o mo¿liwo¶ciach takich jak oryginalny Sylpheed
63 ale z nowymi/poprawionymi funkcjami. Niektóre dodatki s± naprawdê
64 ¶wietne i u¿yteczne.
65
66 %package plugins
67 Summary:        Special plugins for Sylpheed-Claws
68 Summary(pl):    Dodatkowe pluginy dla Sylpheed-Claws
69 Group:          X11/Applications/Networking
70 Requires:       %{name} = %{version}-%{release}
71 %{?with_dillo:Requires: dillo}
72
73 %description plugins
74 This is collection of some usefull plugins for Sylpheed-claws.
75
76 %description plugins -l pl
77 Jest to zbiór kilku dodatkowych pluginów powiêkszaj±cych mo¿liwo¶ci
78 Sylpheeda.
79
80 %package devel
81 Summary:        Headers from Sylpheed-Claws
82 Summary(pl):    Pliki nag³ówkowe programu Sylpheed-Claws
83 Group:          X11/Applications/Networking
84 Requires:       %{name} = %{version}-%{release}
85
86 %description devel
87 Sylpheed-Claws development package.
88
89 %description devel -l pl
90 Pliki nag³ówkowe programu Sylpheed-Claws.
91
92 %package themes
93 Summary:        Themes for Sylpheed-Claws
94 Summary(pl):    Motywy dla programu Sylpheed-Claws
95 Group:          X11/Applications/Networking
96 Requires:       %{name} = %{version}-%{release}
97
98 %description themes
99 Sylpheed-Claws themes package.
100
101 %description themes -l pl
102 Motywy dla programu Sylpheed-Claws.
103
104 %prep
105 %setup -q -a2
106 %patch0 -p1
107 mv %{_sname}-iconset-* themes
108 mv -f themes/README README.themes
109
110 mv -f po/{zh_TW.Big5,zh_TW}.po
111 rm -f po/stamp-po
112
113 %build
114 %{__libtoolize}
115 %{__gettextize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         %{?with_gpg:--enable-gpgme} %{!?with_gpg:--disable-gpgme} \
122         %{?with_ldap:--enable-ldap} \
123         %{?with_ssl:--enable-openssl} \
124         %{?with_ipv6:--enable-ipv6 } \
125         %{!?with_faces:--disable-compface} \
126         %{?with_dillo:--enable-dillo-viewer-plugin } \
127         %{!?with_dillo:--disable-dillo-viewer-plugin } \
128         %{?with_clamav:--enable-clamav-plugin } \
129         %{!?with_clamav:--disable-clamav-plugin } \
130         %{?with_mathml:--enable-mathml-viewer-plugin } \
131         %{!?with_mathml:--disable-mathml-viewer-plugin } \
132         %{?with_trayicon:--enable-trayicon-plugin } \
133         %{!?with_trayicon:--disable-trayicon-plugin } \
134         %{?with_spamassassin:--enable-spamassassin-plugin } \
135         --enable-aspell \
136         --enable-gdk-pixbuf \
137         --enable-threads \
138         --disable-static
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
150 cp -a themes $RPM_BUILD_ROOT%{_datadir}/%{name}
151
152 install %{_sname}.png $RPM_BUILD_ROOT%{_pixmapsdir}
153
154 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog NEWS README* TODO
164 %{_mandir}/man1/%{_sname}.1*
165 %attr(755,root,root) %{_bindir}/*
166 %dir %{_datadir}/%{name}
167 %dir %{_datadir}/%{name}/manual
168 %{_datadir}/%{name}/manual/en
169 %lang(de) %{_datadir}/%{name}/manual/de
170 %lang(es) %{_datadir}/%{name}/manual/es
171 %lang(fr) %{_datadir}/%{name}/manual/fr
172 %lang(ja) %{_datadir}/%{name}/manual/ja
173 %dir %{_datadir}/%{name}/faq
174 %{_datadir}/%{name}/faq/en
175 %lang(de) %{_datadir}/%{name}/faq/de
176 %lang(es) %{_datadir}/%{name}/faq/es
177 %lang(fr) %{_datadir}/%{name}/faq/fr
178 %lang(it) %{_datadir}/%{name}/faq/it
179 %{_desktopdir}/%{name}.desktop
180 %{_pixmapsdir}/%{_sname}.png
181
182 %files plugins
183 %defattr(644,root,root,755)
184 %dir %{_libdir}/%{name}
185 %dir %{_libdir}/%{name}/plugins
186 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
187
188 %files devel
189 %defattr(644,root,root,755)
190 %{_includedir}/%{name}
191 %{_pkgconfigdir}/*.pc
192
193 %files themes
194 %defattr(644,root,root,755)
195 %{_datadir}/%{name}/themes
This page took 0.258545 seconds and 3 git commands to generate.