]> git.pld-linux.org Git - packages/claws-mail.git/blob - claws-mail.spec
bf584d1bfdabbd615f394d872b2e395a368a7398
[packages/claws-mail.git] / claws-mail.spec
1 #
2 # Conditional build:
3 %bcond_without  gpg             # build without GPG support
4 %bcond_without  ssl             # build without SSL support
5 %bcond_without  ipv6            # build without IPv6 support
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_without  faces           # build without compfaces support
8 %bcond_without  dillo           # build without dillo plugin (html browser)
9 %bcond_without  clamav          # build without clamav plugin
10 %bcond_without  spamassassin    # build without spamassassin plugin
11 %bcond_without  trayicon        # build without trayicon plugin
12 %bcond_with     mathml          # build with mathml plugin
13 #
14 %define         _sname  sylpheed
15 %define         _iconver        20040206
16 Summary:        A bleeding edge branch of Sylpheed, a GTK+ based, lightweight, and fast e-mail client
17 Summary(pl):    Rozwojowa wersja Sylpheed z du¿± ilo¶ci± zmian oraz ulepszeñ
18 Name:           %{_sname}-claws
19 Version:        0.9.11
20 Release:        2
21 License:        GPL v2
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{_sname}-%{version}claws.tar.bz2
24 # Source0-md5:  d64647fdbcb49bfa4447989bffb9d0b8
25 Source1:        %{name}.desktop
26 Source2:        http://dl.sourceforge.net/%{name}/%{_sname}-iconset-%{_iconver}.tar.gz
27 # Source2-md5:  478128ccf00914990f73383692b5cd30
28 URL:            http://sylpheed-claws.sourceforge.net/
29 BuildRequires:  aspell-devel >= 0.50
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  bzip2-devel
33 %{?with_clamav:BuildRequires:   clamav-devel}
34 %{?with_faces:BuildRequires:    faces-devel}
35 BuildRequires:  gdk-pixbuf-devel >= 0.8
36 BuildRequires:  gettext-devel
37 BuildRequires:  gmp-devel
38 %{?with_gpg:BuildRequires:      gpgme-devel >= 0.3.10}
39 %{?with_gpg:BuildRequires:      gpgme-devel < 0.4}
40 BuildRequires:  gtk+-devel >= 1.2.6
41 BuildRequires:  imlib-devel
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libtool
44 # TODO: package gtkmathview: http://helm.cs.unibo.it/mml-widget/ (0.4.3 for gtk1, 0.6.0 for gtk2)
45 %{?with_mathml:BuildRequires:   gtkmathview >= 0.4.2}
46 %{?with_mathml:BuildRequires:   gtkmathview < 0.5}
47 %{?with_ldap:BuildRequires:     openldap-devel}
48 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
49 BuildRequires:  pkgconfig
50 %{?with_faces:Requires: faces}
51 Obsoletes:      sylpheed
52 Obsoletes:      sylpheed-gtk2
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 This program is an X based fast e-mail client which has features same
57 as orginal Sylpheed but with new/improved features. Some of new stuff
58 is really cool and useable.
59
60 %description -l pl
61 Szybki klient poczty o mo¿liwo¶ciach takich jak oryginalny Sylpheed
62 ale z nowymi/poprawionymi funkcjami. Niektóre dodatki s± naprawdê
63 ¶wietne i u¿yteczne.
64
65 %package plugins
66 Summary:        Special plugins for Sylpheed-Claws
67 Summary(pl):    Dodatkowe pluginy dla Sylpheed-Claws
68 Group:          X11/Applications/Networking
69 Requires:       %{name} = %{version}-%{release}
70 %{?with_dillo:Requires: dillo}
71
72 %description plugins
73 This is collection of some usefull plugins for Sylpheed-claws.
74
75 %description plugins -l pl
76 Jest to zbiór kilku dodatkowych pluginów powiêkszaj±cych mo¿liwo¶ci Sylpheeda.
77
78 %package devel
79 Summary:        Headers from Sylpheed-Claws
80 Summary(pl):    Pliki nag³ówkowe programu Sylpheed-Claws
81 Group:          X11/Applications/Networking
82 Requires:       %{name} = %{version}-%{release}
83
84 %description devel
85 Sylpheed-Claws development package.
86
87 %description devel -l pl
88 Pliki nag³ówkowe programu Sylpheed-Claws.
89
90 %package themes
91 Summary:        Themes for Sylpheed-Claws
92 Summary(pl):    Motywy dla programu Sylpheed-Claws
93 Group:          X11/Applications/Networking
94 Requires:       %{name} = %{version}-%{release}
95
96 %description themes
97 Sylpheed-Claws themes package.
98
99 %description themes -l pl
100 Motywy dla programu Sylpheed-Claws.
101
102 %prep
103 %setup -q -n %{_sname}-%{version}claws -a1 -a2
104 mv %{_sname}-iconset-* themes
105 mv -f themes/README README.themes
106
107 %build
108 rm -f missing
109 %{__libtoolize}
110 %{__gettextize}
111 %{__aclocal} -I m4
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         %{?with_gpg:--enable-gpgme} %{!?with_gpg:--disable-gpgme} \
117         %{?with_ldap:--enable-ldap} \
118         %{?with_ssl:--enable-openssl} \
119         %{?with_ipv6:--enable-ipv6 } \
120         %{!?with_faces:--disable-compface} \
121         %{?with_dillo:--enable-dillo-viewer-plugin } \
122         %{!?with_dillo:--disable-dillo-viewer-plugin } \
123         %{?with_clamav:--enable-clamav-plugin } \
124         %{!?with_clamav:--disable-clamav-plugin } \
125         %{?with_mathml:--enable-mathml-viewer-plugin } \
126         %{!?with_mathml:--disable-mathml-viewer-plugin } \
127         %{?with_trayicon:--enable-trayicon-plugin } \
128         %{!?with_trayicon:--disable-trayicon-plugin } \
129         %{?with_spamassassin:--enable-spamassassin-plugin } \
130         --enable-aspell \
131         --enable-gdk-pixbuf \
132         --enable-threads
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
144 cp -a themes $RPM_BUILD_ROOT%{_datadir}/%{_sname}
145
146 install %{_sname}.png $RPM_BUILD_ROOT%{_pixmapsdir}
147
148 %find_lang %{_sname}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files -f %{_sname}.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README* TODO
156 %{_mandir}/man1/%{_sname}.1*
157 %attr(755,root,root) %{_bindir}/*
158 %dir %{_datadir}/%{_sname}
159 %dir %{_datadir}/%{_sname}/manual
160 %{_datadir}/%{_sname}/manual/en
161 %lang(de) %{_datadir}/%{_sname}/manual/de
162 %lang(es) %{_datadir}/%{_sname}/manual/es
163 %lang(fr) %{_datadir}/%{_sname}/manual/fr
164 %lang(ja) %{_datadir}/%{_sname}/manual/ja
165 %dir %{_datadir}/%{_sname}/faq
166 %{_datadir}/%{_sname}/faq/en
167 %lang(de) %{_datadir}/%{_sname}/faq/de
168 %lang(es) %{_datadir}/%{_sname}/faq/es
169 %lang(fr) %{_datadir}/%{_sname}/faq/fr
170 %lang(it) %{_datadir}/%{_sname}/faq/it
171 %{_desktopdir}/%{name}.desktop
172 %{_pixmapsdir}/%{_sname}.png
173
174 %files plugins
175 %defattr(644,root,root,755)
176 %dir %{_libdir}/%{_sname}
177 %dir %{_libdir}/%{_sname}/plugins
178 %attr(755,root,root) %{_libdir}/%{_sname}/plugins/*so
179
180 %files devel
181 %defattr(644,root,root,755)
182 %{_includedir}/%{_sname}
183 %{_pkgconfigdir}/*.pc
184
185 %files themes
186 %defattr(644,root,root,755)
187 %{_datadir}/%{_sname}/themes
This page took 0.067936 seconds and 3 git commands to generate.