]> git.pld-linux.org Git - packages/claws-mail.git/blob - claws-mail.spec
14c074466e0d25e38f83006560f4c158809ee977
[packages/claws-mail.git] / claws-mail.spec
1 #
2 # Conditional build:
3 %bcond_without jconv    # build without jconv support
4 %bcond_without gpg      # build without gpg support
5 %bcond_without ssl      # build without ssl support
6 %bcond_without ipv6     # build without ipv6 support
7 %bcond_without ldap     # build without ldap support
8 %bcond_without faces    # build without compfaces support
9 %bcond_without dillo    # build without dillo plugin (html browser)
10 %bcond_without clamav   # build without clamav plugin
11 %bcond_with mathml      # build with mathml plugin
12 %bcond_without trayicon # buildwithout trayicon plugin
13 %bcond_without spamassassin     # build without spamassassin plugin
14 #
15
16 %define         _sname  sylpheed
17 %define         _iconver        20040206
18 Summary:        A bleeding edge branch of Sylpheed, a GTK+ based, lightweight, and fast e-mail client
19 Summary(pl):    Rozwojowa wersja Sylpheed z du¿± ilo¶ci± zmian oraz ulepszeñ
20 Name:           %{_sname}-claws
21 Version:        0.9.9
22 Release:        1
23 License:        GPL v2
24 Group:          X11/Applications/Networking
25 Source0:        http://dl.sourceforge.net/%{name}/%{_sname}-%{version}claws.tar.bz2
26 # Source0-md5:  9068192f009fb8240be6e9222ff27999
27 Source1:        %{name}.desktop
28 Source2:        http://dl.sourceforge.net/%{name}/%{_sname}-iconset-%{_iconver}.tar.gz
29 # Source2-md5:  478128ccf00914990f73383692b5cd30
30 URL:            http://sylpheed-claws.sourceforge.net/
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 %{?with_clamav:BuildRequires:   clamav-devel}
34 %{?with_faces:BuildRequires:    faces-devel}
35 BuildRequires:  gdk-pixbuf-devel >= 0.8
36 BuildRequires:  gettext-devel
37 BuildRequires:  gmp-devel
38 BuildRequires:  bzip2-devel
39 %{?with_gpg:BuildRequires:      gpgme-devel < 0.4}
40 BuildRequires:  gtk+-devel >= 1.2.6
41 BuildRequires:  imlib-devel
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libtool
44 %{?with_ldap:BuildRequires:     openldap-devel}
45 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7c}
46 BuildRequires:  aspell-devel >= 0.50
47 %{?with_jconv:BuildRequires:    libjconv-devel}
48 %{?with_faces:Requires: faces}
49 Obsoletes:      sylpheed
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 This program is an X based fast e-mail client which has features same
54 as orginal Sylpheed but with new/improved features. Some of new stuff
55 is really cool and useable.
56
57 %description -l pl
58 Szybki klient poczty o mo¿liwo¶ciach takich jak oryginalny Sylpheed
59 ale z nowymi/poprawionymi funkcjami. Niektóre dodatki s± naprawdê
60 ¶wietne i u¿yteczne.
61
62 %package plugins
63 Summary:        Special plugins for Sylpheed-Claws
64 Summary(pl):    Dodatkowe pluginy dla Sylpheed-Claws
65 Group:          X11/Applications/Networking
66 Requires:       %{name} = %{version}
67 %{?with_dillo:Requires: dillo}
68
69 %description plugins
70 This is collection of some usefull plugins for Sylpheed-claws.
71
72 %description plugins -l pl
73 Jest to zbiór kilku dodatkowych pluginów powiêkszaj±cych mo¿liwo¶ci Sylpheeda.
74
75 %package devel
76 Summary:        Headers from Sylpheed-Claws
77 Summary(pl):    Pliki nag³ówkowe programu Sylpheed-Claws
78 Group:          X11/Applications/Networking
79 Requires:       %{name} = %{version}
80
81 %description devel
82 Sylpheed-Claws development package.
83
84 %description devel -l pl
85 Pliki nag³ówkowe programu Sylpheed-Claws.
86
87 %package themes
88 Summary:        Themes for Sylpheed-Claws
89 Summary(pl):    Motywy dla programu Sylpheed-Claws
90 Group:          X11/Applications/Networking
91 Requires:       %{name} = %{version}
92
93 %description themes
94 Sylpheed-Claws themes package.
95
96 %description themes -l pl
97 Motywy dla programu Sylpheed-Claws.
98
99 %prep
100 %setup -q -n %{_sname}-%{version}claws -a1 -a2
101 mv %{_sname}-iconset-* themes
102 mv -f themes/README README.themes
103
104 %build
105 rm -f missing
106 %{__libtoolize}
107 %{__gettextize}
108 %{__aclocal} -I ac
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         %{?with_jconv:--enable-jconv} %{?without_jconv:--disable-jconv} \
114         %{?with_gpg:--enable-gpgme} %{?without_gpg:--disable-gpgme} \
115         %{?with_ldap:--enable-ldap} \
116         %{?with_ssl:--enable-openssl} \
117         %{?with_ipv6:--enable-ipv6 } \
118         %{?without_faces:--disable-compfaces } \
119         %{?with_dillo:--enable-dillo-viewer-plugin } \
120         %{?without_dillo:--disable-dillo-viewer-plugin } \
121         %{?with_clamav:--enable-clamav-plugin } \
122         %{?without_clamav:--disable-clamav-plugin } \
123         %{?with_mathml:--enable-mathml-viewer-plugin } \
124         %{?without_mathml:--disable-mathml-viewer-plugin } \
125         %{?with_trayicon:--enable-trayicon-plugin } \
126         %{?without_trayicon:--disable-trayicon-plugin } \
127         %{?with_spamassassin:--enable-spamassassin-plugin } \
128         --enable-aspell \
129         --enable-gdk-pixbuf \
130         --enable-threads
131
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
142 cp -a themes $RPM_BUILD_ROOT%{_datadir}/%{_sname}
143
144 install %{_sname}.png $RPM_BUILD_ROOT%{_pixmapsdir}
145
146 %find_lang %{_sname}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %files -f %{_sname}.lang
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog NEWS README* TODO
154 %{_mandir}/man1/%{_sname}.1*
155 %attr(755,root,root) %{_bindir}/*
156 %dir %{_datadir}/%{_sname}
157 %dir %{_datadir}/%{_sname}/manual
158 %{_datadir}/%{_sname}/manual/en
159 %lang(de) %{_datadir}/%{_sname}/manual/de
160 %lang(es) %{_datadir}/%{_sname}/manual/es
161 %lang(fr) %{_datadir}/%{_sname}/manual/fr
162 %lang(ja) %{_datadir}/%{_sname}/manual/ja
163 %dir %{_datadir}/%{_sname}/faq
164 %{_datadir}/%{_sname}/faq/en
165 %lang(de) %{_datadir}/%{_sname}/faq/de
166 %lang(es) %{_datadir}/%{_sname}/faq/es
167 %lang(fr) %{_datadir}/%{_sname}/faq/fr
168 %lang(it) %{_datadir}/%{_sname}/faq/it
169 %{_desktopdir}/%{name}.desktop
170 %{_pixmapsdir}/%{_sname}.png
171
172 %files plugins
173 %defattr(644,root,root,755)
174 %dir %{_libdir}/%{_sname}
175 %dir %{_libdir}/%{_sname}/plugins
176 %attr(755,root,root) %{_libdir}/%{_sname}/plugins/*so
177
178 %files devel
179 %defattr(644,root,root,755)
180 %{_includedir}/%{_sname}
181 %{_pkgconfigdir}/*.pc
182
183 %files themes
184 %defattr(644,root,root,755)
185 %{_datadir}/%{_sname}/themes
This page took 0.077332 seconds and 2 git commands to generate.