]> git.pld-linux.org Git - packages/claws-mail-extra-plugins.git/blob - claws-mail-extra-plugins.spec
- added temporary [..]-others package
[packages/claws-mail-extra-plugins.git] / claws-mail-extra-plugins.spec
1
2 #TODO           -split plugins in to packages
3 #               -remove *others package
4
5 Summary:        Plugins for sylpheed-claws (Metapackage)
6 Summary(pl):    Wtyczki dla sylpheed-claws (Metapaczka)
7 Name:           sylpheed-claws-extra-plugins
8 Version:        2.2.0
9 Release:        1
10 License:        GPL
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/sylpheed-claws/%{name}-%{version}.tar.gz
13 # Source0-md5:  0e305f70bdfcb7968846d20f42da561f
14 URL:            http://claws.sylpheed.org/plugins.php
15 BuildRequires:  sylpheed-claws-devel >= 2.1.0
16 BuildRequires:  libgtkhtml-devel
17 BuildRequires:  synce-libsynce-devel
18 BuildRequires:  synce-librapi2-devel
19 Requires:       sylpheed-claws >= 2.1.0
20 Requires:       sylpheed-claws-plugin-maildir >= %{version}
21 Requires:       sylpheed-claws-plugin-gtkhtml2_viewer >= %{version}
22 Requires:       sylpheed-claws-plugin-smime >= %{version}
23 Requires:       sylpheed-claws-plugin-others >= %{version}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Plugins for sylpheed-claws
28
29 %description -l pl
30 Wtyczki dla sylpheed-claws
31
32 %package -n sylpheed-claws-plugin-gtkhtml2_viewer
33 Summary:        gtkhtml2_viewer plugin for sylpheed-claws
34 Summary(pl):    Wtyczka gtkhtml2_viewer dla sylpheed-claws
35 Group:          X11/Applications/Networking
36
37 %description -n sylpheed-claws-plugin-gtkhtml2_viewer
38 Renders HTML mail using the gtkhtml2 rendering widget.
39
40 %description -n sylpheed-claws-plugin-gtkhtml2_viewer -l pl
41 Wy¶wietla maile HTML u¿ywaj±c widgetia gtkhtml2.
42
43 %package -n sylpheed-claws-plugin-maildir
44 Summary:        Maildir++ Plugin for Sylpheed-Claws
45 Summary(pl):    Wtyczka Maildir++ dla Sylpheed-Claws
46 Group:          X11/Applications/Networking
47
48 %description -n sylpheed-claws-plugin-maildir
49 The Maildir++ plugin for Sylpheed-Claws provides direct access to
50 Maildir++ Mailboxes used by IMAP-Servers like Courier-IMAP, BincIMAP
51 or Dovecot without having all the IMAP overhead of a connection to
52 'localhost'.
53
54 %description -n sylpheed-claws-plugin-maildir -l pl
55 Wtyczka obs³ugi Maildir++ dla Sylpheed-Claws umo¿liwia bezpo¶redni
56 dostêp do skrzynek formatu Maildir++ u¿ywanych przez serwery IMAP, jak
57 np. Courier-IMAP, BincIMAP czy Dovecot bez narzutu zwi±zanego z
58 obs³ug± protoko³u IMAP przy po³±czeniu z "localhostem".
59
60 %package -n sylpheed-claws-plugin-smime
61 Summary:        S/MIME plugin for sylpheed-claws
62 Summary(pl):    Wtyczka S/MIME dla sylpheed-claws
63 Group:          X11/Applications/Networking
64
65 %description -n sylpheed-claws-plugin-smime
66 This plugin handles S/MIME signed and/or encrypted mails. You can
67 decrypt mails, verify signatures or sign and encrypt your own mails.
68
69 %description -n sylpheed-claws-plugin-smime -l pl
70 Ta wtyczka obs³uguje podpisan± i/lub zaszyfrowan± pocztê S/MIME.
71 Mo¿esz rozszyfrowywaæ, weryfikowaæ lub podpisywaæ i szyfrowaæ w³asn±
72 pocztê.
73
74 %package -n sylpheed-claws-plugin-others
75 Summary:        Few plugins for sylpheed-claws
76 Summary(pl):    Kilka dodatkowych wtyczek dla sylpheed-claws
77 Group:          X11/Applications/Networking
78
79 %description -n sylpheed-claws-plugin-others
80 Few plugins for sylpheed-claws.
81
82 %define _plugins_dir    %{_libdir}/sylpheed-claws/plugins
83
84 %prep
85 %setup -q
86
87 %build
88 for i in `find * -maxdepth 0 -type d -print`; do
89         cd "$i"
90         %configure
91         %{__make}
92         cd ../
93 done
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98
99 for i in `find * -maxdepth 0 -type d -print`; do
100         cd "$i"
101         %{__make} install \
102                 DESTDIR=$RPM_BUILD_ROOT
103         cd ../
104 done
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111
112 %files -n sylpheed-claws-plugin-gtkhtml2_viewer
113 %defattr(644,root,root,755)
114 %doc maildir-*/ChangeLog maildir-*/README
115 %attr(755,root,root) %{_plugins_dir}/gtkhtml2_viewer.so
116 %lang(es) %{_datadir}/locale/es/LC_MESSAGES/gtkhtml2_viewer.mo
117 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/gtkhtml2_viewer.mo
118 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/gtkhtml2_viewer.mo
119
120 %files -n sylpheed-claws-plugin-maildir
121 %defattr(644,root,root,755)
122 %doc maildir-*/ChangeLog maildir-*/README
123 %attr(755,root,root) %{_plugins_dir}/maildir.so
124
125 %files -n sylpheed-claws-plugin-smime
126 %defattr(644,root,root,755)
127 %doc smime-*/ChangeLog smime-*/README
128 %attr(755,root,root) %{_plugins_dir}/smime.so
129
130 %files -n sylpheed-claws-plugin-others
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_plugins_dir}/acpi_notifier.so
133 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/acpi_notifier.mo
134 %lang(es) %{_datadir}/locale/es/LC_MESSAGES/acpi_notifier.mo
135 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/acpi_notifier.mo
136 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/acpi_notifier.mo
137 %lang(it) %{_datadir}/locale/it/LC_MESSAGES/acpi_notifier.mo
138 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/acpi_notifier.mo
139 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/acpi_notifier.mo
140 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/acpi_notifier.mo
141 %lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/acpi_notifier.mo
142 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/acpi_notifier.mo
143 %attr(755,root,root) %{_plugins_dir}/att_remover.so
144 %attr(755,root,root) %{_plugins_dir}/cachesaver.so
145 %attr(755,root,root) %{_plugins_dir}/etpan-privacy.so
146 %attr(755,root,root) %{_plugins_dir}/fetchinfo_plugin.so
147 %attr(755,root,root) %{_plugins_dir}/fetchinfo_plugin_gtk.so
148 %attr(755,root,root) %{_plugins_dir}/mailmbox.so
149 %attr(755,root,root) %{_plugins_dir}/newmail.so
150 %attr(755,root,root) %{_plugins_dir}/notification_plugin.so
151 %attr(755,root,root) %{_plugins_dir}/perl_plugin.so
152 %attr(755,root,root) %{_plugins_dir}/rssyl.so
153 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/rssyl.mo
154 %lang(es) %{_datadir}/locale/es/LC_MESSAGES/rssyl.mo
155 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/rssyl.mo
156 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/rssyl.mo
157 %lang(it) %{_datadir}/locale/it/LC_MESSAGES/rssyl.mo
158 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/rssyl.mo
159 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/rssyl.mo
160 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/rssyl.mo
161 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/rssyl.mo
162 %lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/rssyl.mo
163 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/rssyl.mo
164 %attr(755,root,root) %{_plugins_dir}/synce_plugin.so
165 %attr(755,root,root) %{_plugins_dir}/vcalendar.so
166 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/vcalendar.mo
167 %lang(es) %{_datadir}/locale/es/LC_MESSAGES/vcalendar.mo
168 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/vcalendar.mo
169 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/vcalendar.mo
170 %lang(it) %{_datadir}/locale/it/LC_MESSAGES/vcalendar.mo
171 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/vcalendar.mo
172 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/vcalendar.mo
173 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/vcalendar.mo
174 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/vcalendar.mo
175 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/vcalendar.mo
This page took 0.243941 seconds and 4 git commands to generate.