]> git.pld-linux.org Git - packages/claws-mail-extra-plugins.git/blob - claws-mail-extra-plugins.spec
- updated to 2.3.0
[packages/claws-mail-extra-plugins.git] / claws-mail-extra-plugins.spec
1
2 #TODO           -split plugins in to packages
3 #               -remove *others package
4
5 Summary:        Plugins for sylpheed-claws (Metapackage)
6 Summary(pl):    Wtyczki dla sylpheed-claws (metapakiet)
7 Name:           sylpheed-claws-extra-plugins
8 Version:        2.3.0
9 Release:        1
10 License:        GPL
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/sylpheed-claws/%{name}-%{version}.tar.bz2
13 # Source0-md5:  06b53d69913ea1c96fb154fa2686606a
14 URL:            http://claws.sylpheed.org/plugins.php
15 BuildRequires:  curl-devel
16 BuildRequires:  libgtkhtml-devel
17 BuildRequires:  perl-devel
18 BuildRequires:  sylpheed-claws-devel >= 2.1.0
19 BuildRequires:  synce-librapi2-devel
20 BuildRequires:  synce-libsynce-devel
21 Requires:       sylpheed-claws >= 2.1.0
22 Requires:       sylpheed-claws-plugin-gtkhtml2_viewer = %{version}-%{release}
23 Requires:       sylpheed-claws-plugin-maildir = %{version}-%{release}
24 Requires:       sylpheed-claws-plugin-smime = %{version}-%{release}
25 Requires:       sylpheed-claws-plugin-others = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _plugins_dir    %{_libdir}/sylpheed-claws/plugins
29
30 %description
31 Plugins for sylpheed-claws (metapackage).
32
33 %description -l pl
34 Wtyczki dla sylpheed-claws (metapakiet).
35
36 %package -n sylpheed-claws-plugin-gtkhtml2_viewer
37 Summary:        gtkhtml2_viewer plugin for sylpheed-claws
38 Summary(pl):    Wtyczka gtkhtml2_viewer dla sylpheed-claws
39 Group:          X11/Applications/Networking
40
41 %description -n sylpheed-claws-plugin-gtkhtml2_viewer
42 Renders HTML mail using the gtkhtml2 rendering widget.
43
44 %description -n sylpheed-claws-plugin-gtkhtml2_viewer -l pl
45 Wy¶wietla maile HTML u¿ywaj±c widgeta gtkhtml2.
46
47 %package -n sylpheed-claws-plugin-maildir
48 Summary:        Maildir++ Plugin for Sylpheed-Claws
49 Summary(pl):    Wtyczka Maildir++ dla Sylpheed-Claws
50 Group:          X11/Applications/Networking
51
52 %description -n sylpheed-claws-plugin-maildir
53 The Maildir++ plugin for Sylpheed-Claws provides direct access to
54 Maildir++ Mailboxes used by IMAP-Servers like Courier-IMAP, BincIMAP
55 or Dovecot without having all the IMAP overhead of a connection to
56 'localhost'.
57
58 %description -n sylpheed-claws-plugin-maildir -l pl
59 Wtyczka obs³ugi Maildir++ dla Sylpheed-Claws umo¿liwia bezpo¶redni
60 dostêp do skrzynek formatu Maildir++ u¿ywanych przez serwery IMAP, jak
61 np. Courier-IMAP, BincIMAP czy Dovecot bez narzutu zwi±zanego z
62 obs³ug± protoko³u IMAP przy po³±czeniu z "localhostem".
63
64 %package -n sylpheed-claws-plugin-smime
65 Summary:        S/MIME plugin for sylpheed-claws
66 Summary(pl):    Wtyczka S/MIME dla sylpheed-claws
67 Group:          X11/Applications/Networking
68
69 %description -n sylpheed-claws-plugin-smime
70 This plugin handles S/MIME signed and/or encrypted mails. You can
71 decrypt mails, verify signatures or sign and encrypt your own mails.
72
73 %description -n sylpheed-claws-plugin-smime -l pl
74 Ta wtyczka obs³uguje podpisan± i/lub zaszyfrowan± pocztê S/MIME.
75 Pozwala rozszyfrowywaæ, weryfikowaæ lub podpisywaæ i szyfrowaæ w³asn±
76 pocztê.
77
78 %package -n sylpheed-claws-plugin-others
79 Summary:        Few plugins for sylpheed-claws
80 Summary(pl):    Kilka dodatkowych wtyczek dla sylpheed-claws
81 Group:          X11/Applications/Networking
82
83 %description -n sylpheed-claws-plugin-others
84 Few plugins for sylpheed-claws.
85
86 %description -n sylpheed-claws-plugin-others -l pl
87 Kilka dodatkowych wtyczek dla sylpheed-claws.
88
89 %prep
90 %setup -q
91
92 %build
93 for i in `find * -maxdepth 0 -type d -print`; do
94         cd "$i"
95         %configure
96         %{__make}
97         cd ..
98 done
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 for i in `find * -maxdepth 0 -type d -print`; do
104         %{__make} -C "$i" install \
105                 DESTDIR=$RPM_BUILD_ROOT
106 done
107
108 %find_lang gtkhtml2_viewer
109
110 %find_lang acpi_notifier
111 %find_lang rssyl
112 %find_lang vcalendar
113 cat acpi_notifier.lang rssyl.lang vcalendar.lang > others.lang
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120
121 %files -n sylpheed-claws-plugin-gtkhtml2_viewer -f gtkhtml2_viewer.lang
122 %defattr(644,root,root,755)
123 %doc maildir-*/ChangeLog maildir-*/README
124 %attr(755,root,root) %{_plugins_dir}/gtkhtml2_viewer.so
125
126 %files -n sylpheed-claws-plugin-maildir
127 %defattr(644,root,root,755)
128 %doc maildir-*/ChangeLog maildir-*/README
129 %attr(755,root,root) %{_plugins_dir}/maildir.so
130
131 %files -n sylpheed-claws-plugin-smime
132 %defattr(644,root,root,755)
133 %doc smime-*/ChangeLog smime-*/README
134 %attr(755,root,root) %{_plugins_dir}/smime.so
135
136 %files -n sylpheed-claws-plugin-others -f others.lang
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_plugins_dir}/acpi_notifier.so
139 %attr(755,root,root) %{_plugins_dir}/att_remover.so
140 %attr(755,root,root) %{_plugins_dir}/cachesaver.so
141 %attr(755,root,root) %{_plugins_dir}/etpan-privacy.so
142 %attr(755,root,root) %{_plugins_dir}/fetchinfo_plugin.so
143 %attr(755,root,root) %{_plugins_dir}/fetchinfo_plugin_gtk.so
144 %attr(755,root,root) %{_plugins_dir}/mailmbox.so
145 %attr(755,root,root) %{_plugins_dir}/newmail.so
146 %attr(755,root,root) %{_plugins_dir}/notification_plugin.so
147 %attr(755,root,root) %{_plugins_dir}/perl_plugin.so
148 %attr(755,root,root) %{_plugins_dir}/rssyl.so
149 %attr(755,root,root) %{_plugins_dir}/synce_plugin.so
150 %attr(755,root,root) %{_plugins_dir}/vcalendar.so
This page took 0.200589 seconds and 4 git commands to generate.