]> git.pld-linux.org Git - packages/clapack.git/blob - clapack.spec
- up to 3.2.1 (patches from gentoo); cblas is gone
[packages/clapack.git] / clapack.spec
1 Summary:        The CLAPACK libraries for numerical linear algebra
2 Summary(pl.UTF-8):      Biblioteki numeryczne CLAPACK do algebry liniowej
3 Name:           clapack
4 Version:        3.2.1
5 Release:        1
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/clapack/%{name}-%{version}-CMAKE.tgz
9 # Source0-md5:  4fd18eb33f3ff8c5d65a7d43913d661b
10 Patch0:         %{name}-%{version}-fix_include_file.patch
11 Patch1:         %{name}-%{version}-noblasf2c.patch
12 Patch2:         %{name}-%{version}-hang.patch
13 Patch3:         %{name}-%{version}-findblas-r6.patch
14 URL:            http://www.netlib.org/clapack/
15 BuildRequires:  cmake
16 BuildRequires:  gcc-g77
17 BuildRequires:  libtool >= 1:1.4.2-9
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 CLAPACK (Linear Algebra PACKage) is a standard library for numerical
22 linear algebra. CLAPACK provides routines for solving systems of
23 simultaneous linear equations, least-squares solutions of linear
24 systems of equations, eigenvalue problems, and singular value
25 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
26 Schur, and generalized Schur) and related computations (i.e.,
27 reordering of Schur factorizations and estimating condition numbers)
28 are also included. CLAPACK can handle dense and banded matrices, but
29 not general sparse matrices. Similar functionality is provided for
30 real and complex matrices in both single and double precision. CLAPACK
31 is coded in Fortran77 and translated to C using f2c.
32
33 %description -l pl.UTF-8
34 CLAPACK (Linear Algebra PACKage) jest standardową biblioteką
35 numeryczną do algebry liniowej. Dostarcza funkcje rozwiązywania:
36 układów równań liniowych, układów równań metodą najmniejszych
37 kwadratów, problemów własnych. Zawiera algorytmy faktoryzacji macierzy
38 (LU, Cholesky'ego, QR, SVD, Schura, uogólnioną Schura) i związanych z
39 tym obliczeń (np. przenumerowanie w faktoryzacji Schura i estymację
40 uwarunkowania). CLAPACK może obsługiwać macierze blokowe i pasmowe,
41 ale nie rzadkie w ogólnym przypadku. Zapewnia funkcjonalność dla
42 macierzy rzeczywistych i zespolonych, dla liczb pojedynczej i
43 podwójnej precyzji. CLAPACK jest napisany w Fortranie 77 i
44 przetłumaczony na C przy użyciu f2c.
45
46 %package devel
47 Summary:        CLAPACK header files
48 Summary(pl.UTF-8):      Pliki nagłówkowe CLAPACK
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 CLAPACK header files.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe CLAPACK.
57
58 %package static
59 Summary:        Static CLAPACK libraries
60 Summary(pl.UTF-8):      Biblioteki statyczne CLAPACK
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static CLAPACK libraries.
66
67 %description static -l pl.UTF-8
68 Biblioteki statyczne CLAPACK.
69
70 %prep
71 %setup -q -n %{name}-%{version}-CMAKE
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76
77 %build
78 install -d build
79 cd build
80 %cmake \
81         ..
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} -C build install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README*
100 %attr(755,root,root) %{_libdir}/libclapack.so.*.*.*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_libdir}/libclapack.so
105 %{_includedir}/clapack
106 %{_datadir}/cmake/Modules/clapack*.cmake
This page took 0.036987 seconds and 3 git commands to generate.