]> git.pld-linux.org Git - packages/cinelerra.git/blob - cinelerra.spec
8331ec1f42c4917893ce9978a728c861557274d0
[packages/cinelerra.git] / cinelerra.spec
1 # TODO: build guicast as separate, shared library to use in
2 #       xmovie, mix2005 and cinelerra
3 Summary:        Cinelerra - capturing, editing and production of audio/video material
4 Summary(pl):    Cinelerra - nagrywanie, obróbka i produkcja materia³u audio/video
5 Name:           cinelerra
6 Version:        2.0
7 Release:        1
8 License:        GPL
9 Group:          X11/Applications
10 Source0:        http://dl.sourceforge.net/heroines/%{name}-%{version}-src.tar.bz2
11 # Source0-md5:  2beb3f1df203cbdc8918f06ea573324c
12 Patch0:         %{name}-system-libs.patch
13 Patch1:         %{name}-strip.patch
14 Patch2:         %{name}-fontsdir.patch
15 Patch3:         %{name}-locale_h.patch
16 Patch4:         %{name}-guicast_bootstrap.patch
17 URL:            http://heroinewarrior.com/cinelerra.php3
18 BuildRequires:  OpenEXR-devel >= 1.2.1
19 BuildRequires:  XFree86-devel
20 BuildRequires:  alsa-lib-devel >= 1.0.8
21 BuildRequires:  esound-devel
22 BuildRequires:  freetype-devel >= 2.1.4
23 BuildRequires:  lame-libs-devel >= 3.93.1
24 BuildRequires:  libavc1394-devel >= 0.5.1
25 BuildRequires:  libiec61883-devel >= 1.0.0
26 BuildRequires:  libmpeg3-devel >= 1.6
27 BuildRequires:  libraw1394-devel >= 1.2.0
28 BuildRequires:  libsndfile-devel >= 1.0.11
29 BuildRequires:  libstdc++-devel >= 5:3.2.2
30 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
31 BuildRequires:  libtiff-devel >= 3.5.7
32 BuildRequires:  libuuid-devel
33 %ifarch %{ix86}
34 BuildRequires:  nasm
35 %endif
36 BuildRequires:  quicktime4linux-devel >= 2.1
37 Requires:       OpenEXR-devel >= 1.2.1
38 Requires:       alsa-lib >= 1.0.8
39 Requires:       freetype >= 2.1.4
40 Requires:       libavc1394 >= 0.5.1
41 Requires:       libiec61883 >= 1.0.0
42 Requires:       libmpeg3 >= 1.6
43 Requires:       libraw1394 >= 1.2.0
44 Requires:       libsndfile >= 1.0.11
45 Requires:       libtheora >= 1.0-0.alpha4
46 Requires:       quicktime4linux >= 2.1
47 Obsoletes:      bcast
48 # build system seems to be x86-oriented; anybody to fix it ?
49 ExclusiveArch:  %{ix86} %{x8664}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _noautostrip    .*/microtheme.plugin
53
54 %description
55 There are two types of moviegoers: producers who create new content,
56 going back over their content at future points for further refinement,
57 and consumers who want to acquire the content and watch it. Cinelerra
58 is not intended for consumers. Cinelerra has many features for
59 uncompressed content, high resolution processing, and compositing,
60 with very few shortcuts. Producers need these features because of the
61 need to retouch many generations of footage with alterations to the
62 format, which makes Cinelerra very complex.
63
64 Cinelerra was meant to be a Broadcast 2000 replacement.
65
66 %description -l pl
67 S± dwa rodzaje u¿ytkowników zajmuj±cych siê filmami: producenci
68 tworz±cy nowe filmy, wracaj±cy do nich w przysz³o¶ci w celu dalszego
69 wyg³adzenia, oraz konsumenci, którzy chc± tylko zdobyæ film i go
70 obejrzeæ. Cinelerra nie jest dla konsumentów. Program ma wiele
71 mo¿liwo¶ci do edycji nieskompresowanej zawarto¶ci, obróbki w wysokiej
72 rozdzielczo¶ci oraz monta¿u, z bardzo ma³± liczb± skrótów. Producenci
73 potrzebuj± tych mo¿liwo¶ci ze wzglêdu na konieczno¶æ retuszowania
74 oraz modyfikacji formatu, co czyni program bardzo z³o¿onym.
75
76 Cinelerra by³a tworzona z my¶l± o zast±pieniu programu Broadcast 2000.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83 %patch3 -p1
84 %patch4 -p1
85
86 # assume we have <linux/videodev2.h> (it's in llh)
87 echo '#define HAVE_VIDEO4LINUX2' > hvirtual_config.h
88 echo '#define PACKAGE_STRING "cinelerra"' >> hvirtual_config.h
89
90 rm -rf OpenEXR-* alsa-lib-* audiofile esound fftw-* freetype-* libavc1394-* libiec61883-* libmpeg3 libraw1394-* libsndfile-* libtheora-* mjpegtools-* quicktime tiff-* uuid
91
92 %build
93 CFLAGS="%{rpmcflags}"; export CFLAGS
94 %{__make} -f build/Makefile.toolame
95 %{__make} -C mpeg2enc
96 %{__make} -C mplexlo
97 %{__make} -C guicast
98 # cinelerra, defaulttheme and microtheme are stripped before running "bootstrap"
99 %{__make} -C cinelerra \
100         STRIP="%{?debug:true}%{!?debug:strip -R.note -R.comment}"
101 %{__make} -C plugins \
102         STRIP="%{?debug:true}%{!?debug:strip -R.note -R.comment}"
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/cinelerra}
107
108 install cinelerra/*/cinelerra $RPM_BUILD_ROOT%{_bindir}
109 install plugins/`uname -m`/*.plugin $RPM_BUILD_ROOT%{_libdir}/cinelerra
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc doc/{*.png,*.html,press} cinelerra/{CHANGELOG*,TODO}
117 %attr(755,root,root) %{_bindir}/*
118 %attr(755,root,root) %{_libdir}/cinelerra
This page took 0.128278 seconds and 3 git commands to generate.