]> git.pld-linux.org Git - packages/chromium.git/blob - chromium.spec
7baf8cbde9a6378c3170e23dd0a0848fab433f03
[packages/chromium.git] / chromium.spec
1 Summary:        Chromium B.S.U. is a fast paced, arcade-style space shooter
2 Summary(pl):    Chromium B.S.U. to szybko tocz±ca siê strzelanina
3 Name:           chromium
4 Version:        0.9.12
5 Release:        8
6 License:        Artistic
7 Group:          X11/Applications/Games
8 Group(de):      X11/Applikationen/Spiele
9 Group(pl):      X11/Aplikacje/Gry
10 Source0:        http://www.reptilelabour.com/software/files/chromium/%{name}-src-%{version}.tar.gz
11 Source1:        http://www.reptilelabour.com/software/files/chromium/%{name}-data-%{version}.tar.gz
12 Source2:        %{name}.desktop
13 Source3:        %{name}-setup.desktop
14 Source4:        %{name}.png
15 Patch0:         %{name}-fix-flags.patch
16 Patch1:         %{name}-glibc-2.2.2.patch
17 Patch3:         %{name}-fix-openal-configurecall.patch
18 Patch4:         %{name}-configure_needs_bash.patch
19 Patch5:         %{name}-qt.patch
20 Patch6:         %{name}-use_proper_CC.patch
21 URL:            http://www.reptilelabour.com/software/chromium/
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel >= 1.1.6
24 BuildRequires:  libogg-devel libvorbis-devel
25 BuildRequires:  smpeg >= 0.4.2
26 BuildRequires:  qt-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _prefix         /usr/X11R6/
30 %define         _mandir         %{_prefix}/man
31 %define         _bindir         %{_prefix}/bin
32 %define         _datadir        %{_prefix}/share/games
33 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
34 %define         _noreqdep       libGL.so.1 libGLU.so.1 libGLcore.so.1
35
36 %description
37 You are captain of the cargo ship Chromium B.S.U., responsible for
38 delivering supplies to our troops on the front line. Your ship has a
39 small fleet of robotic fighters which you control from the relative
40 safety of the Chromium vessel.
41 - Do not let ANY enemy ships get past your fighters! Each enemy ship
42   that makes it past the bottom of the screen will attack the Chromium,
43   and you lose a fighter.
44 - Use your fighters as weapons! Crash into enemies to destroy them
45   before they can get past you.
46 - Strategic suicide is a powerful tactic! When the Chromium launches a
47   new fighter, it releases a high energy burst which destroys all
48   enemies in range.
49 - Self-destruct to preserve your ammunition! A double-right-click will
50   cause your current fighter to self-destruct. Before the ship blows up,
51   it ejects its ammunition so that the next fighter can pick it up.
52
53 %description -l pl
54 Jeste¶ kapitanem statku Chromium B.S.U, odpowiedzialnego za
55 dostarczenie zapasów do oddzia³ów na linii frontu. Statek ma ma³±
56 flotê automatycznych my¶liwców, którymi mo¿esz kierowaæ ze statku.
57 - Nie pozwól ¯ADNEMU wrogowi przej¶æ za swoje my¶liwce! Ka¿dy statek
58   który dotrze na dó³ ekranu zaatakuje Chromium i stracisz my¶liwca.
59 - U¿ywaj my¶liwców jako broni! Uderzaj we wrogów aby zniszczyæ ich
60   zanim oni przedostan± siê do ciebie.
61 - Strategiczne samobójstwo to dobra taktyka! Kiedy Chromium odpala
62   nowego my¶liwca, wytwarza du¿o energii, która niszczy wszystkich
63   wrogów w zasiêgu.
64 - Autodestrukcja pozwala zachowaæ amunicjê - przed wysadzeniem siê
65   my¶liwiec zwraca amunicjê tak, ¿e nastêpny mo¿e j± przej±æ.
66
67 %package setup
68 Summary:        Setup frontend for Chromium
69 Summary(pl):    Graficzny konfigurator Chromium
70 Group:          X11/Applications/Games
71 Group(de):      X11/Applikationen/Spiele
72 Group(pl):      X11/Aplikacje/Gry
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       qt
75
76 %description setup
77 This package contains the setup frontend (using QT) to ease
78 configuration of Chromium, especially for its playlist features.
79
80 %description setup -l pl
81 Ten pakiet zawiera graficzny konfigurator (napisany w QT) u³atwiaj±cy
82 ustalanie parametrów dla gry Chromium, szczególnie je¶li chodzi o
83 listê muzyki do odtwarzania.
84
85 %prep
86 %setup -q -n Chromium-0.9
87 %patch0 -p0
88 %patch1 -p0
89 %patch3 -p0
90 %patch4 -p1
91 %patch5 -p1
92 %patch6 -p1
93 find . -type d -name .xvpics -exec rm -rf {} \; ||:
94
95 %build
96 export CFLAGS="%{rpmcflags} -fno-omit-frame-pointer -pipe"
97 export CXXFLAGS="%{rpmcflags} -fno-omit-frame-pointer -pipe"
98 export CC=%{__cc}
99 export CXX=%{__cc}
100 export LINK=%{__cc}
101 export DEFS="%{rpmcflags} -DGAMESBINDIR=\\\"%{_bindir}\\\" \
102             -DPKGDATADIR=\\\"%{_datadir}/Chromium-0.9\\\" -DUSE_SDL \
103             `sdl-config --cflags` -DOLD_OPENAL -DAUDIO_OPENAL -D_REENTRANT \
104             -I../../include -I../support/openal/linux/include -I../support/openal/include"
105 #export OPENAL_CONFIG_OPTS="./configure %{_target_platform} --with-gcc=%{__cc}"
106 export OPENAL_CONFIG_OPTS="./configure --with-gcc=%{__cc}"
107 export QTDIR=%{_prefix}
108 ./configure --enable-vorbis
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT{%{_applnkdir}/{Games/Arcade,Settings},%{_pixmapsdir},%{_bindir},%{_datadir}}
114
115 # It is enough to install one file
116 #%{__make} install DESTDIR=RPM_BUILD_ROOT
117 install bin/* $RPM_BUILD_ROOT/%{_bindir}
118
119 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Games/Arcade/%{name}.desktop
120 install %{SOURCE3} $RPM_BUILD_ROOT%{_applnkdir}/Settings/%{name}.desktop
121 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
122
123 gzip -9nf README LICENSE
124
125 #This installs datafiles
126 tar zxvf %{SOURCE1} -C $RPM_BUILD_ROOT/%{_datadir}
127 find . -type d -name CVS -exec rm -rf {} \; ||:
128
129 %files
130 %defattr(644,root,root,755)
131 %doc LICENSE.gz
132 %attr(755,root,root) %{_bindir}/*
133 %{_datadir}/*
134 %{_pixmapsdir}/chromium.png
135 %{_applnkdir}/Games/Arcade/*
136
137 %files setup
138 %defattr(644,root,root,755)
139 %doc README.gz
140 %attr(755,root,root) %{_bindir}/chromium-setup
141 %{_applnkdir}/Settings/*
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
This page took 0.07368 seconds and 3 git commands to generate.