]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
cd4b2b34d033ef623fb2a2a1788aabc8af152ab6
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  ffmpegsumo              # build with ffmpegsumo
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_jsoncpp  # system jsoncpp
18 %bcond_without  system_libusb   # system libusb-1
19 %bcond_without  system_libwebp  # system libwebp
20 %bcond_without  system_speex    # system speex
21 %bcond_with             system_sqlite   # system sqlite
22 %bcond_without  system_srtp             # system srtp (can be used if using bundled libjingle)
23 %bcond_with             system_v8               # system v8
24 %bcond_without  system_vpx              # system vpx
25 %bcond_without  system_yasm             # system yasm
26 # system zlib disabled because of mixed-source.patch
27 # https://code.google.com/p/chromium/issues/detail?id=143623
28 %bcond_with             system_zlib             # system zlib
29 %bcond_with             tcmalloc                # use tcmalloc
30 %bcond_without  verbose                 # verbose build (V=1)
31
32 %if %{with nacl}
33 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
34 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
35 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
36 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
37 #14:51:06 @baggins> as-needed will take care of unneeded lib
38 #14:52:03 @baggins> -lssp comes with gcc
39 %define         _ssp_cflags     %{nil}
40 %endif
41
42 # TODO
43 # - check system sqlite linking problems
44 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
45 # - use_system_ssl (use_openssl: http://crbug.com/62803)
46 # - use_system_ffmpeg && build_ffmpegsumo
47 # - use_system_hunspell
48 # - use_system_stlport
49 # - other defaults: src/build/common.gypi
50
51 # NOTES:
52 # - mute BEEP mixer if you do not want to hear horrible system bell when
53 #   pressing home/end in url bar or more ^F search results on page.
54 # - build -bp: 1.2G
55 # - build i686: -bc: 2.7G; -bb: ~1.0GB
56 # - build x86_64: ~1.9G
57 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
58 # - to look for new tarball, use update-source.sh script
59
60 # NOTE TO USERS:
61 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
62 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
63 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
64
65 %define         branch          23.0.1271
66 %define         basever         64
67 %define         patchver        91
68 %define         gyp_rev 1014
69 Summary:        A WebKit powered web browser
70 Name:           chromium-browser
71 Version:        %{branch}.%{patchver}
72 Release:        1
73 License:        BSD, LGPL v2+ (ffmpeg)
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
76 # Source0-md5:  6c467affd292ee9a9020ac91147969c8
77 %if "%{?patchver}" != ""
78 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
79 # Patch0-md5:   1fa1a86b56fed7a9f04a7f0d8d591178
80 %endif
81 Source1:        %{name}.default
82 Source2:        %{name}.sh
83 Source3:        %{name}.desktop
84 Source5:        find-lang.sh
85 Source6:        update-source.sh
86 Source7:        clean-source.sh
87 Source8:        get-source.sh
88 #Patch10:               system-libs.patch
89 Patch1:         plugin-searchdirs.patch
90 Patch2:         gyp-system-minizip.patch
91 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
92 Patch4:         path-libpdf.patch
93 Patch5:         options-support.patch
94 Patch6:         get-webkit_revision.patch
95 Patch7:         dlopen_sonamed_gl.patch
96 Patch8:         chromium_useragent.patch.in
97 Patch9:         chromium-ppapi.patch
98 # https://bugs.gentoo.org/show_bug.cgi?id=393471
99 # libjpeg-turbo >= 1.1.90 supports that feature
100 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
101 Patch15:        nacl-build-irt.patch
102 Patch16:        nacl-linkingfix.patch
103 Patch17:        system-icu.patch
104 Patch18:        nacl-no-untar.patch
105 Patch19:        system-jsoncpp.patch
106 Patch20:        system-speex.patch
107 Patch21:        system-srtp.patch
108 Patch22:        gnome3-volume-control.patch
109 URL:            http://www.chromium.org/Home
110 %{?with_gconf:BuildRequires:    GConf2-devel}
111 BuildRequires:  OpenGL-GLU-devel
112 BuildRequires:  alsa-lib-devel
113 BuildRequires:  atk-devel
114 BuildRequires:  bison
115 BuildRequires:  bzip2-devel
116 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
117 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
118 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
119 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
120 %{?with_cups:BuildRequires:     cups-devel}
121 BuildRequires:  dbus-glib-devel
122 BuildRequires:  expat-devel
123 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
124 BuildRequires:  flex
125 BuildRequires:  fontconfig-devel
126 BuildRequires:  glib2-devel
127 BuildRequires:  gperf
128 BuildRequires:  gtk+2-devel
129 %{?with_kerberos:BuildRequires: heimdal-devel}
130 BuildRequires:  hicolor-icon-theme
131 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
132 BuildRequires:  libevent-devel
133 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
134 BuildRequires:  libicu-devel >= 4.6
135 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
136 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
137 BuildRequires:  libpng-devel
138 %{?with_selinux:BuildRequires:  libselinux-devel}
139 BuildRequires:  libstdc++-devel
140 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
141 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
142 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
143 BuildRequires:  libxml2-devel
144 BuildRequires:  libxslt-devel
145 BuildRequires:  lzma
146 BuildRequires:  minizip-devel
147 BuildRequires:  nspr-devel
148 BuildRequires:  nss-devel >= 1:3.12.3
149 BuildRequires:  pam-devel
150 BuildRequires:  pango-devel
151 BuildRequires:  perl-modules
152 BuildRequires:  pkgconfig
153 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
154 BuildRequires:  python
155 #BuildRequires: python-gyp >= 1-%{gyp_rev}
156 BuildRequires:  python-modules
157 BuildRequires:  rpm >= 4.4.9-56
158 BuildRequires:  rpmbuild(macros) >= 1.453
159 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
160 BuildRequires:  sqlite3-devel >= 3.6.1
161 %{?with_system_srtp:BuildRequires:      srtp-devel >= 1.4.4}
162 BuildRequires:  subversion
163 BuildRequires:  tar >= 1:1.22
164 BuildRequires:  udev-devel
165 BuildRequires:  util-linux
166 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
167 BuildRequires:  which
168 BuildRequires:  xorg-lib-libXScrnSaver-devel
169 BuildRequires:  xorg-lib-libXt-devel
170 BuildRequires:  xorg-lib-libXtst-devel
171 BuildRequires:  xz
172 %{?with_system_yasm:BuildRequires:      yasm}
173 %{?with_system_zlib:BuildRequires:      zlib-devel}
174 Requires:       browser-plugins >= 2.0
175 Requires:       desktop-file-utils
176 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
177 Requires:       hicolor-icon-theme
178 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
179 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
180 Requires:       xdg-utils >= 1.0.2-4
181 Provides:       wwwbrowser
182 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
183 Obsoletes:      chromium-browser-inspector < 15.0.863.0
184 ExclusiveArch:  %{ix86} %{x8664} arm
185 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
186
187 %define         find_lang       sh find-lang.sh %{buildroot}
188
189 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
190 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
191
192 %if %{without debuginfo}
193 %define         _enable_debug_packages  0
194 %endif
195
196 %description
197 Chromium is an open-source browser project that aims to build a safer,
198 faster, and more stable way for all Internet users to experience the
199 web.
200
201 Chromium serves as a base for Google Chrome, which is Chromium
202 rebranded (name and logo) with very few additions such as usage
203 tracking and an auto-updater system.
204
205 %package l10n
206 Summary:        chromium-browser language packages
207 Group:          I18n
208 Requires:       %{name} = %{version}-%{release}
209
210 %description l10n
211 Chromium is an open-source browser project that aims to build a safer,
212 faster, and more stable way for all Internet users to experience the
213 web.
214
215 This package contains language packages for 50 languages:
216
217 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
218 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
219 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
220 zh-TW
221
222 %prep
223 %setup -qc
224 %if "%{?patchver}" != ""
225 cd %{name}-%{branch}.%{basever}
226 %patch0 -p1
227 cd ..
228 %endif
229 mv %{name}-%{branch}.%{basever}/src .
230
231 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
232 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
233 . ./src/chrome/VERSION
234 ver=$MAJOR.$MINOR.$BUILD.$PATCH
235 test "$ver" = %{version}
236
237 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
238 test "$gyp_rev" = %{gyp_rev} || :
239
240 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
241
242 # add chromium and pld to useragent
243 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
244 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
245     -e 's/@BUILD_DIST_NAME@/PLD/g' \
246     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
247     < %{PATCH8} | %{__patch} -p1
248
249 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
250 ln -s %{SOURCE7} src
251
252 #%patch10 -p1
253 %patch1 -p1
254 %patch2 -p1
255 %patch3 -p1
256 %patch4 -p1
257 %patch5 -p1
258 %patch6 -p1
259 %patch7 -p1
260 %patch15 -p1
261 cd src
262 %patch9 -p0
263 %{!?with_libjpegturbo:%patch11 -p0}
264 %patch16 -p1
265 %patch17 -p0
266 %patch19 -p1
267 %patch21 -p1
268 %patch22 -p1
269 cd ..
270 %patch18 -p1
271 %patch20 -p1
272
273 cd src
274
275 # Missing gyp files in tarball.
276 # https://code.google.com/p/chromium/issues/detail?id=144823
277 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
278         echo "tarball fixed, please remove workaround"
279         exit 1
280 fi
281
282 install -d chrome/test/data/nacl
283 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
284 {
285  'targets': [
286    {
287      'target_name': 'nacl_tests',
288      'type': 'none',
289    },
290  ],
291 }
292 EOF
293
294 sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
295
296 %build
297 cd src
298
299 %if %{with nacl}
300 rm -rf native_client/toolchain/linux_x86_newlib
301 # Make symlinks for nacl
302 cd native_client/toolchain
303 install -d linux_x86_newlib/x86_64-nacl/bin
304 install -d linux_x86_newlib/x86_64-nacl/lib
305 install -d linux_x86_newlib/x86_64-nacl/lib32
306 install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
307 install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
308 install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
309 # link newlib toolchain to glibc as well, see gentoo bug #417019
310 #ln -s linux_x86_newlib linux_x86
311 cd linux_x86_newlib/x86_64-nacl/bin
312 ln -s %{_bindir}/x86_64-nacl-gcc gcc
313 ln -s %{_bindir}/x86_64-nacl-g++ g++
314 ln -s %{_bindir}/x86_64-nacl-ar ar
315 ln -s %{_bindir}/x86_64-nacl-as as
316 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
317 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
318 ln -s %{_bindir}/x86_64-nacl-strip strip
319 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
320 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
321 cd ../nacl/include
322 for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
323         ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
324 done
325 cd ../../../../../..
326 %endif
327
328 test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
329 %ifarch %{ix86}
330         -Dtarget_arch=ia32 \
331 %endif
332 %ifarch %{x8664}
333         -Dtarget_arch=x64 \
334 %endif
335 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
336         -Dno_strict_aliasing=1 -Dgcc_version=44 \
337 %endif
338 %if %{with sandboxing}
339         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
340         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
341 %endif
342         %{!?debug:-Dwerror=} \
343         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
344         %{?with_shared_libs:-Dlibrary=shared_library} \
345         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
346         -Dffmpeg_branding=Chrome \
347         -Dproprietary_codecs=1 \
348 %if %{with nacl}
349         -Ddisable_glibc=1 \
350         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
351         -Ddisable_glibc_untar=1 \
352         -Ddisable_newlib_untar=1 \
353         -Ddisable_pnacl_untar=1 \
354 %else
355         -Ddisable_nacl=1 \
356 %endif
357         -Ddisable_pnacl=1 \
358         %{!?with_sse2:-Ddisable_sse2=1} \
359         %{?with_selinux:-Dselinux=1} \
360         %{gyp_with cups} \
361         %{gyp_with gconf} \
362         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
363         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
364         %{gyp_with pulseaudio} \
365         %{gyp_with system_flac} \
366         %{gyp_with system_libusb} \
367         %{gyp_with system_libwebp} \
368         %{gyp_with system_speex} \
369         %{gyp_with system_sqlite} \
370         %{gyp_with system_v8} \
371         %{gyp_with system_vpx} \
372         %{gyp_with system_yasm} \
373         %{gyp_with system_zlib} \
374         -Duse_system_bzip2=1 \
375         -Duse_system_icu=1 \
376         -Duse_system_libevent=1 \
377         -Duse_system_libjpeg=1 \
378         -Duse_system_libpng=1 \
379         -Duse_system_libxml=1 \
380         -Duse_system_libxslt=1 \
381         -Duse_system_xdg_utils=1 \
382         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
383         -Dlinux_use_gold_binary=0 \
384         -Dlinux_use_gold_flags=0
385
386 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
387         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
388         %{?with_verbose:V=1} \
389         CC="%{__cc}" \
390         CXX="%{__cxx}" \
391         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
392         CC.host="%{__cc}" \
393         CXX.host="%{__cxx}" \
394         LDFLAGS.host="%{rpmldflags}" \
395         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
396         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
397
398 %install
399 rm -rf $RPM_BUILD_ROOT
400 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
401         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
402
403 cd src/out/%{!?debug:Release}%{?debug:Debug}
404 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
405 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
406 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
407 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
408 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
409 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
410 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
411 %if %{with ffmpegsumo}
412 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
413 %endif
414 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
415
416 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
417
418 %if %{with nacl}
419 # Install Native Client files on platforms that support it.
420 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
421 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
422 %ifarch %{x8664}
423 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
424 %endif
425 %ifarch %{ix86}
426 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
427 %endif
428 %endif
429
430 cd -
431
432 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
433         size=${icon##*/product_logo_}
434         size=${size%.png}
435
436         # this will skip non-numeric (22_mono_invert, 22_mono)
437         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
438         test -d "$dir" || continue
439
440         install -d $RPM_BUILD_ROOT$dir
441         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
442 done
443
444 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
445 # http://code.google.com/p/chromium/issues/detail?id=24507
446 gecko-mediaplayer*.so
447 EOF
448
449 # find locales
450 %find_lang %{name}.lang
451 # always package en-US
452 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
453
454 %clean
455 rm -rf $RPM_BUILD_ROOT
456
457 %post
458 %update_icon_cache hicolor
459 %update_desktop_database
460 %update_browser_plugins
461
462 %postun
463 if [ "$1" = 0 ]; then
464         %update_icon_cache hicolor
465         %update_browser_plugins
466 fi
467
468 %files
469 %defattr(644,root,root,755)
470 %{_browserpluginsconfdir}/browsers.d/%{name}.*
471 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
472 %dir %{_sysconfdir}/%{name}
473 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
474 %attr(755,root,root) %{_bindir}/%{name}
475 %{_mandir}/man1/%{name}.1*
476 %{_desktopdir}/*.desktop
477 %{_iconsdir}/hicolor/*/apps/%{name}.png
478 %dir %{_libdir}/%{name}
479 %{_libdir}/%{name}/chrome*.pak
480 %{_libdir}/%{name}/content_resources.pak
481 %{_libdir}/%{name}/resources.pak
482 %dir %{_libdir}/%{name}/locales
483 %{_libdir}/%{name}/locales/en-US.pak
484 %dir %{_libdir}/%{name}/resources
485 %{_libdir}/%{name}/resources/inspector
486 %dir %{_libdir}/%{name}/themes
487 %dir %{_libdir}/%{name}/extensions
488 %dir %{_libdir}/%{name}/plugins
489 %attr(755,root,root) %{_libdir}/%{name}/%{name}
490 # These unique permissions are intentional and necessary for the sandboxing
491 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
492
493 # ffmpeg libs
494 %if %{with ffmpegsumo}
495 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
496 %endif
497
498 %if %{with nacl}
499 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
500 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
501 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
502 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
503 %endif
504
505 %files l10n -f %{name}.lang
506 %defattr(644,root,root,755)
This page took 0.050955 seconds and 2 git commands to generate.