]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
bf3870097094a25f0be977cc163a8502e025a6f3
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_with             system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_with             system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_with             system_protobuf # system protobuf
27 %bcond_without  system_speex    # system speex
28 %bcond_with             system_sqlite   # system sqlite
29 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
30 %bcond_with             system_v8               # system v8
31 %bcond_without  system_libvpx   # system libvpx
32 %bcond_without  system_yasm             # system yasm
33 %bcond_without  system_zlib             # system zlib
34 %bcond_without  tcmalloc                # use tcmalloc
35 %bcond_without  verbose                 # verbose build (V=1)
36
37 %if %{with nacl}
38 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42 #14:51:06 @baggins> as-needed will take care of unneeded lib
43 #14:52:03 @baggins> -lssp comes with gcc
44 %define         _ssp_cflags     %{nil}
45 %endif
46
47 # TODO
48 # - check system sqlite linking problems
49 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
50 # - use_system_ssl (use_openssl: http://crbug.com/62803)
51 # - use_system_hunspell
52 # - use_system_stlport
53 # - other defaults: src/build/common.gypi
54
55 # NOTES:
56 # - mute BEEP mixer if you do not want to hear horrible system bell when
57 #   pressing home/end in url bar or more ^F search results on page.
58 # - space considerations:
59 #   - unpacked sources: ~574MiB
60 #   - built code: ~1.4GiB (x86_64/i686)
61 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
62 # - to look for new tarball, use update-source.sh script
63
64 # NOTE TO USERS:
65 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
66 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
67 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
68
69 %define         branch          24.0.1312
70 %define         basever         52
71 %define         patchver        %{nil}
72 %define         gyp_rev 1014
73 Summary:        A WebKit powered web browser
74 Name:           chromium-browser
75 %if "%{?patchver}" != ""
76 Version:        %{branch}.%{patchver}
77 %else
78 Version:        %{branch}.%{basever}
79 %endif
80 Release:        1
81 License:        BSD, LGPL v2+ (ffmpeg)
82 Group:          X11/Applications/Networking
83 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
84 # Source0-md5:  bcc3976e61b9ce715ba9c85d46df72f1
85 %if "%{?patchver}" != ""
86 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
87 # Patch0-md5:   2f4e98e37053705fd86ffcb49f1f2247
88 %endif
89 Source1:        %{name}.default
90 Source2:        %{name}.sh
91 Source3:        %{name}.desktop
92 Source5:        find-lang.sh
93 Source6:        update-source.sh
94 Source7:        clean-source.sh
95 Source8:        get-source.sh
96 Source9:        master_preferences.json
97 Patch1:         plugin-searchdirs.patch
98 #Patch2:                system-nspr.patch
99 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
100 Patch4:         path-libpdf.patch
101 Patch6:         get-webkit_revision.patch
102 Patch7:         dlopen_sonamed_gl.patch
103 Patch8:         chromium_useragent.patch.in
104 Patch9:         chromium-ppapi.patch
105 Patch10:        system-libxnvctrl.patch
106 # https://bugs.gentoo.org/show_bug.cgi?id=393471
107 # libjpeg-turbo >= 1.1.90 supports that feature
108 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
109 Patch15:        nacl-build-irt.patch
110 Patch16:        nacl-linkingfix.patch
111 Patch18:        nacl-no-untar.patch
112 Patch19:        system-jsoncpp.patch
113 Patch22:        pulse_fix-157876.patch
114 Patch23:        no-pnacl.patch
115 Patch24:        nacl-verbose.patch
116 Patch25:        gnome3-volume-control.patch
117 Patch26:        master-prefs-path.patch
118 Patch27:        tcmalloc-glibc2.16.patch
119 URL:            http://www.chromium.org/Home
120 %{?with_gconf:BuildRequires:    GConf2-devel}
121 BuildRequires:  OpenGL-GLU-devel
122 BuildRequires:  alsa-lib-devel
123 BuildRequires:  atk-devel
124 BuildRequires:  bison
125 BuildRequires:  bzip2-devel
126 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
127 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
128 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
129 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
130 %{?with_cups:BuildRequires:     cups-devel}
131 BuildRequires:  dbus-glib-devel
132 BuildRequires:  expat-devel
133 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
134 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
135 BuildRequires:  flex
136 BuildRequires:  fontconfig-devel
137 BuildRequires:  glib2-devel
138 BuildRequires:  gperf
139 BuildRequires:  gtest-devel
140 BuildRequires:  gtk+2-devel
141 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
142 %{?with_kerberos:BuildRequires: heimdal-devel}
143 BuildRequires:  hicolor-icon-theme
144 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
145 %{?with_system_libxvnctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
146 BuildRequires:  libevent-devel
147 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
148 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
149 BuildRequires:  libicu-devel >= 4.6
150 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
151 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
152 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
153 BuildRequires:  libpng-devel
154 %{?with_selinux:BuildRequires:  libselinux-devel}
155 BuildRequires:  libstdc++-devel
156 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
157 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
158 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
159 BuildRequires:  libxml2-devel
160 BuildRequires:  libxslt-devel
161 BuildRequires:  lzma
162 %{?with_system_minizip:BuildRequires:   minizip-devel}
163 BuildRequires:  nspr-devel
164 BuildRequires:  nss-devel >= 1:3.12.3
165 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
166 BuildRequires:  pam-devel
167 BuildRequires:  pango-devel
168 BuildRequires:  perl-modules
169 BuildRequires:  pkgconfig
170 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
171 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
172 BuildRequires:  python
173 #BuildRequires: python-gyp >= 1-%{gyp_rev}
174 BuildRequires:  python-modules
175 BuildRequires:  rpm >= 4.4.9-56
176 BuildRequires:  rpmbuild(macros) >= 1.453
177 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
178 BuildRequires:  sqlite3-devel >= 3.6.1
179 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
180 BuildRequires:  subversion
181 BuildRequires:  tar >= 1:1.22
182 BuildRequires:  udev-devel
183 BuildRequires:  util-linux
184 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
185 BuildRequires:  which
186 BuildRequires:  xorg-lib-libXScrnSaver-devel
187 BuildRequires:  xorg-lib-libXt-devel
188 BuildRequires:  xorg-lib-libXtst-devel
189 BuildRequires:  xz
190 %{?with_system_yasm:BuildRequires:      yasm}
191 %{?with_system_zlib:BuildRequires:      zlib-devel}
192 Requires:       browser-plugins >= 2.0
193 Requires:       desktop-file-utils
194 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
195 Requires:       hicolor-icon-theme
196 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
197 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
198 Requires:       xdg-utils >= 1.0.2-4
199 Provides:       wwwbrowser
200 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
201 Obsoletes:      chromium-browser-inspector < 15.0.863.0
202 ExclusiveArch:  %{ix86} %{x8664} arm
203 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
204
205 %define         find_lang       sh find-lang.sh %{buildroot}
206
207 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
208 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
209
210 %if %{without debuginfo}
211 %define         _enable_debug_packages  0
212 %endif
213
214 %description
215 Chromium is an open-source browser project that aims to build a safer,
216 faster, and more stable way for all Internet users to experience the
217 web.
218
219 Chromium serves as a base for Google Chrome, which is Chromium
220 rebranded (name and logo) with very few additions such as usage
221 tracking and an auto-updater system.
222
223 %package l10n
224 Summary:        chromium-browser language packages
225 Group:          I18n
226 Requires:       %{name} = %{version}-%{release}
227
228 %description l10n
229 Chromium is an open-source browser project that aims to build a safer,
230 faster, and more stable way for all Internet users to experience the
231 web.
232
233 This package contains language packages for 50 languages:
234
235 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
236 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
237 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
238 zh-TW
239
240 %prep
241 %setup -qc
242 %if "%{?patchver}" != ""
243 cd %{name}-%{branch}.%{basever}
244 %patch0 -p1
245 cd ..
246 %endif
247 mv %{name}-%{branch}.%{basever}/src .
248
249 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
250 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
251 . ./src/chrome/VERSION
252 ver=$MAJOR.$MINOR.$BUILD.$PATCH
253 test "$ver" = %{version}
254
255 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
256 test "$gyp_rev" = %{gyp_rev} || :
257
258 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
259
260 # add chromium and pld to useragent
261 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
262 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
263     -e 's/@BUILD_DIST_NAME@/PLD/g' \
264     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
265     < %{PATCH8} | %{__patch} -p1
266
267 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
268 ln -s %{SOURCE7} src
269
270 %patch1 -p1
271 %patch3 -p1
272 %patch4 -p1
273 %patch6 -p1
274 %patch7 -p1
275 %patch15 -p1
276 cd src
277 %patch9 -p0
278 #%patch2 -p1
279 %{!?with_libjpegturbo:%patch11 -p0}
280 %patch16 -p1
281 %patch19 -p1
282 %patch22 -p1
283 %patch25 -p1
284 %patch27 -p1
285 cd ..
286 %patch18 -p1
287 %patch23 -p1
288 %patch24 -p1
289 %patch26 -p1
290
291 cd src
292
293 # Missing gyp files in tarball.
294 # https://code.google.com/p/chromium/issues/detail?id=144823
295 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
296         echo "tarball fixed, please remove workaround"
297         exit 1
298 fi
299
300 install -d chrome/test/data/nacl
301 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
302 {
303  'targets': [
304    {
305      'target_name': 'nacl_tests',
306      'type': 'none',
307    },
308  ],
309 }
310 EOF
311
312 sh -x clean-source.sh \
313         %{!?with_nacl:nacl=0} \
314         %{!?with_system_protobuf:protobuf=0} \
315         %{!?with_system_v8:v8=0} \
316         %{!?with_system_zlib:zlib=0} \
317         %{nil}
318
319 %build
320 cd src
321
322 %if %{with nacl}
323 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
324 # Make symlinks for NaCL
325 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
326
327 cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
328 __cc='%{__cc}'
329 if [ "${__cc#ccache}" != "$__cc" ]; then
330         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
331         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
332         %{__sed} -i -e '1i#!/bin/sh' gcc g++
333         chmod +x gcc g++
334 else
335         ln -s %{_bindir}/x86_64-nacl-gcc gcc
336         ln -s %{_bindir}/x86_64-nacl-g++ g++
337 fi
338 ln -s %{_bindir}/x86_64-nacl-ar ar
339 ln -s %{_bindir}/x86_64-nacl-as as
340 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
341 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
342 ln -s %{_bindir}/x86_64-nacl-strip strip
343 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
344 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
345 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
346 cd ../../../../..
347 fi
348 %endif
349
350 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
351 test -e Makefile || %{__python} build/gyp_chromium \
352         --format=make \
353         -Goutput_dir=../out \
354         build/all.gyp \
355 %ifarch %{ix86}
356         -Dtarget_arch=ia32 \
357 %endif
358 %ifarch %{x8664}
359         -Dtarget_arch=x64 \
360 %endif
361 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
362         -Dno_strict_aliasing=1 -Dgcc_version=44 \
363 %endif
364 %if %{with sandboxing}
365         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
366         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
367 %endif
368         %{!?debug:-Dwerror=} \
369         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
370         %{?with_shared_libs:-Dlibrary=shared_library} \
371         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
372         -Dinclude_tests=0 \
373 %if %{with nacl}
374         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
375         -Ddisable_glibc_untar=1 \
376         -Ddisable_newlib_untar=1 \
377         -Ddisable_glibc=1 \
378         -Ddisable_pnacl=1 \
379         -Dbuild_pnacl_newlib=0 \
380 %else
381         -Ddisable_pnacl_untar=1 \
382         -Ddisable_nacl=1 \
383 %endif
384         %{!?with_sse2:-Ddisable_sse2=1} \
385         %{?with_selinux:-Dselinux=1} \
386         %{gyp_with cups} \
387         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
388         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
389         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
390         %{gyp_with pulseaudio} \
391         %{gyp_with system_ffmpeg} \
392         %{gyp_with system_flac} \
393         %{gyp_with system_harfbuzz} \
394         %{gyp_with system_libexif} \
395         %{gyp_with system_libmtp} \
396         %{gyp_with system_libsrtp} \
397         %{gyp_with system_libusb} \
398         %{gyp_with system_libvpx} \
399         %{gyp_with system_libwebp} \
400         %{gyp_with system_libxnvctrl} \
401         %{gyp_with system_minizip} \
402         %{gyp_with system_opus} \
403         %{gyp_with system_protobuf} \
404         %{gyp_with system_speex} \
405         %{gyp_with system_sqlite} \
406         %{gyp_with system_v8} \
407         %{gyp_with system_yasm} \
408         %{gyp_with system_zlib} \
409         -Duse_system_bzip2=1 \
410         -Duse_system_expat=1 \
411         -Duse_system_icu=1 \
412         -Duse_system_libevent=1 \
413         -Duse_system_libjpeg=1 \
414         -Duse_system_libpng=1 \
415         -Duse_system_libxml=1 \
416         -Duse_system_libxslt=1 \
417         -Duse_system_xdg_utils=1 \
418         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
419         -Dlinux_use_gold_binary=0 \
420         -Dlinux_use_gold_flags=0
421
422 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
423         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
424         %{?with_verbose:V=1} \
425         CC="%{__cc}" \
426         CXX="%{__cxx}" \
427         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
428         CC.host="%{__cc}" \
429         CXX.host="%{__cxx}" \
430         LDFLAGS.host="%{rpmldflags}" \
431         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
432         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
433
434 %install
435 rm -rf $RPM_BUILD_ROOT
436 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
437         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
438
439 cd out/%{!?debug:Release}%{?debug:Debug}
440 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
441 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
442 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
443 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
444 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
445 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
446 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
447 %if %{without system_ffmpeg}
448 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
449 %endif
450 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
451 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
452
453 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
454
455 %if %{with nacl}
456 # Install Native Client files on platforms that support it.
457 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
458 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
459 %ifarch %{x8664}
460 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
461 %endif
462 %ifarch %{ix86}
463 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
464 %endif
465 %endif
466
467 cd -
468
469 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
470         size=${icon##*/product_logo_}
471         size=${size%.png}
472
473         # this will skip non-numeric (22_mono_invert, 22_mono)
474         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
475         test -d "$dir" || continue
476
477         install -d $RPM_BUILD_ROOT$dir
478         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
479 done
480
481 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
482 # http://code.google.com/p/chromium/issues/detail?id=24507
483 gecko-mediaplayer*.so
484 EOF
485
486 # find locales
487 %find_lang %{name}.lang
488 # always package en-US
489 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
490
491 %clean
492 rm -rf $RPM_BUILD_ROOT
493
494 %post
495 %update_icon_cache hicolor
496 %update_desktop_database
497 %update_browser_plugins
498
499 %postun
500 if [ "$1" = 0 ]; then
501         %update_icon_cache hicolor
502         %update_browser_plugins
503 fi
504
505 %files
506 %defattr(644,root,root,755)
507 %doc src/{AUTHORS,LICENSE}
508 %{_browserpluginsconfdir}/browsers.d/%{name}.*
509 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
510 %dir %{_sysconfdir}/%{name}
511 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
512 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
513 %attr(755,root,root) %{_bindir}/%{name}
514 %{_mandir}/man1/%{name}.1*
515 %{_desktopdir}/*.desktop
516 %{_iconsdir}/hicolor/*/apps/%{name}.png
517 %dir %{_libdir}/%{name}
518 %{_libdir}/%{name}/chrome*.pak
519 %{_libdir}/%{name}/content_resources.pak
520 %{_libdir}/%{name}/resources.pak
521 %dir %{_libdir}/%{name}/locales
522 %{_libdir}/%{name}/locales/en-US.pak
523 %dir %{_libdir}/%{name}/resources
524 %{_libdir}/%{name}/resources/inspector
525 %dir %{_libdir}/%{name}/themes
526 %dir %{_libdir}/%{name}/extensions
527 %dir %{_libdir}/%{name}/plugins
528 %attr(755,root,root) %{_libdir}/%{name}/%{name}
529 # These unique permissions are intentional and necessary for the sandboxing
530 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
531
532 # ffmpeg libs
533 %if %{without system_ffmpeg}
534 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
535 %endif
536
537 %if %{with nacl}
538 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
539 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
540 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
541 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
542 %endif
543
544 %files l10n -f %{name}.lang
545 %defattr(644,root,root,755)
This page took 0.053468 seconds and 2 git commands to generate.