]> git.pld-linux.org Git - packages/cherokee.git/blob - cherokee.spec
aaed057b3b4f20501c14414d6919a26bcfd2a448
[packages/cherokee.git] / cherokee.spec
1 # TODO:
2 # - does it requires spawn-fcgi?
3 # - warning: Installed (but unpackaged) file(s) found:
4 #   /usr/share/locale/de/LC_MESSAGES/cherokee.mo
5 #   /usr/share/locale/en/LC_MESSAGES/cherokee.mo
6 #   /usr/share/locale/es/LC_MESSAGES/cherokee.mo
7 #   /usr/share/locale/nl/LC_MESSAGES/cherokee.mo
8 #   /usr/share/locale/sv_SE/LC_MESSAGES/cherokee.mo
9 #   /usr/share/locale/zh_CN/LC_MESSAGES/cherokee.mo
10 #
11 # Conditional build:
12 %bcond_without  geoip           # without GeoIP support
13 #
14 Summary:        Fast, Flexible and Lightweight Web server
15 Summary(pl.UTF-8):      Cherokee - serwer WWW
16 Name:           cherokee
17 Version:        0.99.29
18 Release:        0.1
19 License:        GPL v2
20 Group:          Networking/Daemons
21 Source0:        http://www.cherokee-project.com/download/0.99/%{version}/%{name}-%{version}.tar.gz
22 # Source0-md5:  236f17981c0c8908f6911fda239fc3a4
23 Source1:        %{name}.init
24 Source2:        %{name}.sysconfig
25 Patch0:         %{name}-config.patch
26 Patch1:         %{name}-php-path.patch
27 Patch2:         %{name}-panic_path.patch
28 URL:            http://www.cherokee-project.com/
29 %{?with_geoip:BuildRequires:    GeoIP-devel}
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  ffmpeg-devel
33 BuildRequires:  libtool
34 BuildRequires:  mysql-devel
35 BuildRequires:  openldap-devel
36 BuildRequires:  openssl-devel
37 BuildRequires:  pam-devel
38 BuildRequires:  pcre-devel
39 BuildRequires:  php-fcgi
40 BuildRequires:  pkgconfig
41 BuildRequires:  python-docutils
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.268
44 BuildRequires:  zlib-devel
45 Requires(post,preun):   rc-scripts
46 Requires(postun):       /usr/sbin/groupdel
47 Requires(postun):       /usr/sbin/userdel
48 Requires(pre):  /bin/id
49 Requires(pre):  /usr/bin/getgid
50 Requires(pre):  /usr/sbin/groupadd
51 Requires(pre):  /usr/sbin/useradd
52 Requires:       %{name}-libs = %{version}-%{release}
53 Suggests:       php-fcgi
54 Provides:       group(cherokee)
55 Provides:       group(http)
56 Provides:       user(cherokee)
57 Provides:       webserver
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _sysconfdir     /etc/cherokee
61 %define         _wwwhome        /home/services/%{name}
62 %define         _wwwroot        %{_wwwhome}/html
63
64 %description
65 Cherokee is a flexible, very fast, lightweight Web server. It is
66 implemented entirely in C, and has no dependencies beyond a standard C
67 library. It is embeddable and extensible with plug-ins. It supports
68 on-the-fly configuration by reading files or strings, TLS/SSL via
69 OpenSSL, virtual hosts, authentication, cache friendly features, PHP,
70 custom error management, and much more.
71
72 %description -l pl.UTF-8
73 Cherokee to elastyczny, bardzo szybki i lekki serwer WWW. Jest
74 zaimplementowany całkowicie w C i nie ma zależności poza standardową
75 biblioteką C. Jest osadzalny i rozbudowywalny poprzez wtyczki.
76 Obsługuje konfigurację w locie poprzez odczyt plików lub łańcuchów
77 znaków, TLS/SSL poprzez OpenSSL, hosty wirtualne, uwierzytelnianie,
78 opcje związane z pamięcią podręczną, PHP, własne zarządzanie błędami i
79 wiele więcej.
80
81 %package libs
82 Summary:        Cherokee web server libraries
83 Summary(pl.UTF-8):      Biblioteki serwera WWW Cherokee
84 Group:          Libraries
85
86 %description libs
87 Cherokee web server libraries.
88
89 %description libs -l pl.UTF-8
90 Biblioteki serwera WWW Cherokee.
91
92 %package devel
93 Summary:        Header files for Cherokee web server
94 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera WWW Cherokee
95 Group:          Development/Libraries
96 Requires:       %{name}-libs = %{version}-%{release}
97
98 %description devel
99 Header files for Cherokee web server.
100
101 %description devel -l pl.UTF-8
102 Pliki nagłówkowe dla serwera WWW Cherokee.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109
110 %build
111 %{__libtoolize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 export PHPCGI=%{_bindir}/php.fcgi
117 %configure \
118         --disable-static \
119         --enable-os-string="PLD Linux" \
120         --sysconfdir=/etc \
121         --with-wwwroot=%{_wwwroot} \
122         --with-wwwuser=cherokee \
123         --with-wwwgroup=http \
124         %{!?with_geoip:--without-geoip}
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{/etc/{pam.d,sysconfig,rc.d/init.d},/var/log/%{name}}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
135 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
136
137 # users don't need this
138 mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee-panic
139
140 # modules dlopened by *.so
141 rm -f $RPM_BUILD_ROOT%{_libdir}/cherokee/lib*.la
142
143 # unify manual dir
144 rm -rf html
145 mv $RPM_BUILD_ROOT%{_docdir}/%{name} html
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %pre
151 %groupadd -g 161 cherokee
152 %groupadd -g 51 http
153 %useradd -u 161 -d %{_wwwhome} -c "Cherokee User" -g cherokee cherokee
154 %addusertogroup cherokee http
155
156 %post
157 /sbin/chkconfig --add %{name}
158 %service %{name} restart "Cherokee webserver"
159 exit 0
160
161 %preun
162 if [ "$1" = "0" ]; then
163         %service %{name} stop
164         /sbin/chkconfig --del %{name}
165 fi
166
167 %postun
168 if [ "$1" = "0" ]; then
169         %userremove cherokee
170         %groupremove cherokee
171         %groupremove http
172 fi
173
174 %post   libs -p /sbin/ldconfig
175 %postun libs -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %doc AUTHORS ChangeLog html contrib/*to*.py
180 %dir %attr(750,root,root) %{_sysconfdir}
181 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cherokee.conf
182
183 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/cherokee
184 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cherokee
185 %attr(754,root,root) /etc/rc.d/init.d/cherokee
186
187 %attr(755,root,root) %{_bindir}/cget
188 %attr(755,root,root) %{_bindir}/cherokee-tweak
189 %attr(755,root,root) %{_sbindir}/cherokee
190 %attr(755,root,root) %{_sbindir}/cherokee-admin
191 %attr(755,root,root) %{_sbindir}/cherokee-panic
192 %attr(755,root,root) %{_sbindir}/cherokee-worker
193
194 %dir %{_libdir}/cherokee
195 %attr(755,root,root) %{_libdir}/cherokee/libplugin_admin.so
196 %attr(755,root,root) %{_libdir}/cherokee/libplugin_and.so
197 %attr(755,root,root) %{_libdir}/cherokee/libplugin_authlist.so
198 %attr(755,root,root) %{_libdir}/cherokee/libplugin_bind.so
199 %attr(755,root,root) %{_libdir}/cherokee/libplugin_cgi.so
200 %attr(755,root,root) %{_libdir}/cherokee/libplugin_combined.so
201 %attr(755,root,root) %{_libdir}/cherokee/libplugin_common.so
202 %attr(755,root,root) %{_libdir}/cherokee/libplugin_custom_error.so
203 %attr(755,root,root) %{_libdir}/cherokee/libplugin_custom.so
204 %attr(755,root,root) %{_libdir}/cherokee/libplugin_dbslayer.so
205 %attr(755,root,root) %{_libdir}/cherokee/libplugin_deflate.so
206 %attr(755,root,root) %{_libdir}/cherokee/libplugin_directory.so
207 %attr(755,root,root) %{_libdir}/cherokee/libplugin_dirlist.so
208 %attr(755,root,root) %{_libdir}/cherokee/libplugin_empty_gif.so
209 %attr(755,root,root) %{_libdir}/cherokee/libplugin_error_nn.so
210 %attr(755,root,root) %{_libdir}/cherokee/libplugin_error_redir.so
211 %attr(755,root,root) %{_libdir}/cherokee/libplugin_evhost.so
212 %attr(755,root,root) %{_libdir}/cherokee/libplugin_exists.so
213 %attr(755,root,root) %{_libdir}/cherokee/libplugin_extensions.so
214 %attr(755,root,root) %{_libdir}/cherokee/libplugin_fastcgi.so
215 %attr(755,root,root) %{_libdir}/cherokee/libplugin_fcgi.so
216 %attr(755,root,root) %{_libdir}/cherokee/libplugin_file.so
217 %attr(755,root,root) %{_libdir}/cherokee/libplugin_from.so
218 %attr(755,root,root) %{_libdir}/cherokee/libplugin_fullpath.so
219 %{?with_geoip:%attr(755,root,root) %{_libdir}/cherokee/libplugin_geoip.so}
220 %attr(755,root,root) %{_libdir}/cherokee/libplugin_gzip.so
221 %attr(755,root,root) %{_libdir}/cherokee/libplugin_header.so
222 %attr(755,root,root) %{_libdir}/cherokee/libplugin_htdigest.so
223 %attr(755,root,root) %{_libdir}/cherokee/libplugin_htpasswd.so
224 %attr(755,root,root) %{_libdir}/cherokee/libplugin_ip_hash.so
225 %attr(755,root,root) %{_libdir}/cherokee/libplugin_ldap.so
226 %attr(755,root,root) %{_libdir}/cherokee/libplugin_libssl.so
227 %attr(755,root,root) %{_libdir}/cherokee/libplugin_method.so
228 %attr(755,root,root) %{_libdir}/cherokee/libplugin_mysql.so
229 %attr(755,root,root) %{_libdir}/cherokee/libplugin_ncsa.so
230 %attr(755,root,root) %{_libdir}/cherokee/libplugin_not.so
231 %attr(755,root,root) %{_libdir}/cherokee/libplugin_or.so
232 %attr(755,root,root) %{_libdir}/cherokee/libplugin_pam.so
233 %attr(755,root,root) %{_libdir}/cherokee/libplugin_plain.so
234 %attr(755,root,root) %{_libdir}/cherokee/libplugin_proxy.so
235 %attr(755,root,root) %{_libdir}/cherokee/libplugin_redir.so
236 %attr(755,root,root) %{_libdir}/cherokee/libplugin_rehost.so
237 %attr(755,root,root) %{_libdir}/cherokee/libplugin_render_rrd.so
238 %attr(755,root,root) %{_libdir}/cherokee/libplugin_request.so
239 %attr(755,root,root) %{_libdir}/cherokee/libplugin_round_robin.so
240 %attr(755,root,root) %{_libdir}/cherokee/libplugin_rrd.so
241 %attr(755,root,root) %{_libdir}/cherokee/libplugin_scgi.so
242 %attr(755,root,root) %{_libdir}/cherokee/libplugin_secdownload.so
243 %attr(755,root,root) %{_libdir}/cherokee/libplugin_server_info.so
244 %attr(755,root,root) %{_libdir}/cherokee/libplugin_ssi.so
245 %attr(755,root,root) %{_libdir}/cherokee/libplugin_streaming.so
246 %attr(755,root,root) %{_libdir}/cherokee/libplugin_target_ip.so
247 %attr(755,root,root) %{_libdir}/cherokee/libplugin_uwsgi.so
248 %attr(755,root,root) %{_libdir}/cherokee/libplugin_wildcard.so
249
250 %{_mandir}/man1/cget.1*
251 %{_mandir}/man1/cherokee.1*
252 %{_mandir}/man1/cherokee-admin.1*
253 %{_mandir}/man1/cherokee-tweak.1*
254 %{_mandir}/man1/cherokee-worker.1*
255
256 %dir %{_datadir}/cherokee
257 %dir %{_datadir}/cherokee/admin
258 %{_datadir}/cherokee/admin/cherokee.conf.sample
259 %{_datadir}/cherokee/admin/performance.conf.sample
260 %{_datadir}/cherokee/admin/*.html
261 %attr(755,root,root) %{_datadir}/cherokee/admin/*.py
262 %{_datadir}/cherokee/admin/static
263 %{_datadir}/cherokee/deps
264 %{_datadir}/cherokee/icons
265 %{_datadir}/cherokee/themes
266
267 %dir %{_wwwhome}
268 %dir %{_wwwroot}
269 %config(missingok) %{_wwwroot}/*
270
271 %dir %attr(750,cherokee,logs) /var/log/%{name}
272
273 %files libs
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_libdir}/libcherokee-base.so.*.*.*
276 %attr(755,root,root) %ghost %{_libdir}/libcherokee-base.so.0
277 %attr(755,root,root) %{_libdir}/libcherokee-client.so.*.*.*
278 %attr(755,root,root) %ghost %{_libdir}/libcherokee-client.so.0
279 %attr(755,root,root) %{_libdir}/libcherokee-config.so.*.*.*
280 %attr(755,root,root) %ghost %{_libdir}/libcherokee-config.so.0
281 %attr(755,root,root) %{_libdir}/libcherokee-server.so.*.*.*
282 %attr(755,root,root) %ghost %{_libdir}/libcherokee-server.so.0
283
284 %files devel
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_bindir}/cherokee-config
287 %attr(755,root,root) %{_libdir}/libcherokee-base.so
288 %attr(755,root,root) %{_libdir}/libcherokee-client.so
289 %attr(755,root,root) %{_libdir}/libcherokee-config.so
290 %attr(755,root,root) %{_libdir}/libcherokee-server.so
291 %{_libdir}/libcherokee-base.la
292 %{_libdir}/libcherokee-client.la
293 %{_libdir}/libcherokee-config.la
294 %{_libdir}/libcherokee-server.la
295 %{_includedir}/cherokee
296 %{_pkgconfigdir}/cherokee.pc
297 %{_aclocaldir}/cherokee.m4
298 %{_mandir}/man1/cherokee-config.1*
This page took 0.088412 seconds and 3 git commands to generate.