]> git.pld-linux.org Git - packages/charles.git/blob - charles.spec
- use _rel macro
[packages/charles.git] / charles.spec
1
2 %include        /usr/lib/rpm/macros.java
3
4 %define         _rel    0.1
5
6 # I have no access to full version, so I'm packaging trial version only.
7 # If you have full tarball, add with(out?)_trial bcond
8 %define         with_trial 1
9
10 Summary:        Web debugging proxy application
11 Name:           charles
12 Version:        3.4.1
13 Release:        %{_rel}%{?with_trial:trial}
14 License:        Proprietary, not distributable
15 Group:          Development/Languages/Java
16 Source0:        %{name}.tar.gz
17 # Source0-md5:  bcab2cd381d8f5ae9ffed08a0a89b76d
18 NoSource:       0
19 Source1:        %{name}.sh
20 URL:            http://www.charlesproxy.com/
21 BuildRequires:  jpackage-utils
22 BuildRequires:  rpm-javaprov
23 BuildRequires:  rpmbuild(macros) >= 1.300
24 Requires:       jpackage-utils
25 Requires:       jre-X11
26 ExclusiveArch:  %{ix86}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Charles is an HTTP proxy / HTTP monitor / Reverse Proxy that enables a
31 developer to view all of the HTTP and SSL / HTTPS traffic between
32 their machine and the Internet. This includes requests, responses and
33 the HTTP headers (which contain the cookies and caching information).
34
35 %prep
36 %setup -q -n %{name}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_javadir}/%{name},%{_libdir}/%{name},%{_bindir}}
41
42 cp -a lib/*jar $RPM_BUILD_ROOT%{_javadir}/%{name}
43 cp -a lib/*so $RPM_BUILD_ROOT%{_libdir}/%{name}
44 cp -a %{SOURCE1} $RPM_BUILD_ROOT/%{_bindir}/%{name}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %{_javadir}/%{name}
52 %{_libdir}/%{name}
53 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.041461 seconds and 3 git commands to generate.