]> git.pld-linux.org Git - packages/cfitsio.git/blob - cfitsio.spec
- updated to 4.3.1
[packages/cfitsio.git] / cfitsio.spec
1 # TODO: gsiftp support?
2 Summary:        CFITSIO Interface Library
3 Summary(pl.UTF-8):      Biblioteka interfejsu CFITSIO
4 Name:           cfitsio
5 Version:        4.3.1
6 Release:        1
7 License:        MIT-like
8 Group:          Libraries
9 Source0:        https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/%{name}-%{version}.tar.gz
10 # Source0-md5:  3f63226f70477b62975102bc68c94338
11 Patch1:         %{name}-ldflags.patch
12 URL:            https://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
13 BuildRequires:  autoconf
14 BuildRequires:  bzip2-devel
15 BuildRequires:  curl-devel
16 BuildRequires:  gcc-g77
17 BuildRequires:  zlib-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 CFITSIO is a library of ANSI C routines for reading and writing FITS
22 format data files.  A set of Fortran-callable wrapper routines are
23 also included for the convenience of Fortran programmers.
24
25 %description -l pl.UTF-8
26 CFITSIO to biblioteka funkcji w C do odczytu i zapisu plików z danymi
27 w formacie FITS. Zawiera także zestaw wrapperów pozwalających na
28 wywoływanie tych funkcji z programów w Fortranie.
29
30 %package devel
31 Summary:        Header files and documentation for CFITSIO
32 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do CFITSIO
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       zlib-devel
36
37 %description devel
38 Header files and development documentation for CFITSIO.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe i dokumentacja programisty do CFITSIO.
42
43 %package static
44 Summary:        Static CFITSIO library
45 Summary(pl.UTF-8):      Statyczna biblioteka CFITSIO
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static version of CFITSIO library.
51
52 %description static -l pl.UTF-8
53 Statyczna wersja biblioteki CFITSIO.
54
55 %prep
56 %setup -q
57 %patch1 -p1
58
59 %build
60 %{__autoconf}
61 %configure \
62         --with-bzip2
63
64 %{__make} shared
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
69
70 %{__make} install \
71         CFITSIO_LIB=$RPM_BUILD_ROOT%{_libdir} \
72         CFITSIO_INCLUDE=$RPM_BUILD_ROOT%{_includedir}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc License.txt README docs/changes.txt
83 %attr(755,root,root) %{_libdir}/libcfitsio.so.*.*.*
84 %attr(755,root,root) %ghost %{_libdir}/libcfitsio.so.10
85
86 %files devel
87 %defattr(644,root,root,755)
88 %doc docs/{cfortran.doc,cfitsio.ps,fitsio.doc,fitsio.ps,quick.ps}
89 %attr(755,root,root) %{_libdir}/libcfitsio.so
90 %{_includedir}/drvrsmem.h
91 %{_includedir}/fitsio*.h
92 %{_includedir}/longnam.h
93 %{_pkgconfigdir}/cfitsio.pc
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libcfitsio.a
This page took 0.041451 seconds and 4 git commands to generate.