]> git.pld-linux.org Git - packages/cfitsio.git/blob - cfitsio.spec
- updated to 3.450 (security fixes, new soname)
[packages/cfitsio.git] / cfitsio.spec
1 # TODO: gsiftp support?
2 Summary:        CFITSIO Interface Library
3 Summary(pl.UTF-8):      Biblioteka interfejsu CFITSIO
4 Name:           cfitsio
5 Version:        3.450
6 %define sver    %(echo %{version} | tr -d .)
7 Release:        1
8 License:        MIT-like
9 Group:          Libraries
10 Source0:        https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/%{name}%{sver}.tar.gz
11 # Source0-md5:  f470849bb43561d9a9b1925eeb7f7f0d
12 Patch0:         %{name}-zlib.patch
13 Patch1:         %{name}-ldflags.patch
14 URL:            https://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
15 BuildRequires:  autoconf
16 BuildRequires:  bzip2-devel
17 BuildRequires:  curl-devel
18 BuildRequires:  gcc-g77
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 CFITSIO is a library of ANSI C routines for reading and writing FITS
24 format data files.  A set of Fortran-callable wrapper routines are
25 also included for the convenience of Fortran programmers.
26
27 %description -l pl.UTF-8
28 CFITSIO to biblioteka funkcji w C do odczytu i zapisu plików z danymi
29 w formacie FITS. Zawiera także zestaw wrapperów pozwalających na
30 wywoływanie tych funkcji z programów w Fortranie.
31
32 %package devel
33 Summary:        Header files and documentation for CFITSIO
34 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do CFITSIO
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       zlib-devel
38
39 %description devel
40 Header files and development documentation for CFITSIO.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe i dokumentacja programisty do CFITSIO.
44
45 %package static
46 Summary:        Static CFITSIO library
47 Summary(pl.UTF-8):      Statyczna biblioteka CFITSIO
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static version of CFITSIO library.
53
54 %description static -l pl.UTF-8
55 Statyczna wersja biblioteki CFITSIO.
56
57 %prep
58 %setup -q -n %{name}
59 %patch0 -p1
60 %patch1 -p1
61
62 # enforce headers from system zlib
63 %{__rm} zlib/{crc32.h,deflate.h,inffast.h,inffixed.h,inflate.h,inftrees.h,zconf.h,zlib.h,zutil.h}
64
65 %build
66 %{__autoconf}
67 %configure \
68         --with-bzip2
69
70 %{__make} shared
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
75
76 %{__make} install \
77         CFITSIO_LIB=$RPM_BUILD_ROOT%{_libdir} \
78         CFITSIO_INCLUDE=$RPM_BUILD_ROOT%{_includedir}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc License.txt README docs/changes.txt
89 %attr(755,root,root) %{_libdir}/libcfitsio.so.*.*.*
90 %attr(755,root,root) %ghost %{_libdir}/libcfitsio.so.7
91
92 %files devel
93 %defattr(644,root,root,755)
94 %doc docs/{cfortran.doc,cfitsio.ps,fitsio.doc,fitsio.ps,quick.ps}
95 %attr(755,root,root) %{_libdir}/libcfitsio.so
96 %{_includedir}/drvrsmem.h
97 %{_includedir}/fitsio*.h
98 %{_includedir}/longnam.h
99 %{_pkgconfigdir}/cfitsio.pc
100
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libcfitsio.a
This page took 0.041907 seconds and 4 git commands to generate.